Opened 14 years ago

Closed 14 years ago

#10966 closed defect (fixed)

gpgme does not build

Reported by: luke-macports@… Owned by: yeled@…
Priority: High Milestone:
Component: ports Version:
Keywords: Cc:
Port:

Description

pomme:~/src/gaim.my lukeschierer$ sudo port clean gpgme ---> Cleaning gpgme pomme:~/src/gaim.my lukeschierer$ sudo port upgrade gpgme ---> Activating gpgme 1.1.2_1 ---> Deactivating gpgme 1.1.2_1 ---> Fetching gpgme ---> Verifying checksum(s) for gpgme ---> Extracting gpgme ---> Applying patches to gpgme Error: Target com.apple.patch returned: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_devel_gpgme/work/gpgme-1.1.2" && patch -p0 < "/opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/devel/gpgme/files/patch-assuan_assuan.h"" returned error 1 Command output: patching file assuan/assuan.h Reversed (or previously applied) patch detected! Assume -R? [n] Apply anyway? [n] Skipping patch. 1 out of 1 hunk ignored -- saving rejects to file assuan/assuan.h.rej

pomme:~/src/gaim.my lukeschierer$

Change History (2)

comment:1 Changed 14 years ago by takanori@…

I've confirmed this problem.

It looks like "variant darwin {...}" is explained twice when calling "port upgrade gpgme". This may be a bug in MacPorts.

Anyway, I'll rewrite the Portfile to avoid this issue. Thank you for reporting.

comment:2 Changed 14 years ago by markd@…

Resolution: fixed
Status: newclosed

This has been fixed.

Note: See TracTickets for help on using tickets.