Opened 14 years ago

Closed 14 years ago

#11005 closed defect (fixed)

rb-postgres depends on postgresql8, not postgresql81

Reported by: jon.olsson@… Owned by: macports-tickets@…
Priority: High Milestone:
Component: ports Version:
Keywords: Cc:
Port:

Description

As stated in the Portfile for postgresql8:

This port is here just for compatibility. 
To set up a database server or for new or updated port
dependencies, please use postgresql81.

Patch:

--- Portfile.orig       2006-11-07 15:32:47.000000000 +0100
+++ Portfile    2006-11-07 15:32:58.000000000 +0100
@@ -15,7 +15,7 @@
 checksums              md5 8ef67b3f4b089248f0420baeb0e3b3c8
 platforms              darwin
 
-depends_lib-append             port:postgresql8
+depends_lib-append             port:postgresql81
 
 configure.args-append  --with-pgsql-include-dir=${prefix}/include/pgsql8 \
                                                --with-pgsql-lib-dir=${prefix}/lib/pgsql8

Change History (2)

comment:1 Changed 14 years ago by jon.olsson@…

Oops.. this is the correct patch:

--- Portfile.orig       2006-11-07 15:32:47.000000000 +0100
+++ Portfile    2006-11-07 15:38:16.000000000 +0100
@@ -15,10 +15,10 @@
 checksums              md5 8ef67b3f4b089248f0420baeb0e3b3c8
 platforms              darwin
 
-depends_lib-append             port:postgresql8
+depends_lib-append             port:postgresql81
 
 configure.args-append  --with-pgsql-include-dir=${prefix}/include/pgsql8 \
                                                --with-pgsql-lib-dir=${prefix}/lib/pgsql8
 configure.env \
-       POSTGRES_LIB="${prefix}/lib/pgsql8 -L${prefix}/lib -lssl -lcrypto" \
-       POSTGRES_INCLUDE="${prefix}/include/pgsql8 -I${prefix}/include"
+       POSTGRES_LIB="${prefix}/lib/postgresql81 -L${prefix}/lib -lssl -lcrypto" \
+       POSTGRES_INCLUDE="${prefix}/include/postgresql81 -I${prefix}/include"

comment:2 Changed 14 years ago by pguyot (Paul Guyot)

Resolution: fixed
Status: newclosed

Committed.

Note: See TracTickets for help on using tickets.