Opened 14 years ago

Closed 14 years ago

#11043 closed defect (fixed)

[New] dports/devel/svk-devel @1.99_91

Reported by: mark@… Owned by: danielluke (Daniel J. Luke)
Priority: High Milestone:
Component: ports Version:
Keywords: dluke@macports.org Cc: narf_tm@…, michaelm@…
Port:

Description

svk-1.99_03 - Technology Preview 3

Some highlights include (taken from TP1 notes):

  • Interactive commits

You can now use "svk commit --interactive". svk will work you through each chunk of changes in each file, and let you decide exactly which ones you want to commit.

  • Floating checkout

You can now use "svk checkout --float" to have the checkout metadata stored in the toplevel directory of the checkout copy. This allows you to move the checkout copy around without having to use "svk checkout --relocate".

  • View support

svk's "views" are much like views in databases. You can now set up a "view" that is actually a map to different parts of a repository. You can then check out the "view" and work with it as if it's just an ordinary svk checkout path.

Please note that this feature is still of beta-quality; some commands do not work properly in view checkouts. We plan to fix them before the tp2 release.

  • Log filter plugins

You can now write custom log processing plugins for filtering and displaying log messages; svk ships with several, and others are available on CPAN. For example, try "svk log --filter 'author clkao'" or "svk log --output stat" (the latter requires SVK::Log::Filter::Stats from CPAN).

  • Better copy and rename support across merge.

This solves the problem described in:

http://svn.haxx.se/dev/archive-2005-08/0712.shtml

  • Startup time improvements

  • Many, many bugfixes and tiny features

Attachments (4)

dports_devel_svk-devel.patch (1.9 KB) - added by mark@… 14 years ago.
Portfile
dports_devel_svk-devel_1_99_04 (1.8 KB) - added by mark@… 14 years ago.
Portfile
dports_devel_svk-devel_1_99_05 (1.9 KB) - added by mgrimes@… 14 years ago.
dports_devel_svk-devel_1_99_91 (1.9 KB) - added by mgrimes@… 14 years ago.

Download all attachments as: .zip

Change History (12)

Changed 14 years ago by mark@…

Portfile

Changed 14 years ago by mark@…

Portfile

comment:1 Changed 14 years ago by mark@…

Added 1.99_04 (or SVK 2.0 beta 1) Portfile as a reference for rolling into svk come release. Well tested.

comment:2 Changed 14 years ago by danielluke (Daniel J. Luke)

Cc: narf_tm@… added

This portfile doesn't work correctly because svk doesn't see the newer File::Temp and tries to download it (as far as I know, perl searches the vendor install location last, and so stops searching for File::Temp once it finds the distro-version).

p5-pathtools overcomes this problem by overwriting the perl-supplied PathTools (and therefore needs the force flag to install).

Alternate ideas on how to deal with this are welcome.

Changed 14 years ago by mgrimes@…

comment:3 Changed 14 years ago by mgrimes@…

Keywords: dluke@macports.org added
Priority: Nice to haveImportant
Summary: [New] dports/devel/svk-devel @1.99_03[New] dports/devel/svk-devel @1.99_05
Type: enhancementdefect

Confirmed, and there seems to be no alternative approach to handling this so I have changed the p5-file-temp Portfile to reflect the same approach as p5-pathtools and submitted as #11175 -- Additionally I've nudged the diff on this ticket to reflect svk 1.99_05 (aka 2.0rc1)

comment:4 Changed 14 years ago by narf_tm@…

I believe a more appropriate fix would be to change the "perl5.8" port so that the default @INC paths have the vendor paths are first. If you look at the order of @INC it doesn't really make sense... I actually believe it should be vendor, site then base.

perl -e "print join \"\n\", @INC"

/opt/local/lib/perl5/5.8.8/darwin-2level
/opt/local/lib/perl5/5.8.8
/opt/local/lib/perl5/site_perl/5.8.8/darwin-2level
/opt/local/lib/perl5/site_perl/5.8.8
/opt/local/lib/perl5/site_perl
/opt/local/lib/perl5/vendor_perl/5.8.8/darwin-2level
/opt/local/lib/perl5/vendor_perl/5.8.8
/opt/local/lib/perl5/vendor_perl

Having all these ports force install over the "perl5.8" port just seems like bad practice. There is a lib hierarchy for a reason.

comment:5 Changed 14 years ago by danielluke (Daniel J. Luke)

The hierarchy should probably be site, vendor, then base (so that local modifications take precedence, over all, and vendor can override dist) ...

... but, that would make dp-provided perl different from 'normal' perl as it appears everywhere else.

comment:6 Changed 14 years ago by mgrimes@…

Cc: michaelm@… added

Standard practice from the perl community is disgustingly replacing perl-core modules with newer counterparts, so I figured I'd run with it for now since this @INC problem and p5-pathtools implementation exists -- now that we have 2 (?) ports that are affecting perl5.8, it's definitely a good idea to hash out the Perl infrastructure changes now as this can only increase so long as our Perl remains at 5.8.8 and CPAN modules continue to update. -- I admit my interest in Perl stems around my crack-like obsession over svk, so I appreciate the feedback from people whom probably actually use Perl perhaps -- but I'm not opposed to learning and tossing you guys failed ideas so long as we're making progress toward a solution. The @INC suggestion sits a lot better with me then overwriting other ports install base. Entirely in agreement about the @INC ordering (site, vendor, perl).

Changed 14 years ago by mgrimes@…

comment:7 Changed 14 years ago by mgrimes@…

Summary: [New] dports/devel/svk-devel @1.99_05[New] dports/devel/svk-devel @1.99_91

Nudge portfile for testing to svk2 release candidate 2 (1.99_91)

comment:8 Changed 14 years ago by danielluke (Daniel J. Luke)

Resolution: fixed
Status: newclosed

Since svk 2.0.0 final has been released, I'll be updating the svk port shortly.

Thanks for your work on this.

Note: See TracTickets for help on using tickets.