Opened 17 years ago

Closed 17 years ago

Last modified 16 years ago

#1108 closed defect (invalid)

gimp doesn't build on Panther

Reported by: olaf@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: fkr@…
Port:

Description

Several problems appear:

$ sudo port install gimp Password: ---> Configuring gimp Error: Target com.apple.configure returned: configure failure: shell command "cd "/Volumes/ufs/projects/darwinports/darwinports/dports/graphics/gimp/work/gimp-1.2.5" && PATH=${PATH}:/opt/local/bin CPPFLAGS=-I/opt/local/include ./configure --prefix=/opt/local --disable-print --disable-perl --mandir=/opt/local/share/man" returned error 1 Command output: checking for tsearch... yes

$ cd "/Volumes/ufs/projects/darwinports/darwinports/dports/graphics/gimp/work/gimp-1.2.5"

$ PATH=${PATH}:/opt/local/bin CPPFLAGS=-I/opt/local/include ./configure --prefix=/opt/local --disable-print --disable-perl --mandir=/opt/local/share/man PATH=/sw/bin:/sw/sbin:/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/opt/local/bin:/usr/local/sbin:/Volumes/ufs/projects/jwsdp-1_0_01/bin:/opt/local/bin:/opt/local/sbin:/usr/X11R6/bin:/opt/local/bin: Command not found.

COMMENT: here it seems that the syntax doesn't work with tcsh ?

$ bash $ PATH=${PATH}:/opt/local/bin CPPFLAGS=-I/opt/local/include ./configure --prefix=/opt/local --disable-print --disable-perl --mandir=/opt/local/share/man ... checking for GTK - version >= 1.2.8... no * Could not run GTK test program, checking why... * The test program failed to compile or link. See the file config.log for the * exact error that occured. This usually means GTK was incorrectly installed * or that you have moved GTK since it was installed. In the latter case, you * may want to edit the gtk-config script: /opt/local/bin/gtk-config configure: error: Test for GTK failed. See the file 'INSTALL' for help.

$ sudo port deps gimp gimp has library dependencies on:

gtk gettext jpeg libpng tiff

Comment: port lists the dependency but gtk has not been build.

Change History (5)

comment:1 Changed 17 years ago by fkr@…

Cc: fkr@… added

builds fine on B85 here. Can anyone else reproduce this?

-fkr

comment:2 Changed 17 years ago by fkr@…

your system seems whacky. Have you installed any additional software like fink that might have messed up your box?

-fkr

comment:3 Changed 17 years ago by olaf@…

Yes, fink is installed. No. I'm not using it, I don't even have the init-files in my .bashrc. The problem seems to me that dp doesn't install all dependencies.

comment:4 Changed 17 years ago by olegb@…

Just for the record, gimp build/installs/works on 10.3.1 - if nobody else can reproduce this bug, i'll close it.

comment:5 Changed 17 years ago by fkr@…

Resolution: invalid
Status: newclosed

time to close this. please re-open if necessary.

Note: See TracTickets for help on using tickets.