Opened 17 years ago

Closed 17 years ago

Last modified 16 years ago

#1109 closed defect (invalid)

gtk lists glib as dependency but doesn't install it

Reported by: olaf@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

# port install gtk ---> Configuring gtk ... checking for glib-config... /opt/local/bin/glib-config checking for GLIB - version >= 1.2.8... no * Could not run GLIB test program, checking why... * The test program failed to compile or link. See the file config.log for the * exact error that occured. This usually means GLIB was incorrectly installed * or that you have moved GLIB since it was installed. In the latter case, you * may want to edit the glib-config script: /opt/local/bin/glib-config configure: error: * GLIB 1.2.8 or better is required. The latest version of GLIB * is always available from ftp://ftp.gtk.org/.

$ port deps gtk gtk has library dependencies on:

gettext glib XFree86

Change History (3)

comment:1 Changed 17 years ago by pguyot (Paul Guyot)

Actually, this is because you installed dlcompat in Jaguar and then you updated to Panther.

port uninstall glib port uninstall dlcompat port install gtk

will do it.

comment:2 Changed 17 years ago by olaf@…

O.k., this solved the bug for me.

Greetings Olaf

comment:3 Changed 17 years ago by blb@…

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.