Opened 17 years ago

Closed 17 years ago

Last modified 16 years ago

#1149 closed defect (wontfix)

libsdl fails to compile on Mac OS 10.3

Reported by: khalek@… Owned by: leimy@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

When trying to port install libsdl I get the following error:

gcc -DPACKAGE=\"SDL\" -DVERSION=\"1.2.6\" -DHAVE_ALLOCA_H=1 -DHAVE_ALLOCA=1 -I. -I. -no-cpp-precomp -I/System/Library/Frameworks/Kernel.framework/Headers/ -g -O2 -Wall -DENABLE_DUMMYVIDEO -DDISKAUD_SUPPORT -I/System/Library/Frameworks/ Carbon.framework/Headers -I/System/Library/Frameworks/Cocoa.framework/Headers -fpascal- strings -DENABLE_QUARTZ -DMACOSX -DTARGET_API_MAC_CARBON=1 -I../../../src/video/quartz -DHAVE_OPENGL -D_THREAD_SAFE -DSDL_USE_PTHREADS -DPTHREAD_NO_RECURSIVE_MUTEX -DHAVE_SEMUN -I../../../include -I../../../include/SDL -I../../../src -I../../../src/macosx -I../../../ src/main -I../../../src/audio -I../../../src/video -I../../../src/video/XFree86/extensions -I../../../ src/events -I../../../src/joystick -I../../../src/cdrom -I../../../src/thread -I../../../src/timer -I../../ ../src/endian -I../../../src/file -c SDL_sysjoystick.c -fno-common -DPIC -o .libs/ SDL_sysjoystick.lo In file included from SDL_sysjoystick.c:42: /System/Library/Frameworks/IOKit.framework/Headers/hid/IOHIDLib.h:260: redefinition of `IOHIDQueueInterface' /System/Library/Frameworks/IOKit.framework/Headers/hid/IOHIDLib.h:156: `IOHIDQueueInterface' previously declared here /System/Library/Frameworks/IOKit.framework/Headers/hid/IOHIDLib.h:291: redefinition of `IOHIDOutputTransactionInterface' /System/Library/Frameworks/IOKit.framework/Headers/hid/IOHIDLib.h:157: `IOHIDOutputTransactionInterface' previously declared here make[3]: * [SDL_sysjoystick.lo] Error 1 make[2]: * [all-recursive] Error 1 make[1]: * [all-recursive] Error 1 make: * [all-recursive] Error 1

Hopefully this is the right place to report this...

Change History (4)

comment:1 Changed 17 years ago by mww@…

Owner: changed from darwinports-bugs@… to leimy@…

this port works fine over here - at least I managed to install it...

Perhaps there are some {LD|C}FLAGS missing? Did you (Jonathan) set some in your terminal before using port?

comment:2 Changed 17 years ago by blb@…

Considering the odd nature of the error (and that in bug 1151), my first question is, did you upgrade the devtools when installing 10.3?

comment:3 Changed 17 years ago by khalek@…

Resolution: wontfix
Status: newclosed

This was with a fresh install of panther and xcode. It turns out the default compiler was set to gcc 2.95 instead of gcc 3.3, for reasons I don't know. Changing the default compiler to gcc 3.3 makes this compile fine. I have yet to try compiling an SDL app but I doubt I would have any problems doing so now.

As I assume 2.95 is unsupported I'm changing the status of this bug to WONTFIX

comment:4 Changed 17 years ago by blb@…

That's definitely weird that it'd pick 2.95.2 by default, but I can confirm both glib and libsdl fail to compile with 2.95.2.

Note: See TracTickets for help on using tickets.