Opened 17 years ago

Closed 17 years ago

Last modified 16 years ago

#1151 closed defect (wontfix)

glib fails to compile on Mac OS 10.3

Reported by: khalek@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

when trying to compile glib I get the following error:

gcc -dynamiclib -flat_namespace -undefined suppress -o .libs/libgthread-1.2.0.0.10.dylib gthread.lo -L/opt/local/lib -lpthread -lc -install_name /opt/local/lib/libgthread-1.2.0.dylib -compatibility_version 1 -current_version 1.10 ld: -undefined: unknown argument: -L/opt/local/lib /usr/bin/libtool: internal link edit command failed make[2]: * [libgthread.la] Error 1 make[1]: * [all-recursive] Error 1 make: * [all-recursive-am] Error 2

Change History (1)

comment:1 Changed 17 years ago by khalek@…

Resolution: wontfix
Status: newclosed

After a fresh install of panther and xcode, it turns out that the default compiler had been set to gcc 2.95, after changing it to 3.3 glib compiles fine.

As I assume gcc 2.95 isn't supported I'm changing the resolution of this bug to WONTFIX

See also bug #1149

Note: See TracTickets for help on using tickets.