Opened 14 years ago

Closed 13 years ago

Last modified 12 years ago

#11613 closed defect (fixed)

[BUG] fftw-3-single

Reported by: takeshi@… Owned by: skymoo (Adam Mercer)
Priority: Low Milestone:
Component: ports Version:
Keywords: Cc:
Port:

Description

fftw-3-sigle does not build on my MacBook Pro. I should fix this because I am the maintainer of fftw-3 and I need this for GDL. But the error below is beyond my ability.

gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I. -I.. -I../simd -O3 -fomit-frame-pointer -malign-double -fstrict-aliasing -ffast-math -march=pentiumpro -D_THREAD_SAFE -MT trig.lo -MD -MP -MF .deps/trig.Tpo -c trig.c -o trig.o

/var/tmpccMMtwDn.s:99:operands given don't match any known 386 instruction /var/tmpccMMtwDn.s:100:operands given don't match any known 386 instruction /var/tmpccMMtwDn.s:132:operands given don't match any known 386 instruction /var/tmpccMMtwDn.s:134:operands given don't match any known 386 instruction /var/tmpccMMtwDn.s:167:operands given don't match any known 386 instruction /var/tmpccMMtwDn.s:168:operands given don't match any known 386 instruction make[2]: * [trig.lo] Error 1 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

Attachments (1)

Portfile (2.4 KB) - added by takeshi@… 14 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 14 years ago by pipping@…

Milestone: Available Ports
Summary: fftw-3-single[BUG] fftw-3-single

comment:2 Changed 14 years ago by pipping@…

Milestone: Available PortsPort Bugs

comment:3 Changed 14 years ago by takeshi@…

I created a merged version fftw3 (temporary name) with the single build as a variant.

Changed 14 years ago by takeshi@…

Attachment: Portfile added

comment:4 Changed 14 years ago by roederja

Is this portfile supposed to be commited ?

comment:5 Changed 14 years ago by markd@…

It is already in the repository, but the build is broken. I don't know how to fix it either.

comment:6 Changed 14 years ago by bytestorm@…

I have built and installed fftw-3-single 3.1.2 on my system and can't reproduce this error. xcode 2.4.1, os 10.4.9, intel c2d.

comment:7 Changed 13 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to ram@…

comment:8 Changed 13 years ago by skymoo (Adam Mercer)

Status: newassigned

Is this still a problem?

comment:9 Changed 13 years ago by tenomoto (Takeshi Enomoto)

Resolution: fixed
Status: assignedclosed

I posted and forgot it. Sorry. It builds OK now.

comment:10 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.