Opened 13 years ago

Closed 13 years ago

#11685 closed defect (fixed)

Metacity depends on gconf but is not listed as dependancy

Reported by: piotr@… Owned by: rhwood@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: metacity gconf dependancy dep Cc: rhwood@…
Port:

Description

When trying to install metacity I encountered the next error (during 'configure' fase of the build):

checking for METACITY... configure: error: Package requirements (gtk+-2.0 >= 2.10.0 pango >= 1.2.0 gconf-2.0 >= 1.2.0 libstartup-notification-1.0 >= 0.7 xrender >= 0.0) were not met.

After installed gconf manually the installation of metacity succeeded. The metacity portfile contains:

depends_lib \

port:startup-notification \ port:gnome-themes

It supose it should have gconf listed too, I'm not sure about gtk, pango and xrender.

Change History (2)

comment:1 Changed 13 years ago by markd@…

Cc: rhwood@… added
Owner: changed from macports-dev@… to rhwood@…

Assign to maintainer.

comment:2 Changed 13 years ago by rhwood@…

Resolution: fixed
Status: newclosed
Version: 1.4

Commited in changeset:23437 Thanks.

Note: See TracTickets for help on using tickets.