Opened 11 years ago

Closed 10 years ago

Last modified 8 years ago

#11895 closed defect (fixed)

qt3-mac 3.3.8_0 building problem

Reported by: s1590001@… Owned by: blair (Blair Zajac)
Priority: Normal Milestone: MacPorts 1.6
Component: base Version: 1.4.3
Keywords: qt qt3-mac Cc: s1590001@…, blair (Blair Zajac), markd@…, ryandesign (Ryan Schmidt)
Port:

Description

I tried to install qt-mac 3.3.8 by MacPorts. During the building progress it reported the following error messages: It seems like some files are missing?

(in interactive mode)

[Users/mac] > install qt3-mac    
--->  Fetching perl5.8
--->  Attempting to fetch perl-5.8.8.tar.bz2 from http://www.cpan.org/src/5.0/
--->  Verifying checksum(s) for perl5.8
--->  Extracting perl5.8
--->  Applying patches to perl5.8
--->  Configuring perl5.8
--->  Building perl5.8 with target all
--->  Staging perl5.8 into destroot
--->  Installing perl5.8 5.8.8_0+darwin_8
--->  Activating perl5.8 5.8.8_0+darwin_8
--->  Cleaning perl5.8
--->  Fetching autoconf
--->  Attempting to fetch autoconf-2.61.tar.bz2 from http://ftp.gnu.org/gnu/autoconf
--->  Verifying checksum(s) for autoconf
--->  Extracting autoconf
--->  Configuring autoconf
--->  Building autoconf with target all
--->  Staging autoconf into destroot
--->  Installing autoconf 2.61_0
--->  Activating autoconf 2.61_0
--->  Cleaning autoconf
--->  Fetching automake
--->  Attempting to fetch automake-1.10.tar.bz2 from http://ftp.gnu.org/gnu/automake
--->  Verifying checksum(s) for automake
--->  Extracting automake
--->  Configuring automake
--->  Building automake with target all
--->  Staging automake into destroot
--->  Installing automake 1.10_0
--->  Activating automake 1.10_0
--->  Cleaning automake
--->  Fetching lcms
--->  Attempting to fetch lcms-1.15.tar.gz from http://www.littlecms.com/
--->  Verifying checksum(s) for lcms
--->  Extracting lcms
--->  Configuring lcms
--->  Building lcms with target all
--->  Staging lcms into destroot
--->  Installing lcms 1.15_0
--->  Activating lcms 1.15_0
--->  Cleaning lcms
--->  Fetching libtool
--->  Attempting to fetch libtool-1.5.22.tar.gz from http://ftp.gnu.org/gnu/libtool
--->  Verifying checksum(s) for libtool
--->  Extracting libtool
--->  Configuring libtool
--->  Building libtool with target all
--->  Staging libtool into destroot
--->  Installing libtool 1.5.22_0
--->  Activating libtool 1.5.22_0
--->  Cleaning libtool
--->  Fetching libmng
--->  Attempting to fetch libmng-1.0.9.tar.gz from http://downloads.sourceforge.net/libmng
--->  Verifying checksum(s) for libmng
--->  Extracting libmng
--->  Configuring libmng
--->  Building libmng with target all
--->  Staging libmng into destroot
--->  Installing libmng 1.0.9_0
--->  Activating libmng 1.0.9_0
--->  Cleaning libmng
--->  Fetching qt3-mac
--->  Attempting to fetch qt-mac-free-3.3.8.tar.gz from ftp://ftp.trolltech.com/qt/source/
--->  Verifying checksum(s) for qt3-mac
--->  Extracting qt3-mac
--->  Applying patches to qt3-mac
--->  Configuring qt3-mac
--->  Building qt3-mac with target symlinks src-qmake src-moc sub-src sub-tools
Error: Target com.apple.build returned: shell command " cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_aqua_qt3-mac/work/qt-mac-free-3.3.8" && make symlinks src-qmake src-moc sub-src sub-tools " returned error 2
Command output: ../interfaces/languageinterface.h:55: warning: 'struct LanguageInterface' has virtual functions but non-virtual destructor
../../../include/private/qwidgetinterface_p.h:74: warning: 'struct QWidgetFactoryInterface' has virtual functions but non-virtual destructor
../../../include/qsqldatabase.h:63: warning: 'class QSqlDriverCreatorBase' has virtual functions but non-virtual destructor
c++ -c -pipe -I/opt/local/include -Wall -W -Os -fPIC  -DQT_INTERNAL_XML -DQ_TEMPLATE_EXTERN=extern -DRESOURCE -DQT_ACCESSIBILITY_SUPPORT -DQT_TABLET_SUPPORT -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -I/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_aqua_qt3-mac/work/qt-mac-free-3.3.8/mkspecs/macx-g++ -I. -I../shared -I../../../include -I/System/Library/Frameworks/OpenGL.framework/Versions/A/Headers -I/System/Library/Frameworks/AGL.framework/Versions/A/Headers -I.moc/release-shared-mt/ -o .obj/release-shared-mt/domtool.o ../shared/domtool.cpp
c++ -c -pipe -I/opt/local/include -Wall -W -Os -fPIC  -DQT_INTERNAL_XML -DQ_TEMPLATE_EXTERN=extern -DRESOURCE -DQT_ACCESSIBILITY_SUPPORT -DQT_TABLET_SUPPORT -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -I/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_aqua_qt3-mac/work/qt-mac-free-3.3.8/mkspecs/macx-g++ -I. -I../shared -I../../../include -I/System/Library/Frameworks/OpenGL.framework/Versions/A/Headers -I/System/Library/Frameworks/AGL.framework/Versions/A/Headers -I.moc/release-shared-mt/ -o .obj/release-shared-mt/uib.o ../shared/uib.cpp
c++ -c -pipe -I/opt/local/include -Wall -W -Os -fPIC  -DQT_INTERNAL_XML -DQ_TEMPLATE_EXTERN=extern -DRESOURCE -DQT_ACCESSIBILITY_SUPPORT -DQT_TABLET_SUPPORT -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -I/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_aqua_qt3-mac/work/qt-mac-free-3.3.8/mkspecs/macx-g++ -I. -I../shared -I../../../include -I/System/Library/Frameworks/OpenGL.framework/Versions/A/Headers -I/System/Library/Frameworks/AGL.framework/Versions/A/Headers -I.moc/release-shared-mt/ -o .obj/release-shared-mt/database.o ../designer/database.cpp
../../../include/qsqldatabase.h:63: warning: 'class QSqlDriverCreatorBase' has virtual functions but non-virtual destructor
/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_aqua_qt3-mac/work/qt-mac-free-3.3.8/bin/moc ../designer/database2.h -o .moc/release-shared-mt/moc_database2.cpp
c++ -c -pipe -I/opt/local/include -Wall -W -Os -fPIC  -DQT_INTERNAL_XML -DQ_TEMPLATE_EXTERN=extern -DRESOURCE -DQT_ACCESSIBILITY_SUPPORT -DQT_TABLET_SUPPORT -DQT_NO_DEBUG -DQT_THREAD_SUPPORT -DQT_SHARED -I/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_aqua_qt3-mac/work/qt-mac-free-3.3.8/mkspecs/macx-g++ -I. -I../shared -I../../../include -I/System/Library/Frameworks/OpenGL.framework/Versions/A/Headers -I/System/Library/Frameworks/AGL.framework/Versions/A/Headers -I.moc/release-shared-mt/ -o .obj/release-shared-mt/moc_database2.o .moc/release-shared-mt/moc_database2.cpp
test -d ../../../lib/ || mkdir -p ../../../lib/
rm -f libqui.1.0.0.dylib libqui.dylib libqui.1.dylib libqui.1.0.dylib
c++ -headerpad_max_install_names -prebind -seg1addr 0xB9000000 -prebind -dynamiclib -compatibility_version      1.0 -current_version    1.0.0 -install_name    libqui.1.dylib -o libqui.1.0.0.dylib .obj/release-shared-mt/qwidgetfactory.o .obj/release-shared-mt/domtool.o .obj/release-shared-mt/uib.o .obj/release-shared-mt/database.o .obj/release-shared-mt/moc_database2.o  -L/opt/local/lib -L/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_aqua_qt3-mac/work/qt-mac-free-3.3.8/lib -lqt-mt -lmng -ljpeg -lpng -lz -framework OpenGL -framework AGL 
ld: warning prebinding disabled because dependent library: libqt-mt.3.dylib is not prebound
ln -s libqui.1.0.0.dylib libqui.dylib
ln -s libqui.1.0.0.dylib libqui.1.dylib
ln -s libqui.1.0.0.dylib libqui.1.0.dylib
rm -f ../../../lib/libqui.1.0.0.dylib
rm -f ../../../lib/libqui.dylib
rm -f ../../../lib/libqui.1.dylib
rm -f ../../../lib/libqui.1.0.dylib
mv -f libqui.1.0.0.dylib libqui.dylib libqui.1.dylib libqui.1.0.dylib ../../../lib/
cd designer && make -f Makefile
/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_aqua_qt3-mac/work/qt-mac-free-3.3.8/bin/uic -L /opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_aqua_qt3-mac/work/qt-mac-free-3.3.8/plugins listboxeditor.ui -o listboxeditor.h
dyld: Library not loaded: libqt-mt.3.dylib
  Referenced from: /opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_aqua_qt3-mac/work/qt-mac-free-3.3.8/bin/uic
  Reason: image not found
make[3]: *** [listboxeditor.h] Trace/BPT trap
make[2]: *** [sub-designer] Error 2
make[1]: *** [sub-designer] Error 2
make: *** [sub-tools] Error 2

Error: Status 1 encountered during processing.
[Users/mac] >

Attachments (1)

Portfile.new (2.9 KB) - added by logicnazi@… 10 years ago.
Patch to fix compilation

Download all attachments as: .zip

Change History (15)

comment:1 Changed 10 years ago by markd@…

  • Cc blair@… added
  • Milestone set to Port Bugs
  • Owner changed from macports-dev@… to blair@…

Assigning to maintainer, and adding comments from the mailing list:

I fixed this problem temporarily by added the following line to the build rules in the Portfile.

build.cmd "export DYLD_LIBRARY_PATH='${worksrcpath}/lib'; make"

comment:2 Changed 10 years ago by markd@…

  • Cc markd@… added

Blair, is this an acceptable way to fix qt3-mac? Another person has confirmed that it works.

comment:3 Changed 10 years ago by ryandesign (Ryan Schmidt)

  • Cc s1590001@… added

comment:4 Changed 10 years ago by blair (Blair Zajac)

This looks like an issue in MacPorts 1.5.x, since it used to work in 1.4.0 and if you look at the Portfile, it does set the environment:

$ grep env Portfile 
configure.env   QMAKESPEC='' QTDIR='' DYLD_LIBRARY_PATH=''
build.env       QMAKESPEC='' QTDIR='' DYLD_LIBRARY_PATH="${worksrcpath}/lib"

Blair

comment:5 Changed 10 years ago by ryandesign (Ryan Schmidt)

  • Cc ryandesign@… added
  • Summary changed from qt3-mac building problem to qt3-mac 3.3.8_0 building problem

I've done some regression testing. The problem surfaced between the release of MacPorts 1.4.0 and 1.4.1, in r23238. Building MacPorts trunk at r23238, I see the error reported in this ticket. Building trunk at r23237, I get past that, though I still get stuck on a different error in destroot:

DEBUG: Executing proc-post-com.apple.destroot-destroot-0
ranlib: can't open file: /tmp/macports/var/db/dports/build/_Users_rschmidt_macports_dports_aqua_qt3-mac/work/destroot/tmp/macports/lib/libdesignercore.a (No such file or directory)
Error: Target com.apple.destroot returned: shell command "ranlib -s /tmp/macports/var/db/dports/build/_Users_rschmidt_macports_dports_aqua_qt3-mac/work/destroot/tmp/macports/lib/libdesignercore.a" returned error 1
Command output: ranlib: can't open file: /tmp/macports/var/db/dports/build/_Users_rschmidt_macports_dports_aqua_qt3-mac/work/destroot/tmp/macports/lib/libdesignercore.a (No such file or directory)

Warning: the following items did not execute (for qt3-mac): com.apple.activate com.apple.destroot com.apple.install
Error: Status 1 encountered during processing.

comment:6 Changed 10 years ago by mww@…

the problem seems to be when setting values to empty strings, like FOO="";

Changed 10 years ago by logicnazi@…

Patch to fix compilation

comment:7 Changed 10 years ago by logicnazi@…

It was those empty strings. Submitted portfile that got it to compile for me.

comment:8 Changed 10 years ago by gerrit.polder@…

I still can't compile.

--->  Building qt3-mac with target symlinks src-qmake src-moc sub-src sub-tools
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_qt3-mac/work/qt-mac-free-3.3.8" && make symlinks src-qmake src-moc sub-src sub-tools " returned error 2
Command output: make: Nothing to be done for `symlinks'.
cd qmake && make
make[1]: `qmake' is up to date.
cd src/moc && make
make[1]: Nothing to be done for `first'.
cd src && make
make[1]: Nothing to be done for `first'.
cd plugins/src && make
cd accessible && make -f Makefile
cd widgets && make -f Makefile
test -d ../../../accessible/ || mkdir -p ../../../accessible/
rm -f libqtwidgets.dylib
c++ -headerpad_max_install_names -bundle -o libqtwidgets.dylib .obj/release-shared-mt/main.o .obj/release-shared-mt/qaccessiblewidget.o .obj/release-shared-mt/qaccessiblemenu.o   -L/opt/local/lib -L/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_qt3-mac/work/qt-mac-free-3.3.8/lib -lqt-mt -lmng -ljpeg -lpng -lz -framework OpenGL -framework AGL 
/usr/bin/ld: warning -prebind has no effect with -bundle
/usr/bin/ld: Undefined symbols:
QAccessible::queryAccessibleInterface(QObject*, QAccessibleInterface**)
QAccessibleObject::queryInterface(QUuid const&, QUnknownInterface**)
QAccessibleObject::QAccessibleObject(QObject*)
QAccessibleObject::~QAccessibleObject()
QAccessibleObject::object() const
QAccessibleObject::isValid() const
typeinfo for QAccessibleObject
non-virtual thunk to QAccessibleObject::queryInterface(QUuid const&, QUnknownInterface**)
non-virtual thunk to QAccessibleObject::isValid() const
collect2: ld returned 1 exit status
make[3]: *** [../../../accessible/libqtwidgets.dylib] Error 1
make[2]: *** [sub-widgets] Error 2
make[1]: *** [sub-accessible] Error 2
make: *** [sub-plugins] Error 2

Error: Status 1 encountered during processing.

comment:9 Changed 10 years ago by afb@…

Environment variables fixed, #12885

comment:10 Changed 10 years ago by markd@…

Any objections to closing this?

comment:11 Changed 10 years ago by jmpp@…

  • Component changed from ports to base
  • Milestone changed from Port Bugs to MacPorts base bugs

comment:12 Changed 10 years ago by jmpp@…

  • Resolution set to fixed
  • Status changed from new to closed

comment:13 Changed 9 years ago by tobypeterson

  • Milestone changed from MacPorts base bugs to MacPorts Future

Milestone MacPorts base bugs deleted

comment:14 Changed 8 years ago by jmroot (Joshua Root)

  • Milestone changed from MacPorts Future to MacPorts 1.6
Note: See TracTickets for help on using tickets.