Opened 13 years ago

Closed 12 years ago

Last modified 11 years ago

#12040 closed defect (duplicate)

db44 4.4.20 won't build; caused by readline in /usr/local

Reported by: alkemiman@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.4.40
Keywords: Cc: alkemiman@…, markd@…, ryandesign (Ryan Schmidt),blair (Blair Zajac)
Port: db44

Description (last modified by ryandesign (Ryan Schmidt))

When attempting to install db44, I get the following error:

sudo port -v install db44
--->  Building db44 with target all
/bin/sh ./libtool --mode=compile /usr/bin/gcc-4.0 -c -O2  -I../dist/.. -I/opt/local/include ../dist/../db_dump185/db_dump185.c
 /usr/bin/gcc-4.0 -c -O2 -I../dist/.. -I/opt/local/include ../dist/../db_dump185/db_dump185.c  -fno-common -DPIC -o .libs/db_dump185.o
../dist/../db_dump185/db_dump185.c: In function 'main':
../dist/../db_dump185/db_dump185.c:212: warning: assignment makes pointer from integer without a cast
../dist/../db_dump185/db_dump185.c:214: warning: assignment makes pointer from integer without a cast
../dist/../db_dump185/db_dump185.c:229: error: 'struct __db' has no member named 'seq'
../dist/../db_dump185/db_dump185.c:229: error: 'R_NEXT' undeclared (first use in this function)
../dist/../db_dump185/db_dump185.c:229: error: (Each undeclared identifier is reported only once
../dist/../db_dump185/db_dump185.c:229: error: for each function it appears in.)
../dist/../db_dump185/db_dump185.c:234: error: 'struct __db' has no member named 'seq'
../dist/../db_dump185/db_dump185.c: In function 'db_hash':
../dist/../db_dump185/db_dump185.c:262: error: 'struct __db' has no member named 'internal'
../dist/../db_dump185/db_dump185.c:264: error: 'struct __db' has no member named 'internal'
../dist/../db_dump185/db_dump185.c: In function 'db_btree':
../dist/../db_dump185/db_dump185.c:289: error: 'struct __db' has no member named 'internal'
make: *** [db_dump185.lo] Error 1
Error: Target com.apple.build returned: shell command " cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_databases_db44/work/db-4.4.20/build_unix" && make all " returned error 2
Command output: /bin/sh ./libtool --mode=compile /usr/bin/gcc-4.0 -c -O2  -I../dist/.. -I/opt/local/include ../dist/../db_dump185/db_dump185.c
 /usr/bin/gcc-4.0 -c -O2 -I../dist/.. -I/opt/local/include ../dist/../db_dump185/db_dump185.c  -fno-common -DPIC -o .libs/db_dump185.o
../dist/../db_dump185/db_dump185.c: In function 'main':
../dist/../db_dump185/db_dump185.c:212: warning: assignment makes pointer from integer without a cast
../dist/../db_dump185/db_dump185.c:214: warning: assignment makes pointer from integer without a cast
../dist/../db_dump185/db_dump185.c:229: error: 'struct __db' has no member named 'seq'
../dist/../db_dump185/db_dump185.c:229: error: 'R_NEXT' undeclared (first use in this function)
../dist/../db_dump185/db_dump185.c:229: error: (Each undeclared identifier is reported only once
../dist/../db_dump185/db_dump185.c:229: error: for each function it appears in.)
../dist/../db_dump185/db_dump185.c:234: error: 'struct __db' has no member named 'seq'
../dist/../db_dump185/db_dump185.c: In function 'db_hash':
../dist/../db_dump185/db_dump185.c:262: error: 'struct __db' has no member named 'internal'
../dist/../db_dump185/db_dump185.c:264: error: 'struct __db' has no member named 'internal'
../dist/../db_dump185/db_dump185.c: In function 'db_btree':
../dist/../db_dump185/db_dump185.c:289: error: 'struct __db' has no member named 'internal'
make: *** [db_dump185.lo] Error 1

Warning: the following items did not execute (for db44): com.apple.activate com.apple.build com.apple.destroot com.apple.install
Error: Status 1 encountered during processing.

Change History (9)

comment:1 Changed 13 years ago by markd@…

Summary: Error installing db44 on Intel based 10.4BUG: db44-4.4.20 error installing on Intel/10.4

comment:2 Changed 13 years ago by markd@…

Cc: alkemiman@… markd@… added

It works ok for me. Are you running a recent version of Xcode tools: 2.4.x?

comment:3 Changed 13 years ago by yves@…

Milestone: Port Bugs

I just got the same error on 10.4.9 / PPC with xcode 2.4.1

powerpc-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5367)

Just reproducing for clarity :

 /usr/bin/gcc-4.0 -c -O2 -I../dist/.. -I/opt/local/include ../dist/../db_dump185/db_dump185.c  -fno-common -DPIC -o .libs/db_dump185.o
../dist/../db_dump185/db_dump185.c: In function 'main':
../dist/../db_dump185/db_dump185.c:212: warning: assignment makes pointer from integer without a cast
../dist/../db_dump185/db_dump185.c:214: warning: assignment makes pointer from integer without a cast
../dist/../db_dump185/db_dump185.c:229: error: 'struct __db' has no member named 'seq'
../dist/../db_dump185/db_dump185.c:229: error: 'R_NEXT' undeclared (first use in this function)
../dist/../db_dump185/db_dump185.c:229: error: (Each undeclared identifier is reported only once
../dist/../db_dump185/db_dump185.c:229: error: for each function it appears in.)
../dist/../db_dump185/db_dump185.c:234: error: 'struct __db' has no member named 'seq'
../dist/../db_dump185/db_dump185.c: In function 'db_hash':
../dist/../db_dump185/db_dump185.c:262: error: 'struct __db' has no member named 'internal'
../dist/../db_dump185/db_dump185.c:264: error: 'struct __db' has no member named 'internal'
../dist/../db_dump185/db_dump185.c: In function 'db_btree':
../dist/../db_dump185/db_dump185.c:289: error: 'struct __db' has no member named 'internal'
make: *** [db_dump185.lo] Error 1

comment:4 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

This has been a tricky problem to track down, but on the mailing list today we got a hint: maybe a rogue readline in /usr/local is causing trouble. To test this theory, rename /usr/local to something else (like /usr/local-off) and try installing db44 again. In the case of the writer on the mailing list, this uncovered the problem that MacPorts itself had been built against a readline in /usr/local. The solution for that is to reinstall MacPorts 1.5.0 from disk image, then selfupdate back to the current version. And as you uncover other software that has been built against a readline in /usr/local, rebuild that software to get it to link properly with the readline installed by MacPorts.

In the future, I recommend not installing anything in /usr/local at all. Install all software with MacPorts if possible. If portfiles do not exist for the software you would like to use, either write the portfiles and contribute them to the project, or file tickets requesting that someone write the portfiles.

Please let us know whether or not this information is helpful in installing db44.

comment:5 Changed 13 years ago by blair (Blair Zajac)

Cc: blair@… added

I understand, haven't verified this myself, but from the svn dev IRC, the CollabNet Subversion binary package from

http://downloads.open.collab.net/binaries.html

currently installs into /usr/local a set of .h files for Berkeley DB, so it's possible by having that installed, it'll break your build.

I understand that they may move the package into /opt/subversion or a similar location, so this one issue should go away.

Blair

comment:6 Changed 13 years ago by ryandesign (Ryan Schmidt)

Summary: BUG: db44-4.4.20 error installing on Intel/10.4db44 4.4.20 won't build; caused by readline in /usr/local

comment:7 Changed 12 years ago by tobypeterson

Resolution: duplicate
Status: newclosed

duplicate of #15077

comment:8 Changed 12 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: db44 added

comment:9 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.