Opened 12 years ago

Closed 10 years ago

Last modified 10 years ago

#12073 closed defect (fixed)

BUG: BitchX-1.1 build fails with ncurses installed

Reported by: dreness (Andre LaBranche) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.4.40
Keywords: Cc: dreness (Andre LaBranche), ryandesign (Ryan Schmidt), carcus@…, sean@…
Port: BitchX

Description (last modified by ryandesign (Ryan Schmidt))

BitchX does not build successfully when ncurses is installed, but seems fine otherwise. The specific error is:

In file included from alias.c:36:
/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_irc_bitchx/work/BitchX/include/ircterm.h:19:31: error: ncurses/termcap.h: No such file or directory

even though /opt/local/include/ncurses/termcap.h is there, and is detected in the configure phase.

Change History (8)

comment:1 Changed 12 years ago by markd@…

Summary: BitchX build fails with ncurses installedBUG: BitchX-1.1 build fails with ncurses installed

Put summary in correct form.

comment:2 Changed 12 years ago by nox@…

Milestone: Port Bugs
Priority: ExpectedNormal

comment:3 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: dre@… ryandesign@… carcus@… sean@… added

This was reported again on the mailing list today. Even installing ncurses does not help this. It looks like bitchx 1.1 is 3 years old, but there is a newer version 1.1a from August 2007. The maintainer should update this port.

comment:4 Changed 12 years ago by ryandesign (Ryan Schmidt)

Sorry, I just reread the original issue: of course installing ncurses does not help this, because the issue apparently only occurs when ncurses is installed.

comment:5 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:6 Changed 10 years ago by tobypeterson

I'm pretty sure this was fixed in r34857 - I can't reproduce the failure. However, it needs to declare its dependency on ncurses.

comment:7 Changed 10 years ago by tobypeterson

Resolution: fixed
Status: newclosed

comment:8 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: BitchX added
Note: See TracTickets for help on using tickets.