Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#12226 closed defect (worksforme)

BUG:ntfs-3g-1.616_0

Reported by: grahamperrin@… Owned by: macports-tickets@…
Priority: Not set Milestone:
Component: ports Version:
Keywords: MacFUSE Cc:
Port:

Description

ntfs-3g will not run when MacFUSE 0.4.0 (MacFUSE Core.pkg) is installed.

Whereas ntfs-3g will _not_ run, sshfs (with similar dependencies) _will_ run.

At http://paste.lisp.org/display/43535 for example,

[macbookpro03:~] gjp22% ntfs-3g -h
dyld: Symbol not found: ___CFConstantStringClassReference
  Referenced from: /opt/local/lib/libfuse.0.dylib
  Expected in: flat namespace

Trace/BPT trap

If you'd like additional information, please let me know.

Thanks.

Change History (3)

comment:1 Changed 14 years ago by grahamperrin@…

Regarding differences between
/opt/local/lib/libfuse.0.dylib
and
/usr/local/lib/libfuse.0.dylib

ls -al /opt/local/lib/libfuse.0.dylib
-rwxr-xr-x   2 root  admin  90084 Jun 27 16:21 /opt/local/lib/libfuse.0.dylib

ls -al /usr/local/lib/libfuse.0.dylib
-rwxr-xr-x   1 root  wheel  486656 Jun  6 00:52 /usr/local/lib/libfuse.0.dylib
file /opt/local/lib/libfuse.0.dylib
/opt/local/lib/libfuse.0.dylib: Mach-O dynamically linked shared library i386

file /usr/local/lib/libfuse.0.dylib
/usr/local/lib/libfuse.0.dylib: Mach-O universal binary with 2 architectures
/usr/local/lib/libfuse.0.dylib (for architecture i386): Mach-O dynamically linked shared library i386
/usr/local/lib/libfuse.0.dylib (for architecture ppc):  Mach-O dynamically linked shared library ppc

comment:2 Changed 14 years ago by kballard (Lily Ballard)

Resolution: worksforme
Status: newclosed

Already fixed, but I didn't bump the revision because I figured anybody that since it wasn't working for anybody that had it installed, it wasn't an issue. But I probably should have bumped the revision as you could still install it before, you just couldn't use it.

I'm going to go ahead and bump the revision, but all you need to do is make sure you're synced and just uninstall/reinstall ntfs-3g.

comment:3 Changed 14 years ago by raimue (Rainer Müller)

grahamperrin confirmed on IRC that ntfs-3g 1.616_1 runs with MacFUSE 0.4.0 from Google Code

Note: See TracTickets for help on using tickets.