Opened 14 years ago

Closed 12 years ago

#12241 closed defect (fixed)

BUG: odcctools: compilation gives error: ‘x86_THREAD_STATE64_COUNT’ was not declared in this scope

Reported by: software@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: yaseppochi (Stephen J. Turnbull)
Port: odcctools

Description (last modified by ryandesign (Ryan Schmidt))

port install odcctools

gives an error during build:

 --->  Building odcctools with target default
 Error: Target com.apple.build returned: shell command " cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.macports.org_dpupdate_dports_devel_odcctools/work/odcctools/odcctools" && make default " returned error 2

The error is caused by "make default". I'll attach the full log.

I did a port sync; port selfupdate to make sure the error was still there in the latest version.

Attachments (2)

odcctools_error.txt (3.9 KB) - added by software@… 14 years ago.
error log
thread_status.h (14.0 KB) - added by mdickens@… 13 years ago.
"thread_status.h" i386-64 replacement file from Xcode 2.4.1

Download all attachments as: .zip

Change History (9)

Changed 14 years ago by software@…

Attachment: odcctools_error.txt added

error log

comment:1 Changed 14 years ago by Lars.Rasmusson@…

I got exactly the same error. Turns out I was using an old version of Xcode, 2.2.1, so I upgraded to a more recent one, 2.4.1, which solved the problem. I think that the 64 bit linking was added to Xcode around version 2.3, which explains why the header files etc. were messed up.

comment:2 Changed 14 years ago by nox@…

Milestone: Port Bugs
Priority: ExpectedNormal
Summary: odcctools: compilation gives error: ‘x86_THREAD_STATE64_COUNT’ was not declared in this scopeBUG: odcctools: compilation gives error: ‘x86_THREAD_STATE64_COUNT’ was not declared in this scope
Version: 1.4.42

comment:3 Changed 13 years ago by mdickens@…

The file "/Developer/SDKs/MacOSX10.4u.sdk/usr/include/mach/i386/thread_status.h" needs to include the 64-bit thread stuff. This is not yet available in Xcode 2.3 (which is what's installed on the G4 Mac I'm compiling on), so I would guess the newer file came in 2.4 (from Apple: "The Xcode 2.4 release ... adds support for 64-bit Intel based Mac computers."). Upgrading to the latest (2.4.1 as of this writing) will get a working copy of that file.

You can get odcctools to compile under Xcode 2.3 by copying a 64-bit savvy version of thread_status.h (which I'll attach as a file here) into "work/odcctools/odcctools/include/mach/i386/". I'm sure there's a way to automate this in the Portfile, but I'll leave that to someone who knows more. - MLD

Changed 13 years ago by mdickens@…

Attachment: thread_status.h added

"thread_status.h" i386-64 replacement file from Xcode 2.4.1

comment:4 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: stephen@… added

Has duplicate #12272.

comment:5 Changed 12 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: odcctools added

Don't forget WikiFormatting! :)

comment:6 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:7 Changed 12 years ago by tobypeterson

Resolution: fixed
Status: newclosed

Judging from previous comments, this is resolved in newer versions of Xcode.

Note: See TracTickets for help on using tickets.