Opened 14 years ago

Closed 14 years ago

Last modified 12 years ago

#12328 closed defect (duplicate)

monotone does not compile

Reported by: luke-macports@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.5.0
Keywords: Cc: luke-macports@…, ryandesign (Ryan Schmidt)
Port:

Description

if g++ -DLOCALEDIR=\"/opt/local/share/locale\" -DHAVE_CONFIG_H -I. -I. -I. -I./lua -I./sqlite -I/opt/local/include -DNDEBUG -DBOOST_DISABLE_THREADS -DBOOST_SP_DISABLE_THREADS -DBOOST_MULTI_INDEX_DISABLE_SERIALIZATION -O2 -Wall -W -Wno-unused -fno-strict-aliasing -MT mtn-ssh_agent.o -MD -MP -MF ".deps/mtn-ssh_agent.Tpo" -c -o mtn-ssh_agent.o test -f 'ssh_agent.cc' || echo './'ssh_agent.cc; \ then mv -f ".deps/mtn-ssh_agent.Tpo" ".deps/mtn-ssh_agent.Po"; else rm -f ".deps/mtn-ssh_agent.Tpo"; exit 1; fi numeric_vocab.hh:25: error: 'CHAR_BIT' was not declared in this scope numeric_vocab.hh:25: error: template argument 1 is invalid make[2]: * [mtn-ssh_agent.o] Error 1 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

Error: Status 1 encountered during processing. pomme:~ lukeschierer$

Change History (3)

comment:1 Changed 14 years ago by ryandesign (Ryan Schmidt)

Cc: luke-macports@… ryandesign@… added
Milestone: Port Bugs
Owner: changed from macports-dev@… to ryandesign@…

Duplicate of #12131.

comment:2 Changed 14 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

comment:3 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.