Opened 13 years ago

Closed 10 years ago

#12336 closed defect (invalid)

BUG: Staging into destroot fails for help2man

Reported by: joefidler@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc:
Port: help2man

Description (last modified by mf2k (Frank Schima))

Help2man is used by KDE , gimp and several others. Thanks for your help, Joe.

snowie:~ joe$ sudo port install help2man
Password:
--->  Staging help2man into destroot
Error: Target org.macports.destroot returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/help2man-1.36.4" && make install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot " returned error 2
Command output: ./mkinstalldirs /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/bin
./mkinstalldirs /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/lib
./mkinstalldirs /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/man/man1
./mkinstalldirs /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/info
/usr/bin/install -c help2man /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/bin
/usr/bin/install -c -m 644 ./help2man.1 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/man/man1
/usr/bin/install -c -m 644 ./help2man.info \
    /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/info/help2man.info
if test -f /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/info/dir; \
then \
    /usr/bin/install-info --info-dir=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_help2man/work/destroot/opt/local/share/info \
        ./help2man.info; \
fi
/usr/bin/gcc-4.0  -o hacklocaledir.so -fPIC -bundle hacklocaledir.c 
hacklocaledir.c: In function '__open':
hacklocaledir.c:44: error: 'RTLD_NEXT' undeclared (first use in this function)
hacklocaledir.c:44: error: (Each undeclared identifier is reported only once
hacklocaledir.c:44: error: for each function it appears in.)
hacklocaledir.c: At top level:
hacklocaledir.c:113: warning: alias definitions not supported in Mach-O; ignored
make: *** [hacklocaledir.so] Error 1

Error: Status 1 encountered during processing.
snowie:~ joe$ 

Change History (11)

comment:1 Changed 13 years ago by joefidler@…

Downloaded from http://ftp.gnu.org/gnu/help2man/. Make for standalone package, gives same error and I suspect there is a problem with help2man. Can help2man be dropped? See Changeset 26905.

snowie:~/dev/help2man-1.36.4 joe$ make perl help2man.PL Extracting help2man (with variable substitutions) gcc -o hacklocaledir.so -fPIC -shared hacklocaledir.c powerpc-apple-darwin8-gcc-4.0.1: unrecognized option '-shared' hacklocaledir.c: In function 'open': hacklocaledir.c:44: error: 'RTLD_NEXT' undeclared (first use in this function) hacklocaledir.c:44: error: (Each undeclared identifier is reported only once hacklocaledir.c:44: error: for each function it appears in.) hacklocaledir.c: At top level: hacklocaledir.c:113: warning: alias definitions not supported in Mach-O; ignored make: * [hacklocaledir.so] Error 1 snowie:~/dev/help2man-1.36.4 joe$

comment:2 Changed 13 years ago by joefidler@…

Just worked around the issue. Took the (very) long way and upgraded to GCC 4.2. After changing the help2man makefile option CC to use GCC-MP-4.2 -it worked and I was able to activate the help2man port and get opter applications installed. I was previously using the Apple GCC 4.01.

Hope this helps, Joe.

comment:3 Changed 13 years ago by nox@…

Priority: BlockerHigh
Summary: Staging into destroot fails for help2manBUG: Staging into destroot fails for help2man
Version: 1.5.0

comment:4 Changed 13 years ago by jmroot (Joshua Root)

Resolution: worksforme
Status: newclosed

I'm unable to reproduce this on either ppc Tiger or x86 Leopard. Marking worksforme, but feel free to reopen if you're still having this problem.

comment:5 in reply to:  4 Changed 12 years ago by gknauth (Geoffrey Knauth)

I'm getting the original error reported:

hacklocaledir.c:44: error: 'RTLD_NEXT' undeclared (first use in this function)

comment:6 Changed 12 years ago by mf2k (Frank Schima)

Description: modified (diff)
Keywords: help2man removed
Port: help2man added
Priority: HighNormal

comment:7 in reply to:  6 Changed 12 years ago by gknauth (Geoffrey Knauth)

I did this:

sudo mv /usr/local{,.off}

and then I was able to install help2man, so there must have been something in /usr/local that got in the way.

comment:8 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:9 Changed 11 years ago by ryandesign (Ryan Schmidt)

Duplicate #16127 shows that the file that was causing the problem was /usr/local/include/dlfcn.h.

comment:10 Changed 10 years ago by kh@…

Resolution: worksforme
Status: closedreopened

iMac 10.6.4 attempting to install gimp - help2man has a failed shell command during configure. I believe that this is to do with a directory being called help2man-1.38.2 whereas port is expecting help2man_1.38.2. Changing the directory name does not, unfortunately help. I cannot therefore install gimp at all.

comment:11 Changed 10 years ago by jmroot (Joshua Root)

Resolution: invalid
Status: reopenedclosed

That's nothing to do with this ticket.

Note: See TracTickets for help on using tickets.