Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#12514 closed update (fixed)

UPDATE: Xft2-2.1.12

Reported by: IngmarStein@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.5.0
Keywords: Cc: IngmarStein@…, ryandesign (Ryan Schmidt), lutz_mader@…
Port:

Description

The attached patch updates the x11/Xft2 port from 2.1.7 to 2.1.12.

Attachments (4)

Portfile.diff (863 bytes) - added by IngmarStein@… 13 years ago.
Portfile.2.diff (1.0 KB) - added by lutz_mader@… 13 years ago.
New Portfile
patch-xft.pc.in (675 bytes) - added by lutz_mader@… 13 years ago.
Patchfile for xftp.pc.in
Portfile.3.diff (498 bytes) - added by lutz_mader@… 13 years ago.

Download all attachments as: .zip

Change History (15)

Changed 13 years ago by IngmarStein@…

Attachment: Portfile.diff added

comment:1 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: IngmarStein@… ryandesign@… added
Milestone: Port Updates

I tried upgrading Xft2 to 2.1.12, and it caused openMotif 2.3.0_1 to no longer build. See #12444. So I'm inclined not to touch Xft2 at this time, until that problem has been resolved. If someone would like to open a dialog with the openMotif or Xft2 developers about this problem and report back here that would be wonderful.

comment:2 Changed 13 years ago by lutz_mader@…

Hi, I spent some time to find out what's going wrong with xft2 2.1.12. The only thing I find, xft-config.in looks like the old one, but some lines in xft.pc.in, available in the xft-config.in header too, are deleted.

OpenMotif use "pkg-config xft --cflags" to get some compile/link options.

After using a patch file to get the old compile/link options, openmotif is running with xft2 2.1.12.

But I don't know, maybe it's a bug or not in xft2, but it seems to me like a typo.

Bye, Lutz

Changed 13 years ago by lutz_mader@…

Attachment: Portfile.2.diff added

New Portfile

Changed 13 years ago by lutz_mader@…

Attachment: patch-xft.pc.in added

Patchfile for xftp.pc.in

comment:3 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: lutz_mader@… added

Thank you, Lutz, for checking into this. Have you confirmed with the developers of Xft2 that this is a bug, and that they will fix it in this way in the next version of Xft2?

comment:4 Changed 13 years ago by lutz_mader@…

Hi, I send a request/question to fontconfig@…, this is the mailing list from the libXft folks. Hopefully I/we get an answer. Bye, Lutz

comment:5 Changed 13 years ago by lutz_mader@…

I add a ticket to the bug list today, see https://bugs.freedesktop.org/show_bug.cgi?id=12152 for more information. Bye, Lutz

comment:6 Changed 13 years ago by lutz_mader@…

Hi, it seems to be a bug between my ears, it's much more easy to install all existing dependencies first. After a closer look to the source I think xft2 (libXft) use xorg-xproto (xproto)! Sorry, Lutz

p.s. The new Portfile file works without any patch.

Changed 13 years ago by lutz_mader@…

Attachment: Portfile.3.diff added

comment:7 Changed 13 years ago by lutz_mader@…

Hi, the libxft folks are conform to me!

See http://bugs.freedesktop.org/show_bug.cgi?id=12152

Bye, Lutz

p.s.
I checked how 2.1.7 works first, but the old version don't need xproto.

------- Comment #4 From Alan Coopersmith 2007-08-25 23:57:42 PST [reply] -------

2.1.7 was before xproto existed.   2.1.8 was the first Xft release from 
the X11R7 modular series.

comment:8 Changed 13 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-dev@… to ryandesign@…

comment:9 Changed 13 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

portfile.3.diff committed in r28312 (with whitespace changes to match the rest of the portfile). Thanks so much, Ingmar and Lutz!

comment:10 Changed 11 years ago by jmroot (Joshua Root)

Type: enhancementupdate

comment:11 Changed 11 years ago by (none)

Milestone: Port Updates

Milestone Port Updates deleted

Note: See TracTickets for help on using tickets.