Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#12569 closed defect (fixed)

gnome-doc-utils: xml2po uses insane amounts of memory

Reported by: afb@… Owned by: rhwood@…
Priority: High Milestone:
Component: ports Version: 1.5.2
Keywords: Cc: boeyms@… rhwood@…
Port:

Description

Seems like gnome-doc-utils doesn't work with Python 2.5, it can't find docbook module due to e.g. missing "md5" module and it uses well over 2 GB of memory to process a 20KB input file.

Switching back to python24 cuts back on the dependencies and makes it finish in seconds.

Attachments (1)

gnome-doc-utils-downgrade.diff (702 bytes) - added by afb@… 13 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 13 years ago by afb@…

It was broken in r27763, two weeks ago.

comment:2 Changed 13 years ago by rhwood@…

Owner: changed from macports-dev@… to rhwood@…
Status: newassigned

I wonder if this issue is the result of using a toolset that is partially on python 2.4 and partially on python 2.5?

comment:3 Changed 13 years ago by afb@…

I'm not sure, but it would be nice if this issue and the missing /opt/local/bin/python could be addressed since it affects MacPorts users daily (usually installing "avahi" or other GNOME).

comment:4 Changed 13 years ago by rhwood@…

What port were you attempting to install when this error was noticed?

Please note that xml2po did this on certain ports prior to the upgrade from python 2.4 to python 2.5

/opt/local/bin/python was explicitely removed to avoid collisions between the python24 and python25 ports. Install port python_select and use the command python-select to set your preferred python version to /opt/local/bin/python

comment:5 Changed 13 years ago by rhwood@…

Cc: boeyms@… added

Changeset:28405 upgrades gnome-doc-utils to version 0.11.2, but retains the use of python 2.5. Can you please test it?

CCing boeyms on this as he might have a better understanding of what's going on than I do...

comment:6 Changed 13 years ago by rhwood@…

Please let me know if installing py25-twisted before installing the problem port has any effect on this issue.

Thank you. (I'd test, but I am about to be late for a class).

comment:7 Changed 13 years ago by afb@…

I know that you need to install/use python_select. The average new MacPorts users doesn't.

comment:8 Changed 13 years ago by afb@…

Upgrading gnome-doc-utils: doesn't help.

Installing py25-twisted: no change either.

The "gnome-panel" (etc) build still "freezes", due to xml2po eating all memory and swapping.

Switching back to the python24 version of gnome-doc-utils, and build zooms right by...

Changed 13 years ago by afb@…

comment:9 Changed 13 years ago by rhwood@…

Is this still an issue for any of you?

I am no longer able to reproduce this issue.

comment:10 Changed 13 years ago by gui-dos (Guido Soranzio)

Resolution: fixed
Status: assignedclosed

Fixed in r34111

comment:11 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.