Opened 17 years ago

Closed 15 years ago

#1264 closed defect (fixed)

popt dport does not build

Reported by: warp-opendarwin@… Owned by: landonf (Landon Fuller)
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: eric.stokes@…, mathieu_carpentier_2x4@…
Port:

Description

The popt dport does not build:

sudo port install popt

---> Fetching popt ---> Verifying checksum for popt ---> Extracting popt ---> Configuring popt ---> Building popt with target all Error: Target com.apple.build returned: shell command "cd "/Users/warp/build/darwinports/ dports/devel/popt/work/popt-1.7" && make all" returned error 2 Command output: mv -f .libs/poptconfig.lo poptconfig.lo source='popthelp.c' object='popthelp.lo' libtool=yes \ depfile='.deps/popthelp.Plo' tmpdepfile='.deps/popthelp.TPlo' \ depmode=gcc3 /bin/sh ./depcomp \ /bin/sh ./libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -I. -Wall -g -O2 -c -o popthelp.lo test -f 'popthelp.c' || echo './'popthelp.c rm -f .libs/popthelp.lo gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -I. -Wall -g -O2 -c popthelp.c -MT popthelp.lo -MD -MP -MF .deps/popthelp.TPlo -fno-common -DPIC -o .libs/popthelp.lo gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -I. -Wall -g -O2 -c popthelp.c -MT popthelp.lo -MD -MP -MF .deps/popthelp.TPlo -o popthelp.o >/dev/null 2>&1 mv -f .libs/popthelp.lo popthelp.lo /bin/sh ./libtool --mode=link gcc -Wall -g -O2 -o libpopt.la -rpath /usr/local/lib popt.lo findme.lo poptparse.lo poptconfig.lo popthelp.lo rm -fr .libs/libpopt.la .libs/libpopt.* .libs/libpopt.* gcc -dynamiclib -flat_namespace -undefined suppress -o .libs/libpopt.0.0.0.dylib popt.lo findme.lo poptparse.lo poptconfig.lo popthelp.lo -lc -install_name /usr/local/lib/libpopt.0.dylib -compatibility_version 1 -current_version 1.0 (cd .libs && rm -f libpopt.0.dylib && ln -s libpopt.0.0.0.dylib libpopt.0.dylib) (cd .libs && rm -f libpopt.dylib && ln -s libpopt.0.0.0.dylib libpopt.dylib) ar cru .libs/libpopt.a popt.o findme.o poptparse.o poptconfig.o popthelp.o ranlib .libs/libpopt.a creating libpopt.la (cd .libs && rm -f libpopt.la && ln -s ../libpopt.la libpopt.la) source='test1.c' object='test1.o' libtool=no \ depfile='.deps/test1.Po' tmpdepfile='.deps/test1.TPo' \ depmode=gcc3 /bin/sh ./depcomp \ gcc -DHAVE_CONFIG_H -I. -I. -I. -I. -I. -Wall -g -O2 -c test -f 'test1.c' || echo './'test1.c /bin/sh ./libtool --mode=link gcc -Wall -g -O2 -o test1 -all-static test1.o libpopt.la libtool: link: warning: complete static linking is impossible in this configuration gcc -Wall -g -O2 -o test1 test1.o ./.libs/libpopt.a ld: Undefined symbols: _dgettext make[2]: * [test1] Error 1 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

gettext is installed on the system.

Attachments (3)

patch-Makefile.am (570 bytes) - added by eric.stokes@… 17 years ago.
a patch which fixes the build problem
patch-Portfile (361 bytes) - added by eric.stokes@… 17 years ago.
patch to make popt build with included gettext
Portfile_popt_1264 (1.3 KB) - added by mathieu_carpentier_2x4@… 15 years ago.
patch to make popt build

Download all attachments as: .zip

Change History (20)

comment:1 Changed 17 years ago by mww@…

Owner: changed from darwinports-bugs@… to landonf@…

reassigned to owner landonf@

comment:2 Changed 17 years ago by eric.stokes@…

Cc: eric.stokes@… added

comment:3 Changed 17 years ago by eric.stokes@…

* Bug 1319 has been marked as a duplicate of this bug. *

Changed 17 years ago by eric.stokes@…

Attachment: patch-Makefile.am added

a patch which fixes the build problem

Changed 17 years ago by eric.stokes@…

Attachment: patch-Portfile added

patch to make popt build with included gettext

comment:4 Changed 16 years ago by warp-opendarwin@…

I'm not trying to be pushy, but while doing a fresh installation of darwinports today, I noticed, that popt still has to be patched by hand to make it compile. Eric Stokes' solution to append -lintl to test test*_LDADD flags seems to work fine - is there any reason not to apply it to the repository and finally close this patch?

comment:5 Changed 16 years ago by kranki@…

I have been using the second patch (2003-12-20 16:22) by hand. It is not obvious by looking at either patch which is better or should be used (without a great deal of effort). It would be nice if this could be resolved since it blocks gnome from being installed.

comment:6 Changed 16 years ago by toby@…

I can't reproduce this problem (Mac OS X 10.3.7, Xcode 1.5)

comment:7 Changed 16 years ago by landonf@…

Resolution: fixed
Status: newclosed

I have since fixed this. It only affected 10.2.x

comment:8 Changed 16 years ago by yves@…

Hi

I am using cvs from 2005-02-10 and the problem is still there, I am on OpenDarwin 7.2.1

comment:9 Changed 16 years ago by spam@…

I am running os X 10.3, and I just installed darwin ports today (3/16/05), and I had to modify the Portfile to use the --with-included-gettext in the standard args (as set in the "platform darwin 6" block) in order for this to compile, otherwise, I got an error like the one in comment #1.

comment:10 Changed 16 years ago by spam@…

(In reply to comment #10)

otherwise, I got an error like the one in comment #1.

Oops, my apologies, I didn't mean comment #1, I meant as in the bug description.

comment:11 Changed 15 years ago by flori@…

Resolution: fixed
Status: closedreopened

This bug is NOT fixed. Eric Stoke's patch has old and new file exchanged. Do you people test at all after you "fix" bugs? I mean, this bug is from 2003, we have 2005 now!

comment:12 Changed 15 years ago by landonf@…

(In reply to comment #12)

This bug is NOT fixed. Eric Stoke's patch has old and new file exchanged. Do

you people test at all after

you "fix" bugs? I mean, this bug is from 2003, we have 2005 now!

I tested my changes on 10.3 and 10.4. I do not know the status of the patch you mention.

Rather than being rude, can you provide a build log (or even better, a patch)?

-landonf

comment:13 Changed 15 years ago by mathieu_carpentier_2x4@…

(In reply to comment #10)

I am running os X 10.3, and I just installed darwin ports today (3/16/05), and I had to modify the Portfile to use the --with-included-gettext in the standard args (as set in the "platform darwin 6" block) in order for this to compile, otherwise, I got an error like the one in comment #1.

I have been able to compile popt by modifying the Portfile. I added the followin g lines in the Portfile: platform darwin 8 {

configure.args --mandir=${prefix}/share/man --with-included-gettext

}

I'm not sure if it's the right way to do (not familiar yet with Portfile), but at least I have been able to install popt without errors.

Changed 15 years ago by mathieu_carpentier_2x4@…

Attachment: Portfile_popt_1264 added

patch to make popt build

comment:14 Changed 15 years ago by mathieu_carpentier_2x4@…

attachments.ispatch: 01
attachments.mimetype: application/octet-streamtext/plain

comment:15 Changed 15 years ago by mathieu_carpentier_2x4@…

Cc: mathieu_carpentier_2x4@… added

comment:16 Changed 15 years ago by mike012012@…

(In reply to comment #14)

(In reply to comment #10)

I am running os X 10.3, and I just installed darwin ports today (3/16/05), and I had to modify the Portfile to use the --with-included-gettext in the standard args (as set in the "platform darwin 6" block) in order for this to compile, otherwise, I got an error like the one in comment #1.

same here. Adding --with-included-gettext to configure.args allowed this package to compile on my system. I'l running Mac OS 10.3.9

comment:17 Changed 15 years ago by landonf@…

Resolution: fixed
Status: reopenedclosed

I've added --with-included-gettext to the default configure.args; it successfully compiles for me on 10.4, but then, the port compiled for me on 10.3 and 10.4 without the change, too.

If this also breaks for someone, please attach a full build log to the bug.

Note: See TracTickets for help on using tickets.