Opened 13 years ago

Closed 13 years ago

#12683 closed defect (invalid)

rsync-Problem

Reported by: sboeser@… Owned by: kvv@…
Priority: Normal Milestone:
Component: server/hosting Version:
Keywords: Cc: boeyms@…, sboeser@…
Port:

Description

After getting the new 1.5 release, I am trying to update the database. However, rsync fails:

mycomputer:~>sudo port -d sync      
DEBUG: Synchronizing ports tree(s)
Synchronizing from rsync://rsync.macports.org/release/ports/
DEBUG: /usr/bin/rsync -rtzv --delete-after rsync://rsync.macports.org/release/ports/ /opt/local/var/macports/sources/rsync.macports.org/release/ports
rsync: failed to connect to rsync.macports.org: Operation timed out (60)
rsync error: error in socket IO (code 10) at /SourceCache/rsync/rsync-24.1/rsync/clientserver.c(94)
DEBUG: sync failed doing rsync
    while executing
"mportsync"
port sync failed: sync failed doing rsync

Thanks, Sebastian

Change History (3)

comment:1 Changed 13 years ago by nox@…

Component: baseinfrastructure
Owner: changed from macports-dev@… to kvv@…

duplicate of #12684

comment:2 Changed 13 years ago by boeyms@…

Cc: boeyms@… sboeser@… added

Are you still having problems running port sync, or has it proven to be a transient network problem? It might also be worthwhile to double-check that you haven't just installed or changed any firewall or port filtering software so that it blocks port 873 (the one used by rsync).

comment:3 Changed 13 years ago by jmpp@…

Priority: HighNormal
Resolution: invalid
Status: newclosed
Version: 1.5.0

Our rsync server is up and running without problems:

$[juan @macbookpro: trunk](724/0,0) -> rsync rsync.macports.org::
release         MacPorts rsync release repository, providing the current MacPorts "released" sources and the ports tree.
trunk           MacPorts rsync "trunk" repository, providing experimental MacPorts sources in svn's trunk/base.
dpupdate        Legacy MacPorts rsync repository for backwards compatibility with 1.4.x releases, providing svn's trunk/base and the ports tree.
dpupdate1       Legacy MacPorts rsync repository for backwards compatibility with 1.4.x releases, providing the current MacPorts "released" sources.

So this must be a user-side network problem. Closing ticket as invalid.

-jmpp

PS: If it does indeed happen to be a recurrent problem please inform me directly, not Mac OS Forge admin personnel, thanks!

Note: See TracTickets for help on using tickets.