Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#12818 closed defect (fixed)

Bad platform specifier in octave portfile

Reported by: neal@… Owned by: stechert@…
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: Cc: neal@…, stechert@…, ryandesign (Ryan Schmidt)
Port:

Description

The platform selectors in the portfile for octave are "platform powerpc" and "platform i386"; I believe what was intended was "platform darwin powerpc" and "platform darwin i386", respectively. On Intel macs, this sets the wrong platform-specific options in the build, causing it to fail.

Change History (6)

comment:1 Changed 13 years ago by nox@…

Cc: stechert@… added
Milestone: Port Bugs

comment:2 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: neal@… ryandesign@… added

All these variants are doing is selecting which compiler to use. I for one don't see why powerpc users are being given gcc40 while intel users get gcc42. Why not let all users use gcc42? That would make more sense to me.

comment:3 Changed 13 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-dev@… to stechert@…

Could the maintainer please comment?

comment:4 Changed 13 years ago by ryandesign (Ryan Schmidt)

Oh: my suggestion to always use gcc42 is a duplicate of #12144.

comment:5 Changed 13 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

I removed the platform specifiers in r31183. See #12144. So I think we can close this bug too. Neal, if you still feel there's a problem in octave 2.9.15_0 or later, please reopen this ticket.

comment:6 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.