Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#12821 closed defect (worksforme)

openmotif destroot failure

Reported by: smithsm@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: openmotif Cc: ryandesign (Ryan Schmidt)
Port: openmotif

Description (last modified by jmpp@…)

OS X 10.4.10 mac book pro intel macports 1.5.2 Installing xpdf dependency openmotif 2.3.0

$  sudo port install xpdf

.....

--->  Fetching openmotif
--->  Attempting to fetch openmotif-2.3.0.tar.gz from ftp://ftp.ics.com/openmotif/2.3/2.3.0/
--->  Verifying checksum(s) for openmotif
--->  Extracting openmotif
--->  Configuring openmotif
--->  Building openmotif with target all
--->  Staging openmotif into destroot
Error: Target org.macports.destroot returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/openmotif-2.3.0" && make install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/destroot " returned error 2
Command output: chmod 644 /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/destroot/opt/local/lib/libUil.a
ranlib /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/destroot/opt/local/lib/libUil.a
libtool: install: warning: remember to run `libtool --finish /opt/local/lib'
test -z "/opt/local/bin" || /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/openmotif-2.3.0/install-sh -d "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/destroot/opt/local/bin"
  /bin/sh ../../libtool --mode=install /usr/bin/install -c 'uil' '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/destroot/opt/local/bin/uil'
libtool: install: warning: `../../lib/Mrm/libMrm.la' has not been installed in `/opt/local/lib'
libtool: install: warning: `/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/openmotif-2.3.0/lib/Xm/libXm.la' has not been installed in `/opt/local/lib'
libtool: install: warning: `../../lib/Xm/libXm.la' has not been installed in `/opt/local/lib'
/usr/bin/install -c .libs/uil /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/destroot/opt/local/bin/uil
test -z "/opt/local/include/uil" || /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/openmotif-2.3.0/install-sh -d "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/destroot/opt/local/include/uil"
 /usr/bin/install -c -m 644 'Uil.h' '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/destroot/opt/local/include/uil/Uil.h'
 /usr/bin/install -c -m 644 'UilSymGl.h' '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/destroot/opt/local/include/uil/UilSymGl.h'
 /usr/bin/install -c -m 644 'UilSymDef.h' '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/destroot/opt/local/include/uil/UilSymDef.h'
 /usr/bin/install -c -m 644 'UilDef.h' '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/destroot/opt/local/include/uil/UilDef.h'
 /usr/bin/install -c -m 644 'XmAppl.uil' '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/destroot/opt/local/include/uil/XmAppl.uil'
make[3]: Nothing to be done for `install-exec-am'.
make[3]: Nothing to be done for `install-data-am'.
Making install in doc
Making install in man
Making install in man1
make[4]: Nothing to be done for `install-exec-am'.
test -z "/opt/local/share/man/man1" || /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/openmotif-2.3.0/install-sh -d "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/destroot/opt/local/share/man/man1"
 /usr/bin/install -c -m 644 './mwm.1' '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/destroot/opt/local/share/man/man1/mwm.1'
 /usr/bin/install -c -m 644 './uil.1' '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/destroot/opt/local/share/man/man1/uil.1'
 /usr/bin/install -c -m 644 './xmbind.1' '/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_openMotif/work/destroot/opt/local/share/man/man1/xmbind.1'
Making install in man3
Makefile:54: *** missing separator.  Stop.
make[2]: *** [install-recursive] Error 1
make[1]: *** [install-recursive] Error 1
make: *** [install-recursive] Error 1

Error: The following dependencies failed to build: openmotif t1lib
Error: Status 1 encountered during processing.
probook:samuel$

Change History (5)

comment:1 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: smithsm@… ryandesign@… added
Milestone: Port Bugs

Related to #12823?

comment:2 Changed 13 years ago by jmroot (Joshua Root)

Cc: smithsm@… removed
Priority: HighNormal
Summary: openmotift1lib fails to install missing separatoropenmotif destroot failure

#12823 mentions that using the universal variant made the install work.

comment:3 Changed 13 years ago by jmpp@…

Description: modified (diff)

comment:4 Changed 12 years ago by ryandesign (Ryan Schmidt)

Port: openmotif added
Resolution: worksforme
Status: newclosed

I'm unable to reproduce this problem with openmotif 2.3.0_2 on a MacBook Pro with Mac OS X 10.4.11, Xcode 2.5 and MacPorts built from trunk. Please re-open if you still experience the issue.

comment:5 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.