Opened 13 years ago

Closed 13 years ago

#12828 closed defect (invalid)

Fontconfig incompatibility

Reported by: djrs@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.5.0
Keywords: fontconfig Cc:
Port:

Description

I've installed ImageMagick using MacPorts 1.520 on my Intel Mac. As part of the installation it also installed fontconfig. However I'm getting this error with any program that links to libfontconfig:

dyld: Library not loaded: /opt/local/lib/libfontconfig.1.dylib Referenced from: /opt/local/bindisplay Reason: Incompatible library version: display requires version 4.0.0 or later, but libfontconfig.1.dylib provides version 2.0.0

As far as I am aware, fontconfig is only up to v2.x

Change History (2)

comment:1 Changed 13 years ago by djrs@…

please close - found a rogue instance of fontconfig that was being linked to (rather than the one installed by ImageMagick)

comment:2 Changed 13 years ago by nox@…

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.