Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#13014 closed submission (fixed)

dsh - distributed shell Portfiles

Reported by: bjorn@… Owned by: raimue (Rainer Müller)
Priority: Normal Milestone:
Component: ports Version: 1.5.0
Keywords: Cc: raimue (Rainer Müller)
Port:

Description

Portfiles for dsh and libdshconfig

Attachments (3)

Portfile.2 (823 bytes) - added by bjorn@… 13 years ago.
net/libdshconfig/Portfile
Portfile (793 bytes) - added by bjorn@… 13 years ago.
net/dsh/Portfile
patch-dsh.conf (250 bytes) - added by bjorn@… 13 years ago.
net/dsh/files/patch-dsh.conf - This makes ssh the default; few people these days use rsh, so the old defaults don't make sense.

Download all attachments as: .zip

Change History (13)

Changed 13 years ago by bjorn@…

Attachment: Portfile.2 added

net/libdshconfig/Portfile

Changed 13 years ago by bjorn@…

Attachment: Portfile added

net/dsh/Portfile

Changed 13 years ago by bjorn@…

Attachment: patch-dsh.conf added

net/dsh/files/patch-dsh.conf - This makes ssh the default; few people these days use rsh, so the old defaults don't make sense.

comment:1 Changed 13 years ago by raimue (Rainer Müller)

Cc: raimue@… added

Does not build on Mac OS X 10.5 Leopard.

--->  Building libdshconfig with target all
make  all-am
if /bin/sh ./libtool --mode=compile ccache /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I. -I.  -I/opt/local/include  -O2 -MT libdshconfig.lo -MD -MP -MF ".deps/libdshconfig.Tpo" \
          -c -o libdshconfig.lo `test -f 'libdshconfig.c' || echo './'`libdshconfig.c; \
        then mv -f ".deps/libdshconfig.Tpo" ".deps/libdshconfig.Plo"; \
        else rm -f ".deps/libdshconfig.Tpo"; exit 1; \
        fi
mkdir .libs
 ccache /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I. -I. -I/opt/local/include -O2 -MT libdshconfig.lo -MD -MP -MF .deps/libdshconfig.Tpo -c libdshconfig.c  -fno-common -DPIC -o .libs/libdshconfig.o
 ccache /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I. -I. -I/opt/local/include -O2 -MT libdshconfig.lo -MD -MP -MF .deps/libdshconfig.Tpo -c libdshconfig.c -o libdshconfig.o >/dev/null 2>&1
/bin/sh ./libtool --mode=link ccache /usr/bin/gcc-4.0  -O2  -L/opt/local/lib -o libdshconfig.la -rpath /opt/local/lib -export-dynamic -version-info 1:0:0 libdshconfig.lo  
libtool: link: unable to infer tagged configuration
libtool: link: specify a tag with `--tag'
make[1]: *** [libdshconfig.la] Error 1
make: *** [all] Error 2

comment:2 Changed 13 years ago by bjorn@…

It does compile for me on OS X Leopard. I've got a Macbook, upgraded from OS X Tiger some months ago.

% gcc --version
i686-apple-darwin9-gcc-4.0.1 (GCC) 4.0.1 (Apple Inc. build 5465)
Copyright (C) 2005 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Strange.

comment:3 Changed 13 years ago by jmroot (Joshua Root)

Raim, does this work for you now that #14503 is fixed?

comment:4 Changed 13 years ago by raimue (Rainer Müller)

No, it still does not work. I get the same error message as above.

comment:5 in reply to:  4 Changed 13 years ago by bjorn@…

Replying to raimue@macports.org:

No, it still does not work. I get the same error message as above.

I can't reproduce this error, but looking online it seems that the generated libtool has a different CXX tag setting encoded than what passed to it when trying to compile. I guess it could be related to which compiler you have installed and are using? Could it be that dependent libraries are compiled with a different compiler?

comment:6 Changed 12 years ago by jmroot (Joshua Root)

I remember people were having issues when running MacPorts 1.6.0 or later and their libtool had been built with an earlier version. (Earlier versions set CXX=g++-4.0 and 1.6.0+ sets CXX=/usr/bin/g++-4.0.) Could this be the problem for you, Rainer?

comment:7 Changed 12 years ago by raimue (Rainer Müller)

Owner: changed from macports-tickets@… to raimue@…
Status: newassigned

comment:8 Changed 12 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: assignedclosed

Finally got it to build. I added a pre-configure phase to libdshconfig which calls autoreconf.

Committed in r38418 and r38419.

comment:9 Changed 12 years ago by jmroot (Joshua Root)

Type: enhancementsubmission

comment:10 Changed 12 years ago by (none)

Milestone: Port Submissions

Milestone Port Submissions deleted

Note: See TracTickets for help on using tickets.