Opened 17 years ago

Closed 15 years ago

#1307 closed defect (invalid)

Can't install any ports

Reported by: pixelcort@… Owned by: macports-tickets@…
Priority: High Milestone:
Component: base Version: 1.0
Keywords: Cc:
Port:

Description

port -vd install lynx (or any package port knows about) causes the installation procedure to commence. destroot step functions properly however final install does not. I have been manually copying data over from the created destroot, however since I am doing this separately from port other ports that depend on it will not be able to be installed.

In debug mode, the system seems to not go past the following step:

DEBUG: Executing com.apple.install (lynx) DEBUG: installing file: /opt/local/bin/lynx

top shows tclsh8.4 running with a consistent positive amount of cpu and time usage.

It seems to currectly copy lynx to /opt/local/bin/lynx completely, however no other files are installed. (Libraries, etc...)

It seems to get stuck after installing the first file, then.

Change History (4)

comment:1 Changed 17 years ago by waldmire@…

Resolution: invalid
Status: newclosed

More information is needed. What version of Darwin are you using? I am using Darwin 7 on x86 and DarwinPorts works fine (not all ports build, but the port systems works).

comment:2 Changed 17 years ago by pixelcort@…

Resolution: invalid
Status: closedreopened

Darwin 7.0.1 x86

comment:3 Changed 16 years ago by toby@…

Component: dportsbase

comment:4 Changed 15 years ago by pguyot (Paul Guyot)

Resolution: invalid
Status: reopenedclosed

This is more than one year old and we didn't get enough information to check and fix the problem.

Note: See TracTickets for help on using tickets.