Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#13147 closed defect (worksforme)

gnuplot/pdflib not building

Reported by: darrell@… Owned by: pguyot (Paul Guyot)
Priority: Normal Milestone:
Component: ports Version: 1.5.0
Keywords: Cc:
Port:

Description (last modified by jmpp@…)

Looks like pdflib is the culprit.

It would also be good if this did not build teTeX if another version of TeX is installed (TeXLive, since teTeX is deprecated).

Chrysophylax:~ darrell$ sudo port install gnuplot
--->  Building pdflib with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_print_pdflib/work/PDFlib-Lite-7.0.1" && make all " returned error 2
Command output: ar: ./p_fields.lo: Too many levels of symbolic links
ar: ./p_gif.lo: Too many levels of symbolic links
ar: ./p_image.lo: Too many levels of symbolic links
ar: ./p_jpeg.lo: Too many levels of symbolic links
ar: ./p_jpx.lo: Too many levels of symbolic links
ar: ./p_object.lo: Too many levels of symbolic links
ar: ./p_opi.lo: Too many levels of symbolic links
ar: ./p_page.lo: Too many levels of symbolic links
ar: ./p_params.lo: Too many levels of symbolic links
ar: ./p_pattern.lo: Too many levels of symbolic links
ar: ./p_photoshp.lo: Too many levels of symbolic links
ar: ./p_png.lo: Too many levels of symbolic links
ar: ./p_template.lo: Too many levels of symbolic links
ar: ./p_tiff.lo: Too many levels of symbolic links
ar: ./p_type3.lo: Too many levels of symbolic links
ar: ./p_util.lo: Too many levels of symbolic links
make[2]: [../../libs/pdflib/libpdf_.la] Error 1 (ignored)
../../libtool --silent --mode=link gcc -L/opt/local/lib -framework ApplicationServices -o libpdf.la -rpath /opt/local/lib -version-info 6:1:0 ./pdflib.lo ../../libs/pdcore/libpdcore.la ../../libs/png/libpng.la ../../libs/flate/libz.la ../../libs/tiff/libtiff.la  ../../libs/font/libfont.la ../../libs/jpeg/libjpeg.la ../../libs/pdflib/libpdf_.la     -export-dynamic
libtool: link: cannot find the library `../../libs/pdflib/libpdf_.la'
make[2]: [libpdf.la] Error 1 (ignored)
../../libtool --silent --mode=link gcc -L/opt/local/lib -framework ApplicationServices -o libs_libpdf.la ./pdflib.lo ../../libs/pdcore/libpdcore.la ../../libs/png/libpng.la ../../libs/flate/libz.la ../../libs/tiff/libtiff.la  ../../libs/font/libfont.la ../../libs/jpeg/libjpeg.la ../../libs/pdflib/libpdf_.la    
libtool: link: cannot find the library `../../libs/pdflib/libpdf_.la'
make[2]: [libpdf.la] Error 1 (ignored)
make[3]: *** No rule to make target `../../../libs/pdflib/libs_libpdf.la', needed by `hello'.  Stop.
make[3]: *** No rule to make target `../../../libs/pdflib/libs_libpdf.la', needed by `hello'.  Stop.
make[2]: *** [all] Error 2
make[1]: *** [all] Error 2
make[2]: *** No rule to make target `../../libs/pdflib/libs_libpdf.la', needed by `pdfimpose'.  Stop.
make[1]: *** [all] Error 2
make: *** [all] Error 2

Error: The following dependencies failed to build: pdflib teTeX
Error: Status 1 encountered during processing.

Change History (4)

comment:1 Changed 13 years ago by cssdev

Owner: changed from macports-dev@… to pguyot@…

Assigning to the port maintainer

comment:2 Changed 13 years ago by pguyot (Paul Guyot)

Resolution: worksforme
Status: newclosed

I'm confused. The problem seems to occur with pdflib, not gnuplot, and I cannot reproduce it.

comment:3 Changed 13 years ago by jmpp@…

Description: modified (diff)
Milestone: Port Bugs

comment:4 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.