Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#13168 closed defect (duplicate)

orbit2 and leopard 10.5 (giop-endian.h)

Reported by: schroeder@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: 10.5, orbit2 Cc:
Port:

Description

--> Building orbit2 with target all Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_orbit2/work/ORBit2-2.14.10" && make all " returned error 2 Command output: true

(rm -f corba-ops-stubs.c corba-ops-common.c corba-ops-skels.c corba-ops.h
true) > /dev/null

../../../src/idl-compiler/orbit-idl-2 --showcpperrors --deps .deps/corba-ops.idl.P corba-ops.idl orbit-idl-2 2.14.10 compiling

mode, show preprocessor errors, passes: stubs skels common headers

Processing file corba-ops.idl cc1: note: obsolete option -I- used, please use -iquote instead for I in corba-ops-stubs.c corba-ops-common.c corba-ops-skels.c corba-ops.h; do\

sed -e 's,ZZZis_a,_is_a,g' -e 's,ZZis_a,is_a,g' $I > $I.out; mv $I.out $I; \

done; \ sed -e "s,Z,_,g" corba-ops-skels.c > corba-ops-skels.c.out; \ mv corba-ops-skels.c.out corba-ops-skels.c;

true make all-am make[6]: Nothing to be done for `all'. /bin/sh ../../../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I../../.. -I. -I. -I../../../include -I../../../include/orbit/orb-core -I../../../include -I../../../include/orbit/orb-core -DORBIT_TYPELIB_DIR=\""/opt/local/lib/orbit-2.0"\" -DORBIT2_INTERNAL_API -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations -DG_DISABLE_DEPRECATED -I../../../linc2/include -I../../../linc2/include -D_REENTRANT -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include -O2 -Werror-implicit-function-declaration -MT orbit-interface-common.lo -MD -MP -MF .deps/orbit-interface-common.Tpo -c -o orbit-interface-common.lo orbit-interface-common.c

gcc -DHAVE_CONFIG_H -I. -I../../.. -I. -I. -I../../../include -I../../../include/orbit/orb-core -I../../../include -I../../../include/orbit/orb-core -DORBIT_TYPELIB_DIR=\"/opt/local/lib/orbit-2.0\" -DORBIT2_INTERNAL_API -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations -DG_DISABLE_DEPRECATED -I../../../linc2/include -I../../../linc2/include -D_REENTRANT -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include -O2 -Werror-implicit-function-declaration -MT orbit-interface-common.lo -MD -MP -MF .deps/orbit-interface-common.Tpo -c orbit-interface-common.c -fno-common -DPIC -o .libs/orbit-interface-common.o

In file included from ../../../include/orbit/GIOP/giop.h:12,

from ../../../include/orbit/orbit.h:15, from ../../../include/orbit/orb-core/orbit-interface.h:738, from orbit-interface-common.c:9:

../../../include/orbit/GIOP/giop-endian.h:19: error: static declaration of 'giop_byteswap' follows non-static declaration ../../../include/orbit/GIOP/giop-endian.h:13: error: previous declaration of 'giop_byteswap' was here make[5]: * [orbit-interface-common.lo] Error 1 make[4]: * [all] Error 2 make[3]: * [all-recursive] Error 1 make[2]: * [all-recursive] Error 1 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

Change History (3)

comment:1 Changed 13 years ago by nox@…

Milestone: MacPorts 1.5Port Bugs
Priority: HighNormal

Duplicate of #13160.

comment:2 Changed 13 years ago by afb@…

Resolution: duplicate
Status: newclosed

comment:3 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.