New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #13255 (closed defect: duplicate)

Opened 6 years ago

Last modified 5 years ago

cdf fails to build

Reported by: jwhowse4@… Owned by: gwright@…
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: Cc:
Port:

Description

While trying to install the opendx package, compilation fails with the following error messages. Any ideas on how to fix this?

gfortran-mp-4.2 -w -fsecond-underscore -c qst2f.f gfortran-mp-4.2 -o qst2f qst2f.o ../lib/libcdf.a -L/Developer/SDKs/MacOSX10.4u.sdk/usr/lib -L/usr/lib/gcc/i686-apple-darwin8/4.0.1 -lm -lc -lgcc -lSystemStubs /usr/bin/ld: warning prebinding disabled because dependent library: /opt/macports/lib/gcc42/libgfortran.2.dylib is not prebound /usr/bin/ld: Undefined symbols: _cdf_attr_create _cdf_attr_entry_inquire _cdf_attr_get _cdf_attr_inquire _cdf_attr_num _cdf_attr_put _cdf_attr_rename _cdf_close _cdf_create _cdf_delete _cdf_doc _cdf_error _cdf_inquire _cdf_open _cdf_var_close _cdf_var_create _cdf_var_get _cdf_var_hyper_get _cdf_var_hyper_put _cdf_var_inquire _cdf_var_num _cdf_var_put _cdf_var_rename _compute_epoch _encode_epoch1 _encode_epoch2 _encode_epoch3 _encode_epoch _epoch_breakdown _parse_epoch1 _parse_epoch2 _parse_epoch3 _parse_epoch collect2: ld returned 1 exit status make[1]: * [qst2f] Error 1 make: * [all.build] Error 2 Error: Target org.macports.build returned: shell command "make OS=macosx ENV=i386 FORTRAN=yes FC=gfortran-mp-4.2 all" returned error 2 Command output: _cdf_attr_rename _cdf_close _cdf_create _cdf_delete _cdf_doc _cdf_error _cdf_inquire _cdf_open _cdf_var_close _cdf_var_create _cdf_var_get _cdf_var_hyper_get _cdf_var_hyper_put _cdf_var_inquire _cdf_var_num _cdf_var_put _cdf_var_rename _compute_epoch _encode_epoch1 _encode_epoch2 _encode_epoch3 _encode_epoch _epoch_breakdown _parse_epoch1 _parse_epoch2 _parse_epoch3 _parse_epoch collect2: ld returned 1 exit status make[1]: * [qst2f] Error 1 make: * [all.build] Error 2

Warning: the following items did not execute (for cdf): org.macports.activate org.macports.build org.macports.destroot org.macports.install Error: The following dependencies failed to build: cdf cosmoplayer opendx-java40 Error: Status 1 encountered during processing.

Change History

comment:1 Changed 6 years ago by nox@…

  • Cc gwright@… added
  • Milestone set to Port Bugs
  • Summary changed from opendx compilation fails to opendx fails to build

comment:2 follow-up: ↓ 3 Changed 6 years ago by gwright@…

  • Status changed from new to assigned

What's the hardware and the OS version you're using?

-Greg

comment:3 in reply to: ↑ 2 Changed 6 years ago by jwhowse4@…

Replying to gwright@macports.org:

What's the hardware and the OS version you're using?

-Greg

I am using a MacBook Pro with Intel Core Duo running Tiger 10.4.10 -James

comment:4 Changed 6 years ago by andrew@…

See bug 12988 for the fix

comment:5 Changed 6 years ago by jmr@…

  • Status changed from assigned to closed
  • Cc gwright@… removed
  • Resolution set to duplicate
  • Summary changed from opendx fails to build to cdf fails to build

Duplicate of #12988.

comment:6 Changed 5 years ago by anonymous

  • Milestone Port Bugs deleted

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.