Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#13334 closed defect (fixed)

libnet fails to build, config.guess and config.sub not found

Reported by: tomasz@… Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: libnet config.guess config.stub Cc: jim@…
Port:

Description

Install for libnet is failing with

Error: Target org.macports.configure returned: error copying "/usr/share/libtool/config.guess": no such file or directory Warning: the following items did not execute (for libnet): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install Error: Status 1 encountered during processing.

This system path/file does not exist on OS X 10.4.11

The closest matches that I can are is

/opt/local/share/libtool/config.guess

/opt/local/share/libtool/config.sub

Substituting these paths in the Portfile allows the package to be created and installed

Attachments (1)

libnet-install-debug (3.9 KB) - added by tomasz@… 13 years ago.

Download all attachments as: .zip

Change History (11)

Changed 13 years ago by tomasz@…

Attachment: libnet-install-debug added

comment:1 Changed 13 years ago by nox@…

Cc: jim@… added
Milestone: Port Bugs
Summary: libnet fails build during copy of nonexistant config.guess & config.sublibnet fails to build, config.guess and config.sub not found

I'm adding libnet maintainer to Cc field

comment:2 Changed 13 years ago by ryandesign (Ryan Schmidt)

/usr/share/libtool/config.guess does exist on my 10.4.11 Intel system. Its modification date is September 12, 2006, which is the same modification date as about 2500 items in /System, so it's a safe bet this was installed by Mac OS X. So the question is why it is not on your system.

comment:3 Changed 13 years ago by ryandesign (Ryan Schmidt)

I checked with a friend running 10.5.1 Intel, and /usr/share/libtool/config.guess is present there too.

comment:4 Changed 13 years ago by cssdev

Strange, I do not have it with 10.4.11 on my MacBook Pro either, and the lack of that directory seems to cause trouble for libsdl_sound (see #13736). I reinstalled XCode 2.5, but there's still no /usr/share/libtool directory on my Mac. Could someone perhaps check their boms to find which package installed it?

$ lsbom /Library/Receipts/*.pkg/Contents/Archive.bom | grep 'usr/share/libtool'

comment:5 Changed 13 years ago by cssdev

After some digging, I found /usr/share/libtool on my Mac OS X Install Disc 1, within DeveloperTools.pkg. Strangely, the XCode 2.5 DeveloperTools.pkg does not include those files! Maybe I need to reinstall the developer tools from the DVD, and then I'll install XCode 2.5.

comment:6 Changed 13 years ago by afb@…

The files are installed by Xcode 2.4(.1) and earlier

comment:7 Changed 13 years ago by afb@…

/usr/share/libtool is missing from DeveloperToolsCLI.pkg of Xcode 2.5, even though it was present in the the DeveloperTools.pkg of Xcode 2.4 - although both packages provide the /usr/bin/glibtool program.

So "upgrading" from Xcode 2.4.1 to Xcode 2.5 will delete the required config.guess and config.sub files.

comment:8 Changed 13 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to ryandesign@…

comment:9 Changed 13 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

Since the maintainer hasn't responded to this, I fixed it in r33146.

comment:10 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.