Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#13377 closed defect (duplicate)

python25 build error

Reported by: rhwood@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port:

Description

Python25 fails to build with undefined symbols:

libtool -o libpython2.5.dylib -dynamic  \
        -all_load libpython2.5.a -single_module \
        -install_name /opt/local/lib/libpython2.5.dylib \
        -compatibility_version 2.5 \
        -current_version 2.5 -lSystem -lSystemStubs -L/opt/local/lib
ld: for architecture ppc
ld: warning prebinding disabled because of undefined symbols
ld: Undefined symbols:
restFP
saveFP
libtool: internal link edit command failed
make: *** [libpython2.5.dylib] Error 1

Warning: the following items did not execute (for python25): org.macports.activa
te org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

Attachments (1)

install.log (63.5 KB) - added by rhwood@… 13 years ago.
Log of "sudo port install python25 > install.log 2>&1"

Download all attachments as: .zip

Change History (7)

Changed 13 years ago by rhwood@…

Attachment: install.log added

Log of "sudo port install python25 > install.log 2>&1"

comment:1 Changed 13 years ago by rhwood@…

Reverting the python25 portfile to revision 30877 works for me.

comment:2 Changed 13 years ago by ebgssth@…

duplicate of #13322?

comment:3 Changed 13 years ago by paulbeard@…

I agree this looks like a dupe of 13322. This patch works for PPC hardware, as it drops back to the 3.3 compiler but since it doesn't build Intel/Universal binaries, it's not a complete solution. It may, however, point to the real solution for someone more up to speed on how compilers work.

--- Portfile    2007-11-19 12:21:26.000000000 -0800
+++ /tmp/Portfile       2007-11-22 13:58:08.000000000 -0800
@@ -67,8 +67,8 @@
 }

 platform darwin 8 {
-       configure.compiler      gcc-4.0
-       configure.args-append   --with-cxx=/usr/bin/g++-4.0
+       configure.compiler      gcc-3.3
+       configure.args-append   --with-cxx=/usr/bin/g++-3.3
 }

 platform darwin 9 {

comment:4 Changed 13 years ago by rhwood@…

The changes between 2.5.1_2 and 2.5.1_3 appear to be configuration flags.

comment:5 Changed 13 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #13322.

comment:6 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.