Opened 12 years ago

Closed 12 years ago

Last modified 10 years ago

#13455 closed defect (fixed)

mp3info doesn't compile on Leopard PPC

Reported by: ken@… Owned by: jmroot (Joshua Root)
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: mp3info Cc:
Port:

Description (last modified by jmpp@…)

On a PPC leopard install, I get:

# port install mp3info
--->  Fetching mp3info
--->  Verifying checksum(s) for mp3info
--->  Extracting mp3info
--->  Configuring mp3info
--->  Building mp3info with target mp3info
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_audio_mp3info/work/mp3info-0.8.5a" && make mp3info " returned error 2
Command output: gcc -g -O2 -Wall   -c -o mp3info.o mp3info.c
gcc -g -O2 -Wall   -c -o textfunc.o textfunc.c
gcc -g -O2 -Wall   -c -o mp3curs.o mp3curs.c
gcc -g -O2 -Wall   -c -o mp3tech.o mp3tech.c
mp3tech.c: In function 'sameConstant':
mp3tech.c:282: error: 'uint' undeclared (first use in this function)
mp3tech.c:282: error: (Each undeclared identifier is reported only once
mp3tech.c:282: error: for each function it appears in.)
mp3tech.c:282: error: syntax error before ')' token
mp3tech.c:282: error: syntax error before ')' token
make: *** [mp3tech.o] Error 1

Error: Status 1 encountered during processing.

A patch to fix the problem is attached.

Attachments (2)

uint.patch (417 bytes) - added by ken@… 12 years ago.
A patch to change the only "uint" references to "unsigned int"
portfile.patch (397 bytes) - added by ken@… 12 years ago.
The simple change to the portfile

Download all attachments as: .zip

Change History (7)

Changed 12 years ago by ken@…

Attachment: uint.patch added

A patch to change the only "uint" references to "unsigned int"

Changed 12 years ago by ken@…

Attachment: portfile.patch added

The simple change to the portfile

comment:1 Changed 12 years ago by jmpp@…

Description: modified (diff)

comment:2 Changed 12 years ago by jmpp@…

Milestone: Port Bugs

comment:3 Changed 12 years ago by jmroot (Joshua Root)

Cc: nomaintainer@… ken@… removed
Owner: changed from macports-tickets@… to jmr@…
Status: newassigned

comment:4 Changed 12 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: assignedclosed

Committed in r34602. Thanks!

comment:5 Changed 10 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.