Opened 13 years ago

Closed 10 years ago

#13474 closed defect (fixed)

dsocks: symbols referenced by relocation entries that can't be stripped

Reported by: christopher.grim@… Owned by: boeyms@…
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: Cc: rene@…
Port: dsocks

Description

dsocks 1.6 failed to install on 10.5.1 (Intel):

$ sudo port install dsocks
--->  Fetching dsocks
--->  Attempting to fetch dsocks-1.6.tar.gz from http://monkey.org/~dugsong/dsocks/
--->  Verifying checksum(s) for dsocks
--->  Extracting dsocks
--->  Applying patches to dsocks
--->  Configuring dsocks
--->  Building dsocks with target all
--->  Staging dsocks into destroot
Error: Target org.macports.destroot returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_dsocks/work/dsocks-1.6" && bsdmake install DESTDIR=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_dsocks/work/destroot LIBDIR=/opt/local/lib " returned error 1
Command output: "/usr/share/mk/bsd.compat.mk", line 36: warning: NOPROFILE is deprecated in favor of NO_PROFILE
install -C -o root -g wheel -m 444   libdsocks.a /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_dsocks/work/destroot/opt/local/lib
ranlib /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_dsocks/work/destroot/opt/local/lib/libdsocks.a
install -s -o root -g wheel -m 444     libdsocks.1.dylib /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_dsocks/work/destroot/opt/local/lib
strip: symbols referenced by relocation entries that can't be stripped in: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_dsocks/work/destroot/opt/local/lib/libdsocks.1.dylib
__dsocks_init
_atomicio
_connect$UNIX2003
*** Error code 70

Stop in /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_net_dsocks/work/dsocks-1.6.

Error: Status 1 encountered during processing.

It installed successfully with STRIP disabled.

Attachments (2)

dsocks-Portfile.diff (386 bytes) - added by christopher.grim@… 13 years ago.
Portfile.diff (422 bytes) - added by rene@… 12 years ago.

Download all attachments as: .zip

Change History (9)

Changed 13 years ago by christopher.grim@…

Attachment: dsocks-Portfile.diff added

comment:1 Changed 13 years ago by jmpp@…

Milestone: Port Bugs

comment:2 Changed 13 years ago by boeyms@…

Owner: changed from macports-tickets@… to boeyms@…

Christopher, could you tell me how you disabled STRIP? Hopefully I can then add that to the Portfile to fix the problem. It looks pretty clear to me that this is a Leopard-only problem (I can't reproduce it on 10.4 PPC G5 or 10.4 Intel, and I don't currently have a Leopard machine).

In addition, would you be able to contact dsocks's author about this bug? Even if I had a Leopard machine, this bug looks beyond my ability to fix.

comment:3 Changed 12 years ago by rene@…

Cc: rene@… added

Cc Me!

comment:4 Changed 12 years ago by rene@…

This problem still persists. I have attached Portfile.diff which adds Christopher's solution for leopard builds only. It is meant to be temorary and should be removed when a new version of dports is released. However, there are some more leopard and osx related fixes in the dsocks svn repository. But I can't find any information on when a new version will be released.

Changed 12 years ago by rene@…

Attachment: Portfile.diff added

comment:5 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:6 Changed 10 years ago by ryandesign (Ryan Schmidt)

Keywords: dsocks strip removed
Port: dsocks added
Summary: dsocks 1.6 install errordsocks: symbols referenced by relocation entries that can't be stripped

See also #22695 which is a similar report for Snow Leopard.

comment:7 Changed 10 years ago by jmroot (Joshua Root)

Keywords: leopard removed
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.