Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#13495 closed defect (fixed)

Error with included tclthread when attempting selfupdate on Leopard

Reported by: sydbarrett74@… Owned by: macports-tickets@…
Priority: Normal Milestone: MacPorts 1.7.0
Component: base Version: 1.5.0
Keywords: selfupdate error Cc:
Port:

Description (last modified by jmpp@…)

OS: Leopard x86 Macports version: 1.5.0 GCC version: 4.0.1

$ sudo port selfupdate
Password:
MacPorts base version 1.5 installed
Downloaded MacPorts base version 1.520
Configuring, Building and Installing new MacPorts base
Error: /opt/local/bin/port: selfupdate failed: Error installing new MacPorts base: shell command "cd /opt/local/var/macports/sources/rsync.macports.org/release/base && ./configure --prefix=/opt/local --with-install-user=root --with-install-group=admin --with-tclpackage=/Library/Tcl && make && make install" returned error 2
Command output: checking for struct stat64... yes
checking for off64_t... no
checking for build with symbols... no
checking for tclsh... /usr/lib/../bin/tclsh8.4
configure: creating ./config.status
config.status: creating Makefile
config.status: creating pkgIndex.tcl
===> making all in config
make[1]: Nothing to be done for `all'.
===> making all in doc
make[1]: Nothing to be done for `all'.
===> making all in src
===> making all in src/thread2.6
gcc -pipe -DPACKAGE_NAME=\"thread\" -DPACKAGE_TARNAME=\"thread\" -DPACKAGE_VERSION=\"2.6\" -DPACKAGE_STRING=\"thread\ 2.6\" -DPACKAGE_BUGREPORT=\"\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DNO_VALUES_H=1 -DHAVE_LIMITS_H=1 -DHAVE_SYS_PARAM_H=1 -DUSE_THREAD_ALLOC=1 -D_REENTRANT=1 -D_THREAD_SAFE=1 -DHAVE_PTHREAD_ATTR_SETSTACKSIZE=1 -DHAVE_READDIR_R=1 -DTCL_THREADS=1 -DTCL_WIDE_INT_TYPE=long\ long -DHAVE_STRUCT_STAT64=1 -DUSE_TCL_STUBS=1   -I"/usr/include"    -Os -Wall -Wno-implicit-int -fno-common -c `echo ./generic/threadCmd.c` -o threadCmd.o
./generic/threadCmd.c: In function 'ThreadBroadcastObjCmd':
./generic/threadCmd.c:1002: warning: 'job.clientData' is used uninitialized in this function
gcc -pipe -DPACKAGE_NAME=\"thread\" -DPACKAGE_TARNAME=\"thread\" -DPACKAGE_VERSION=\"2.6\" -DPACKAGE_STRING=\"thread\ 2.6\" -DPACKAGE_BUGREPORT=\"\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DNO_VALUES_H=1 -DHAVE_LIMITS_H=1 -DHAVE_SYS_PARAM_H=1 -DUSE_THREAD_ALLOC=1 -D_REENTRANT=1 -D_THREAD_SAFE=1 -DHAVE_PTHREAD_ATTR_SETSTACKSIZE=1 -DHAVE_READDIR_R=1 -DTCL_THREADS=1 -DTCL_WIDE_INT_TYPE=long\ long -DHAVE_STRUCT_STAT64=1 -DUSE_TCL_STUBS=1   -I"/usr/include"    -Os -Wall -Wno-implicit-int -fno-common -c `echo ./generic/threadSvCmd.c` -o threadSvCmd.o
./generic/threadSvCmd.c:2220: warning: 'SvFinalize' defined but not used
gcc -pipe -DPACKAGE_NAME=\"thread\" -DPACKAGE_TARNAME=\"thread\" -DPACKAGE_VERSION=\"2.6\" -DPACKAGE_STRING=\"thread\ 2.6\" -DPACKAGE_BUGREPORT=\"\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DNO_VALUES_H=1 -DHAVE_LIMITS_H=1 -DHAVE_SYS_PARAM_H=1 -DUSE_THREAD_ALLOC=1 -D_REENTRANT=1 -D_THREAD_SAFE=1 -DHAVE_PTHREAD_ATTR_SETSTACKSIZE=1 -DHAVE_READDIR_R=1 -DTCL_THREADS=1 -DTCL_WIDE_INT_TYPE=long\ long -DHAVE_STRUCT_STAT64=1 -DUSE_TCL_STUBS=1   -I"/usr/include"    -Os -Wall -Wno-implicit-int -fno-common -c `echo ./generic/threadSpCmd.c` -o threadSpCmd.o
./generic/threadSpCmd.c: In function 'ThreadEvalObjCmd':
./generic/threadSpCmd.c:684: warning: 'mutex' may be used uninitialized in this function
gcc -pipe -DPACKAGE_NAME=\"thread\" -DPACKAGE_TARNAME=\"thread\" -DPACKAGE_VERSION=\"2.6\" -DPACKAGE_STRING=\"thread\ 2.6\" -DPACKAGE_BUGREPORT=\"\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DNO_VALUES_H=1 -DHAVE_LIMITS_H=1 -DHAVE_SYS_PARAM_H=1 -DUSE_THREAD_ALLOC=1 -D_REENTRANT=1 -D_THREAD_SAFE=1 -DHAVE_PTHREAD_ATTR_SETSTACKSIZE=1 -DHAVE_READDIR_R=1 -DTCL_THREADS=1 -DTCL_WIDE_INT_TYPE=long\ long -DHAVE_STRUCT_STAT64=1 -DUSE_TCL_STUBS=1   -I"/usr/include"    -Os -Wall -Wno-implicit-int -fno-common -c `echo ./generic/threadPoolCmd.c` -o threadPoolCmd.o
In file included from /usr/include/sys/time.h:77,
                 from ./generic/threadPoolCmd.c:1707:
/usr/include/sys/_structs.h: In function 'GetTime':
/usr/include/sys/_structs.h:192: error: nested functions are disabled, use -fnested-functions to re-enable
/usr/include/sys/_structs.h:192: error: invalid storage class for function '__darwin_fd_isset'
make[2]: *** [threadPoolCmd.o] Error 1
make[1]: *** [all] Error 1
make: *** [all] Error 1

Change History (6)

comment:1 Changed 13 years ago by jmpp@…

Component: portsbase
Description: modified (diff)
Milestone: MacPorts 1.5MacPorts base bugs

comment:2 Changed 13 years ago by afb@…

Summary: Error when attempting selfupdateError with included tclthread when attempting selfupdate on Leopard

thread2.6 has problems with Leopard. Wonder why it is trying to compile it, though ?

It should be in "/System/Library/Tcl/thread2.6", and be detected there by configure...

checking for Tcl configuration... found /usr/lib/tclConfig.sh
checking for existence of /usr/lib/tclConfig.sh... loading
checking for Tcl public headers... /usr/include
checking for tclsh... /usr/bin/tclsh
checking for Tcl package directory... /Library/Tcl
checking whether tclsh was compiled with threads... yes
checking for curl-config... /usr/bin/curl-config
checking for curl_easy_strerror in -lcurl... yes
checking for Tcl Thread package... yes
checking for sqlite3_open in -lsqlite3... yes
checking for Tcl sqlite3 location... /usr/lib/sqlite3

comment:3 Changed 13 years ago by afb@…

This problem is easily reproduced with:

./configure --with-included-tclthread

comment:4 in reply to:  description Changed 13 years ago by sydbarrett74@…

The problem is no longer being exhibited after I downloaded the 1.6.0 .pkg and ran it...

comment:5 Changed 13 years ago by afb@…

Resolution: fixed
Status: newclosed

Fixed in r36723.

comment:6 Changed 12 years ago by blb@…

Milestone: MacPorts base bugsMacPorts 1.7.0
Note: See TracTickets for help on using tickets.