Opened 12 years ago

Closed 11 years ago

Last modified 10 years ago

#13498 closed defect (fixed)

xephem 3.7 will not build on MacPorts 1.5.2 on Leopard

Reported by: michaelreed@… Owned by: jmroot (Joshua Root)
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: Cc: cabanela@…
Port:

Description (last modified by jmpp@…)

Hello,

When I try to build xephem on MacPorts 1.5.2/Leopard, I am getting the following:

--->  Building xephem
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_xephem/work/xephem-3.7/GUI/xephem" && make " returned error 2
Command output:       _si_newfim in skyip.o
  "_regionStats", referenced from:
      _si_doROI in skyip.o
      _si_doGlass in skyip.o
      _si_newfim in skyip.o
  "_fsmatch", referenced from:
      _wcsMatch in skyip.o
  "_getStringFITS", referenced from:
      _sf_getName in skyfits.o
      _sf_getName in skyfits.o
      _fitsObs in skyfits.o
      _setWCSField in skyip.o
  "_quickStars", referenced from:
      _wcsMatch in skyip.o
      _si_markstars_cb in skyip.o
  "_cmpStars", referenced from:
      _imPhotom in skyip.o
      _imPhotom in skyip.o
  "_setIntFITS", referenced from:
      _si_setContrast in skyip.o
      _si_setContrast in skyip.o
      _si_newfim in skyip.o
  "_clampRegion", referenced from:
      _imPhotom in skyip.o
      _si_doGlass in skyip.o
  "_writeFITS", referenced from:
      _save_file in skyfits.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make: *** [xephem] Error 1

Error: Status 1 encountered during processing.

Change History (6)

comment:1 Changed 12 years ago by skymoo (Adam Mercer)

Cc: cabanela@… added

#13524 has been marked as a duplicate of this bug

comment:2 Changed 12 years ago by skymoo (Adam Mercer)

after bumping the port to 3.7.2 the build fails, for me, on Intel Leopard with the following error:

gcc -L../../libastro -L../../libip -L../../liblilxml -L../../libjpegd -L../../libpng -L../../libz -g -L/usr/X11R6/lib -L/usr/X11R6/lib -o xephem aavso.o annotmenu.o broadcast.o calmenu.o closemenu.o compiler.o coordsmenu.o datamenu.o db.o dbmenu.o earthmap.o earthmenu.o fallbacks.o favmenu.o formats.o fsmenu.o gallerymenu.o glance.o gsc.o gscnet.o helpmenu.o homeio.o hznmenu.o indimenu.o imregmenu.o jpeg2pm.o jupmenu.o listmenu.o mainmenu.o marsmenu.o marsmmenu.o moonmenu.o moviemenu.o msgmenu.o netmenu.o objmenu.o obslog.o patchlevel.o plot_aux.o plotmenu.o preferences.o progress.o ps.o query.o rotated.o satmenu.o saveres.o scope.o sites.o skybinary.o skyeyep.o skyfifos.o skyfiltmenu.o skyfits.o skyhist.o skyip.o skylist.o skytoolbar.o skyviewmenu.o solsysmenu.o splash.o srchmenu.o sunmenu.o time.o tips.o trailmenu.o uranusmenu.o ucac.o usno.o versionmenu.o webdbmenu.o xe2.o xe3.o xephem.o xmisc.o /usr/X11R6/lib/libXm.a -lXp -lXt -lXext -lXmu -lX11 -lastro -lip -llilxml -ljpegd -lpng -lz -lm
i686-apple-darwin9-gcc-4.0.1: /usr/X11R6/lib/libXm.a: No such file or directory
make: *** [xephem] Error 1

comment:3 Changed 12 years ago by jmpp@…

Description: modified (diff)

comment:4 in reply to:  2 Changed 11 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to jmr@…
Status: newassigned

Replying to ram@macports.org:

after bumping the port to 3.7.2 the build fails, for me, on Intel Leopard with the following error:

The build.args need to be set as described in the INSTALL file. I've got it building now.

comment:5 Changed 11 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: assignedclosed

Update committed in r34642.

comment:6 Changed 10 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.