Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#13499 closed defect (fixed)

install of i386-elf-gcc fails on Leopard

Reported by: anders.blomdell@… Owned by: pguyot (Paul Guyot)
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: Cc:
Port:

Description

# port install i386-elf-gcc 
--->  Building i386-elf-gcc with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/build" && make all AR_FOR_TARGET=i386-elf-ar AS_FOR_TARGET=i386-elf-as LD_FOR_TARGET=i386-elf-ld NM_FOR_TARGET=i386-elf-nm RANLIB_FOR_TARGET=i386-elf-ranlib " returned error 2
Command output: make[2]: Nothing to be done for `all'.
cc -no-cpp-precomp   -O2 -DIN_GCC -DCROSS_COMPILE  -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -pedantic -Wno-long-long    -DHAVE_CONFIG_H  -o cc1 \
                c-parse.o c-lang.o c-pretty-print.o stub-objc.o attribs.o c-errors.o c-lex.o c-pragma.o c-decl.o c-typeck.o c-convert.o c-aux-info.o c-common.o c-opts.o c-format.o c-semantics.o c-incpath.o cppdefault.o c-ppoutput.o c-cppbuiltin.o prefix.o c-objc-common.o c-dump.o c-pch.o libcpp.a  main.o libbackend.a ../libiberty/libiberty.a ../intl/libintl.a -L/opt/local/lib -liconv 
Undefined symbols:
  "_iconv_close", referenced from:
      __cpp_destroy_iconv in libcpp.a(cppcharset.o)
      __cpp_destroy_iconv in libcpp.a(cppcharset.o)
      __cpp_convert_input in libcpp.a(cppcharset.o)
  "_iconv", referenced from:
      _convert_using_iconv in libcpp.a(cppcharset.o)
      _convert_using_iconv in libcpp.a(cppcharset.o)
  "_iconv_open", referenced from:
      _init_iconv_desc in libcpp.a(cppcharset.o)
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[1]: *** [cc1] Error 1
make: *** [all-gcc] Error 2

Error: Status 1 encountered during processing.

Workaround, add -L/usr/lib to LIBINTL line in Makefile:

LIBINTL = ${top_builddir}/intl/libintl.a -L/usr/lib -L/opt/local/lib -liconv 

Change History (9)

comment:1 Changed 12 years ago by jmpp@…

Milestone: MacPorts 1.5Port Bugs

comment:2 Changed 12 years ago by andreas@…

Still happens with MacPorts 1.600:

---> Building i386-elf-gcc with target all Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/build" && make all AR_FOR_TARGET=i386-elf-ar AS_FOR_TARGET=i386-elf-as LD_FOR_TARGET=i386-elf-ld NM_FOR_TARGET=i386-elf-nm RANLIB_FOR_TARGET=i386-elf-ranlib " returned error 2 Command output: cc -no-cpp-precomp -c -O2 -DIN_GCC -DCROSS_COMPILE -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -pedantic -Wno-long-long -DHAVE_CONFIG_H -I. -I. -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/gcc-3.4.3/gcc -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/gcc-3.4.3/gcc/. -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/gcc-3.4.3/gcc/../include -I../intl /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/gcc-3.4.3/gcc/tree-optimize.c -o tree-optimize.o cc -no-cpp-precomp -c -O2 -DIN_GCC -DCROSS_COMPILE -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -pedantic -Wno-long-long -DHAVE_CONFIG_H -I. -I. -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/gcc-3.4.3/gcc -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/gcc-3.4.3/gcc/. -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/gcc-3.4.3/gcc/../include -I../intl /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/gcc-3.4.3/gcc/cgraph.c -o cgraph.o cc -no-cpp-precomp -c -O2 -DIN_GCC -DCROSS_COMPILE -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -pedantic -Wno-long-long -DHAVE_CONFIG_H -I. -I. -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/gcc-3.4.3/gcc -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/gcc-3.4.3/gcc/. -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/gcc-3.4.3/gcc/../include -I../intl /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_cross_i386-elf-gcc/work/gcc-3.4.3/gcc/cgraphunit.c -o cgraphunit.o rm -rf libbackend.a ar rc libbackend.a alias.o bb-reorder.o bitmap.o builtins.o caller-save.o calls.o cfg.o cfganal.o cfgbuild.o cfgcleanup.o cfglayout.o cfgloop.o cfgloopanal.o cfgloopmanip.o loop-init.o loop-unswitch.o loop-unroll.o cfgrtl.o combine.o conflict.o convert.o coverage.o cse.o cselib.o dbxout.o debug.o df.o diagnostic.o dojump.o doloop.o dominance.o dwarf2asm.o dwarf2out.o emit-rtl.o except.o explow.o expmed.o expr.o final.o flow.o fold-const.o function.o gcse.o genrtl.o ggc-common.o global.o graph.o gtype-desc.o haifa-sched.o hooks.o ifcvt.o insn-attrtab.o insn-emit.o insn-modes.o insn-extract.o insn-opinit.o insn-output.o insn-peep.o insn-recog.o integrate.o intl.o jump.o langhooks.o lcm.o lists.o local-alloc.o loop.o optabs.o options.o opts.o params.o postreload.o predict.o print-rtl.o print-tree.o value-prof.o profile.o ra.o ra-build.o ra-colorize.o ra-debug.o ra-rewrite.o real.o recog.o reg-stack.o regclass.o regmove.o regrename.o reload.o reload1.o reorg.o resource.o rtl.o rtlanal.o rtl-error.o sbitmap.o sched-deps.o sched-ebb.o sched-rgn.o sched-vis.o sdbout.o sibcall.o simplify-rtx.o sreal.o stmt.o stor-layout.o stringpool.o targhooks.o timevar.o toplev.o tracer.o tree.o tree-dump.o unroll.o varasm.o varray.o version.o vmsdbgout.o xcoffout.o alloc-pool.o et-forest.o cfghooks.o bt-load.o pretty-print.o ggc-page.o web.o i386.o host-default.o hashtable.o tree-inline.o tree-optimize.o cgraph.o cgraphunit.o ranlib: file: libbackend.a(insn-peep.o) has no symbols ranlib: file: libbackend.a(reorg.o) has no symbols ranlib: file: libbackend.a(vmsdbgout.o) has no symbols ranlib: file: libbackend.a(xcoffout.o) has no symbols ranlib libbackend.a ranlib: file: libbackend.a(insn-peep.o) has no symbols ranlib: file: libbackend.a(reorg.o) has no symbols ranlib: file: libbackend.a(vmsdbgout.o) has no symbols ranlib: file: libbackend.a(xcoffout.o) has no symbols cc -no-cpp-precomp -O2 -DIN_GCC -DCROSS_COMPILE -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -pedantic -Wno-long-long -DHAVE_CONFIG_H -o cc1 \

c-parse.o c-lang.o c-pretty-print.o stub-objc.o attribs.o c-errors.o c-lex.o c-pragma.o c-decl.o c-typeck.o c-convert.o c-aux-info.o c-common.o c-opts.o c-format.o c-semantics.o c-incpath.o cppdefault.o c-ppoutput.o c-cppbuiltin.o prefix.o c-objc-common.o c-dump.o c-pch.o libcpp.a main.o libbackend.a ../libiberty/libiberty.a ../intl/libintl.a -L/opt/local/lib -liconv

Undefined symbols:

"_iconv_close", referenced from:

cpp_destroy_iconv in libcpp.a(cppcharset.o) cpp_destroy_iconv in libcpp.a(cppcharset.o) cpp_convert_input in libcpp.a(cppcharset.o)

"_iconv", referenced from:

_convert_using_iconv in libcpp.a(cppcharset.o) _convert_using_iconv in libcpp.a(cppcharset.o)

"_iconv_open", referenced from:

_init_iconv_desc in libcpp.a(cppcharset.o)

ld: symbol(s) not found collect2: ld returned 1 exit status make[1]: * [cc1] Error 1 make: * [all-gcc] Error 2

Error: Status 1 encountered during processing.

comment:3 Changed 12 years ago by jmpp@…

Please enclose terminal output in the {{{ }}} preformatted text macro, for proper formatting. Read WkiFormatting for more information, thanks!

-jmpp

comment:4 Changed 12 years ago by goudalf@…

As andreas said, the bug is still here in 1.600 The workaround provided in this ticket is working. Why isn't it put into mainstream ?

comment:5 Changed 12 years ago by stepan@…

I can confirm the problem is still not fixed.

comment:6 Changed 12 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to pguyot@…

Assigning to maintainer.

comment:7 Changed 12 years ago by pguyot (Paul Guyot)

Resolution: fixed
Status: newclosed

Fixed in r36032. However, I don't have leopard. Could you please confirm the patch works?

comment:8 Changed 12 years ago by anders.blomdell@…

Yes, it works.

comment:9 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.