Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#13524 closed defect (duplicate)

xephem fails to build under Leopard

Reported by: cabanela@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: Cc:
Port:

Description (last modified by jmpp@…)

Having installed all known dependancies, I try to install xephem 3.7 with a

sudo port install xephem

on MacPorts 1.5 under OS 10.5.1. After the initial mechanizations, I get:

--->  Building xephem
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_science_xephem/work/xephem-3.7/GUI/xephem" && make " returned error 2
Command output:       _si_newfim in skyip.o
  "_regionStats", referenced from:
      _si_doROI in skyip.o
      _si_doGlass in skyip.o
      _si_newfim in skyip.o
  "_fsmatch", referenced from:
      _wcsMatch in skyip.o
  "_getStringFITS", referenced from:
      _sf_getName in skyfits.o
      _sf_getName in skyfits.o
      _fitsObs in skyfits.o
      _setWCSField in skyip.o
  "_quickStars", referenced from:
      _wcsMatch in skyip.o
      _si_markstars_cb in skyip.o
  "_cmpStars", referenced from:
      _imPhotom in skyip.o
      _imPhotom in skyip.o
  "_setIntFITS", referenced from:
      _si_setContrast in skyip.o
      _si_setContrast in skyip.o
      _si_newfim in skyip.o
  "_clampRegion", referenced from:
      _imPhotom in skyip.o
      _si_doGlass in skyip.o
  "_writeFITS", referenced from:
      _save_file in skyfits.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make: *** [xephem] Error 1

Error: Status 1 encountered during processing.

Interestingly, I can download the source for xephem 3.7.2 from http://www.clearskyinstitute.com/xephem/ and it compiles without a hitch.

Change History (3)

comment:1 Changed 13 years ago by skymoo (Adam Mercer)

Resolution: duplicate
Status: newclosed

this is a duplicate of #13498

comment:2 Changed 13 years ago by jmpp@…

Description: modified (diff)
Milestone: Port Bugs

comment:3 Changed 13 years ago by jmpp@…

Milestone: Port Bugs
Note: See TracTickets for help on using tickets.