Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#13538 closed defect (worksforme)

gv does not download, does not compile

Reported by: vlado@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: Cc:
Port: gv

Description

First, when I attempted to install the gv port, the download failed:

--->  Fetching gv
DEBUG: Executing org.macports.fetch (gv)
--->  gv-3.5.8.tar.gz doesn't seem to exist in /opt/local/var/macports/distfiles/gv
--->  Attempting to fetch gv-3.5.8.tar.gz from ftp://ftpthep.physik.uni-mainz.de/pub/gv/unix/

DEBUG: Fetching failed:: FTP: login denied
--->  Attempting to fetch gv-3.5.8.tar.gz from http://svn.macports.org/repository/macports/distfiles/gv
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
DEBUG: Fetching failed:: HTTP response code said error
--->  Attempting to fetch gv-3.5.8.tar.gz from http://svn.macports.org/repository/macports/distfiles/general/
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
DEBUG: Fetching failed:: HTTP response code said error

I managed to download manually (using wget) from the first address, though. Having put the file in /opt/local/var/macports/distfiles/gv the compilation started, but it failed with the following output:

signal.c: In function 'signal_sh_terminate':
signal.c:128: warning: implicit declaration of function 'exit'
signal.c:128: warning: incompatible implicit declaration of built-in function 'exit'
signal.c: In function 'signal_sh_updateFile':
signal.c:174: warning: incompatible implicit declaration of built-in function 'exit'
/usr/bin/cc -Os -Wall -Wpointer-arith -no-cpp-precomp     -I/usr/X11/include    -D__powerpc__ -D__DARWIN__                                 -DNO_ALLOCA -DCSRG_BASED      -DNON_BLOCKING_IO     -DUSE_SIGNAL_HANDLER    -DUSER_DEFAULTS=\"~/.gv\" -DGV_LIBDIR=\"/opt/local/lib/gv/\" -DGV_CODE -I/opt/local/include -DUSE_FALLBACK_STYLES          -c -o version.o version.c
/usr/bin/cc -Os -Wall -Wpointer-arith -no-cpp-precomp     -I/usr/X11/include    -D__powerpc__ -D__DARWIN__                                 -DNO_ALLOCA -DCSRG_BASED      -DNON_BLOCKING_IO     -DUSE_SIGNAL_HANDLER    -DUSER_DEFAULTS=\"~/.gv\" -DGV_LIBDIR=\"/opt/local/lib/gv/\" -DGV_CODE -I/opt/local/include -DUSE_FALLBACK_STYLES          -c -o widgets_misc.o widgets_misc.c
/usr/bin/cc -Os -Wall -Wpointer-arith -no-cpp-precomp     -I/usr/X11/include    -D__powerpc__ -D__DARWIN__                                 -DNO_ALLOCA -DCSRG_BASED      -DNON_BLOCKING_IO     -DUSE_SIGNAL_HANDLER    -DUSER_DEFAULTS=\"~/.gv\" -DGV_LIBDIR=\"/opt/local/lib/gv/\" -DGV_CODE -I/opt/local/include -DUSE_FALLBACK_STYLES          -c -o zoom.o zoom.c
/usr/bin/cc -Os -Wall -Wpointer-arith -no-cpp-precomp     -I/usr/X11/include    -D__powerpc__ -D__DARWIN__                                 -DNO_ALLOCA -DCSRG_BASED      -DNON_BLOCKING_IO     -DUSE_SIGNAL_HANDLER    -DUSER_DEFAULTS=\"~/.gv\" -DGV_LIBDIR=\"/opt/local/lib/gv/\" -DGV_CODE -I/opt/local/include -DUSE_FALLBACK_STYLES          -c -o setenv.o setenv.c
setenv.c: In function 'setenv':
setenv.c:57: warning: implicit declaration of function 'strlen'
setenv.c:57: warning: incompatible implicit declaration of built-in function 'strlen'
setenv.c:62: warning: suggest parentheses around assignment used as truth value
setenv.c:83: warning: implicit declaration of function 'memcpy'
setenv.c:83: warning: incompatible implicit declaration of built-in function 'memcpy'
setenv.c:89: warning: assignment discards qualifiers from pointer target type
setenv.c:94: warning: suggest parentheses around assignment used as truth value
setenv.c: At top level:
setenv.c:105: error: conflicting types for 'unsetenv'
/usr/include/stdlib.h:247: error: previous declaration of 'unsetenv' was here
make[1]: *** [setenv.o] Error 1
make: *** [all] Error 2

Error: Status 1 encountered during processing.

This was on Mac OS 10.5.1 (PPC).

Change History (4)

comment:1 Changed 13 years ago by vlado@…

I just noticed there already is a bug covering the build problem. Sorry for the duplicate post! http://trac.macports.org/projects/macports/ticket/13095

comment:2 Changed 13 years ago by ryandesign (Ryan Schmidt)

Milestone: Port Bugs
Resolution: worksforme
Status: newclosed

Yes, the build failure seems to be a duplicate of #13095.

The fetch failure I'm unable to reproduce:

$ sudo port install gv
--->  Fetching gv
--->  Attempting to fetch gv-3.5.8.tar.gz from ftp://ftpthep.physik.uni-mainz.de/pub/gv/unix/
--->  Verifying checksum(s) for gv
--->  Extracting gv
--->  Applying patches to gv
--->  Configuring gv
--->  Building gv with target all
--->  Staging gv into destroot
--->  Installing gv 3.5.8_3
--->  Activating gv 3.5.8_3
--->  Cleaning gv
$

Maybe they had a temporary server issue. (I'm able to install it, too, because I'm on Tiger, not Leopard.)

comment:3 Changed 12 years ago by ryandesign (Ryan Schmidt)

Port: gv added

comment:4 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.