Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#13550 closed defect (duplicate)

python25 Build Error

Reported by: soupsnaz@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: failed to build Cc: gui-dos (Guido Soranzio), rhwood@…
Port:

Description

I uninstalled macports, restarted, reinstalled and used 'sudo port install gnome-games' and got the following errors. The log is attached below. OS: Leopard Macports: 1.5.2

Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python25/work/Python-2.5.1" && make all " returned error 2
Command output: gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -o Python/mystrtoul.o Python/mystrtoul.c
gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -o Python/pyarena.o Python/pyarena.c
gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -o Python/pyfpe.o Python/pyfpe.c
gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -o Python/pystate.o Python/pystate.c
gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -o Python/pythonrun.o Python/pythonrun.c
gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -o Python/structmember.o Python/structmember.c
gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -o Python/symtable.o Python/symtable.c
gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -o Python/sysmodule.o Python/sysmodule.c
gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -o Python/traceback.o Python/traceback.c
gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -o Python/getopt.o Python/getopt.c
gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -o Python/pystrtod.o Python/pystrtod.c
gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -o Python/dynload_shlib.o Python/dynload_shlib.c
gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -o Python/mactoolboxglue.o Python/mactoolboxglue.c
gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -o Python/thread.o Python/thread.c
gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -o Modules/config.o Modules/config.c
gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -DPYTHONPATH='":plat-darwin:plat-mac:plat-mac/lib-scriptpackages:lib-tk"' \
		-DPREFIX='"/opt/local"' \
		-DEXEC_PREFIX='"/opt/local"' \
		-DVERSION='"2.5"' \
		-DVPATH='""' \
		-o Modules/getpath.o ./Modules/getpath.c
gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -o Modules/main.o Modules/main.c
Modules/main.c:186: warning: function declaration isn't a prototype
gcc -c -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE -o Modules/gcmodule.o Modules/gcmodule.c
gcc -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE  -c ./Modules/threadmodule.c -o Modules/threadmodule.o
gcc -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE  -c ./Modules/signalmodule.c -o Modules/signalmodule.o
gcc -fno-strict-aliasing -Wno-long-double -no-cpp-precomp -mno-fused-madd -DNDEBUG -g -O3 -Wall -Wstrict-prototypes  -I. -I./Include -I/opt/local/include -DDARWIN_UNIX03  -DPy_BUILD_CORE  -c ./Modules/posixmodule.c -o Modules/posixmodule.o
./Modules/posixmodule.c: In function 'posix_setpgrp':
./Modules/posixmodule.c:3724: error: too few arguments to function 'setpgrp'
make: *** [Modules/posixmodule.o] Error 1

Error: The following dependencies failed to build: gnome-doc-utils py25-gobject python25 py25-hashlib openssl py25-libxml2 py25-numeric gnome-keyring libgcrypt libgpg-error gnome-python-desktop gnome-platform-suite at-spi gail libbonobo popt py25-wxpython wxWidgets libsdl libsdl_mixer libogg libvorbis smpeg gnome-mime-data gnome-vfs howl neon gnome-vfs-monikers libart_lgpl libbonoboui libglade2 libgnome libgnomecanvas libgnomeui libwnck startup-notification metacity gnome-themes gtk-engines2 icon-naming-utils p5-getopt-long p5-pathtools p5-xml-simple p5-test-simple p5-test-harness p5-xml-namespacesupport p5-xml-sax py25-gnome libzvt gnome-session control-center desktop-file-utils evolution-data-server libsoup nspr gnome-panel gnome-desktop fribidi gnome-menus py25-gtk py25-cairo shared-mime-info gst-plugins-base cdparanoia gstreamer bison m4 flex gzip liboil libtheora libgnomekbd libxklavier nautilus eel libexif librsvg libcroco libgsf vte ncurses ncursesw gawk py25-orbit guile gmp readline
Error: Status 1 encountered during processing.

Attachments (1)

Log.rtf (28.2 KB) - added by soupsnaz@… 13 years ago.
Complete Log

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by soupsnaz@…

Attachment: Log.rtf added

Complete Log

comment:1 Changed 13 years ago by rhwood@…

Cc: gui_dos@… rhwood@… added

Is this still an issue with the current version of gnome-games?

comment:2 Changed 13 years ago by jmroot (Joshua Root)

Priority: HighNormal
Resolution: duplicate
Status: newclosed
Summary: Gnome-Games Build Errorpython25 Build Error

Duplicate of #13335, as it's actually python25 that failed.

comment:3 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.