Opened 12 years ago

Closed 12 years ago

#13599 closed defect (duplicate)

py-gtk2 - 2.10.4 - error in package

Reported by: charme_de_nuit-1@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: py-gtk2 py-gtk gtk python Cc: charme_de_nuit-1@…
Port:

Description

I'm trying to get the latest version of Guido van Robot working on my G4 eMac running OS 10.5.1. It requires py-gtk2, which I've installed using Port Authority. However, even though Port Authority thinks it's installed ok, when I try to use it to run GvR I'm out of luck. Not being very command line savvy, I first posted my problems on the GvR listserv. They looked at my terminal output and concluded:

Here GvRng tries to import GTK but that fails due to an error in the macport PyGTK package, the rest of the messages are related to the problem in that package :-(

So I'm reporting this bug to you, in the hopes that you can fix it :)

Macintosh:gvr_ng-1.9.1 noxlady$ sudo ./setup

-------- Installing Guido van Robot Next Generation ---------
Trying to compiling modules to bytecode.
Installation complete.
To start Guido van Robot -> gvrng [Enter]
Be sure to check the website http://gvr.sf.net, for additional information
and lessons.

Enjoy

Macintosh:gvr_ng-1.9.1 noxlady$ gvrng
Macintosh:gvr_ng-1.9.1 noxlady$ Traceback (most recent call last):
  File "/usr/local/GvRng/gvrng.py", line 69, in <module>
    import gvr_gtk # the frontend to use
  File "/usr/local/GvRng/gui-gtk/gvr_gtk.py", line 22, in <module>
    from SimpleGladeApp import SimpleGladeApp
  File "/usr/local/GvRng/gui-gtk/SimpleGladeApp.py", line 38, in <module>
    import gtk
  File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-gtk2/work/destroot/Library/Python/2.5/site-packages/gtk-2.0/gtk/__init__.py", line 38, in <module>
  File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py-gobject/work/destroot/Library/Python/2.5/site-packages/gtk-2.0/gobject/__init__.py", line 30, in <module>
ImportError: dlopen(/Library/Python/2.5/site-packages/gtk-2.0/gobject/_gobject.so, 2): Symbol not found: _PyGBoxed_Type
  Referenced from: /Library/Python/2.5/site-packages/gtk-2.0/gobject/_gobject.so
  Expected in: flat namespace


As you can see, however, MacPorts really thinks that I have py-gtk2 correctly installed:

Macintosh:gvr_ng-1.9.1 noxlady$ port installed
The following ports are currently installed:
  at-spi @1.21.1_0 (active)
  atk @1.20.0_1 (active)
  audiofile @0.2.6_1 (active)
  autoconf @2.61_1 (active)
  automake @1.10_0 (active)
  cairo @1.4.12_0 (active)
  dbus @1.0.2_2 (active)
  dbus-glib @0.74_0 (active)
  docbook-xml @4.5_1 (active)
  docbook-xml-4.1.2 @4.1.2_1 (active)
  docbook-xml-4.2 @4.2_0 (active)
  docbook-xml-4.3 @4.3_0 (active)
  docbook-xml-4.4 @4.4_0 (active)
  docbook-xml-4.5 @4.5_0 (active)
  docbook-xsl @1.72.0_0 (active)
  esound @0.2.38_1 (active)
  expat @2.0.1_0 (active)
  fontconfig @2.5.0_0+macosx (active)
  freetype @2.3.5_1 (active)
  fribidi @0.10.7_0 (active)
  gail @1.20.1_1 (active)
  gconf @2.20.1_0 (active)
  getopt @1.1.4_1 (active)
  gettext @0.17_1 (active)
  glib2 @2.14.4_0+darwin_9
  glib2 @2.14.4_1+darwin_9 (active)
  gnome-keyring @2.20.1_0 (active)
  gnome-mime-data @2.18.0_3 (active)
  gnome-vfs @2.20.0_1 (active)
  gtk-doc @1.9_0 (active)
  gtk2 @2.12.2_0+x11 (active)
  help2man @1.36.4_1 (active)
  howl @1.0.0_0 (active)
  intltool @0.36.2_0 (active)
  iso-codes @1.6_0 (active)
  jpeg @6b_2 (active)
  libart_lgpl @2.3.19_2 (active)
  libbonobo @2.20.1_2 (active)
  libbonoboui @2.20.0_1 (active)
  libgcrypt @1.2.4_1 (active)
  libglade2 @2.6.2_0 (active)
  libgnome @2.20.1.1_1 (active)
  libgnomecanvas @2.20.1.1_0 (active)
  libgpg-error @1.6_0 (active)
  libiconv @1.12_0 (active)
  libidl @0.8.9_0 (active)
  libogg @1.1.3_2 (active)
  libpng @1.2.23_0
  libpng @1.2.24_0 (active)
  libsdl @1.2.12_0+darwin_9 (active)
  libsdl_mixer @1.2.8_0 (active)
  libtool @1.5.24_1 (active)
  libvorbis @1.2.0_0 (active)
  libxml2 @2.6.30_0 (active)
  libxslt @1.1.22_0 (active)
  m4 @1.4.10_1 (active)
  neon @0.26.4_0 (active)
  openssl @0.9.8g_0 (active)
  orbit2 @2.14.10_2+darwin_9 (active)
  p5-locale-gettext @1.05_0 (active)
  p5-xml-parser @2.36_0 (active)
  pango @1.18.3_0 (active)
  perl5.8 @5.8.8_0 (active)
  pkgconfig @0.22_0 (active)
  popt @1.12_0 (active)
  py-cairo @1.4.0_0 (active)
  py-gobject @2.12.3_1 (active)
  py-gtk2 @2.10.4_0 (active)
  py-numeric @24.2_1+macosx (active)
  py25-gobject @2.14.0_0
  py25-numeric @24.2_1+macosx (active)
  py25-wxpython @2.8.7.1_0 (active)
  python24 @2.4.4_1+darwin_9 (active)
  python25 @2.5.1_4+darwin_9 (active)
  render @0.9_1 (active)
  scrollkeeper @0.3.14_6 (active)
  smpeg @0.4.4_6 (active)
  tiff @3.8.2_1+macosx (active)
  wxWidgets @2.8.7_0 (active)
  Xft2 @2.1.12_0 (active)
  xmlcatmgr @2.2_1 (active)
  xmlto @0.0.18_3 (active)
  xorg-util-macros @1.1.5_0 (active)
  xorg-xproto @7.0.11_1 (active)
  xrender @0.9.0_1 (active)
  zlib @1.2.3_1 (active)
Macintosh:gvr_ng-1.9.1 noxlady$ 

Please let me know if you need any further information.

Meg Claypool
charme_de_nuit-1(at)yahoo(dot)com

Change History (1)

comment:1 Changed 12 years ago by skymoo (Adam Mercer)

Resolution: duplicate
Status: newclosed

this is a duplicate of #13337

Note: See TracTickets for help on using tickets.