Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#13714 closed defect (duplicate)

boost 1.34.1 still won't build on Mac OS X 10.5 Leopard

Reported by: tristandpeters@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: boost Cc: sanchom (Sancho McCann), jmroot (Joshua Root), rob@…, daniel@…
Port:

Description (last modified by jmpp@…)

Despite the apparent resolution of Ticket #13223 ("Boost fails to build on leopard"), I still get the following error when building it:

Building boost with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work/boost_1_34_1" && gmake all " returned error 2
Command output: Makefile:2: *** missing separator.  Stop.

I did a selfupdate and sync before trying again to install boost.

Anyone know anything about this?

Thanks

Change History (18)

comment:1 Changed 12 years ago by jmpp@…

Description: modified (diff)
Milestone: Port Bugs

comment:2 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: sanchom@… added
Summary: still can't install boost on leopardboost 1.34.1 still won't build on Mac OS X 10.5 Leopard

Cc maintainer.

comment:3 Changed 12 years ago by sanchom (Sancho McCann)

What is the problem you are having? I haven't upgraded to Leopard yet, so this problem has basically been handled by others submitting patches. #13223 also presented this problem, but a patch was submitted and was reported to have worked for people running Leopard/PPC and Leopard/Intel. Are you having the same problem as in #13223?

comment:4 Changed 12 years ago by michaelvb@…

I too seem to be having the problem mentioned in this ticket, so I can answer your question. I have read through #13223 and even though it seems to be the same issue, the fix does not seem to work for me either.

I am running Leopard/Intel 10.5.1. Below is what happens when I try to install Boost (I tried it twice, once normally and again with a suggestion from #13233.

iMac:~$ sudo port selfupdate
Password:

MacPorts base version 1.600 installed

Downloaded MacPorts base version 1.600

The MacPorts installation is not outdated and so was not updated
selfupdate done!


iMac:~$ sudo port install boost
--->  Building boost with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work/boost_1_34_1" && gmake all " returned error 2
Command output: Makefile:2: *** missing separator.  Stop.

Error: Status 1 encountered during processing.


iMac:~ $ MAKE=/opt/local/bin/gmake sudo port install boost
--->  Building boost with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work/boost_1_34_1" && gmake all " returned error 2
Command output: Makefile:2: *** missing separator.  Stop.''

If you have any suggestions or would like me to try something just let me know.

comment:5 Changed 12 years ago by tristandpeters@…

Hi, In another forum I saw this and it worked for me finally. do a 1) "sudo port clean boost" first 2) then "sudo port install jam" 3) finally redo "sudo port install boost"

comment:6 Changed 12 years ago by michaelvb@…

I can confirm that your suggested method works Tristand.

I now have boost installed, thanks!

comment:7 Changed 12 years ago by raimue (Rainer Müller)

Hm, should boost not be build with boost-jam? At least it is a dependency. And it worked fine for me on Leopard.

$ sudo port -v installed jam boost-jam boost
The following ports are currently installed:
  boost @1.34.1_1 (active)
  boost-jam @3.1.15_0 (active)

So I definitely did not need jam for building.

comment:8 Changed 12 years ago by jmroot (Joshua Root)

Cc: jmr@… added

I can confirm that something is wrong here. As raimue noted, jam is not needed to build boost. It was cleaning boost, not installing jam, that made the problem go away. I just tried installing boost and got this:

--->  Extracting boost
--->  Extracting boost_1_34_1.tar.bz2
--->  Configuring boost
-n Building Boost.Jam with toolset darwin... 
usage: mkdir [-pv] [-m mode] directory ...
tools/jam/src/
...skipped bjam for lack of ...
...failed updating 1 target.../bjam
-n Unicode/ICU support for Boost.Regex?... 
disabled.
Generating Boost.Build configuration in user-config.jam...
Generating Makefile...
--->  Building boost with target all
Makefile:2: *** missing separator.  Stop.

However, I then cleaned boost and tried installing it again, and it built OK. I guess that's a pretty simple workaround, but it would be good to find out why this is happening and make it work the first time.

comment:9 Changed 12 years ago by jmroot (Joshua Root)

Cc: rob@… added

Cc reporter of duplicate #14043.

comment:10 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: daniel@… added

Daniel Lord also reported this problem on macports-users.

comment:11 Changed 12 years ago by sanchom (Sancho McCann)

Possible related ticket: #14687

comment:12 Changed 12 years ago by sanchom (Sancho McCann)

Recently upgraded port to 1.35... please report if you have the same problem with the new version.

comment:13 in reply to:  12 Changed 12 years ago by spambox@…

Replying to sanchom@gmail.com:

Recently upgraded port to 1.35... please report if you have the same problem with the new version.

1.35 built okay for me on Leopard, but 1.34.1 failed to build, then I found this thread, did 'port clean boost', 'port clean jam' before building it, so I wouldn't take this comment as proof that it works yet

comment:14 Changed 12 years ago by ryandesign (Ryan Schmidt)

This is not a boost bug. This is a Leopard bug that affects many many ports. This ticket can be closed. The solution is to clean the boost work area (sudo port clean --work boost) and request the boost install (or upgrade) again. See this post on the macports-users.

comment:15 Changed 12 years ago by sanchom (Sancho McCann)

Is there a ticket for this bug? We should place a link to it here before closing.

comment:16 in reply to:  15 Changed 12 years ago by afb@…

The ticket is #13930

comment:17 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #13930.

comment:18 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.