Opened 17 years ago

Closed 16 years ago

#1373 closed defect (duplicate)

kdebase3 lib problem / Darwin 7

Reported by: waldmire@… Owned by: ranger@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

---> Building kdebase3 with target all apidox Error: Target com.apple.build returned: shell command "cd "/Users/waldmire/darwinports/dports/ x11/kdebase3/work/kdebase-3.1.2" && CPPFLAGS='-I/usr/X11R6/include -I/opt/local/include - I/opt/local/include/qt3 -no-cpp-precomp -fno-common' LDFLAGS='-L/usr/X11R6/lib' LIBS='-L/ opt/local/lib' DYLD_LIBRARY_PATH='/opt/local/lib' make all apidox" returned error 2 Command output: /opt/local/lib/libkdecore.dylib(single module) definition of _XPanoramiXGetScreenSize /opt/local/lib/libqt-mt.dylib(single module) definition of _XPanoramiXGetScreenSize ld: warning multiple definitions of symbol _XPanoramiXGetState /opt/local/lib/libkdecore.dylib(single module) definition of _XPanoramiXGetState /opt/local/lib/libqt-mt.dylib(single module) definition of _XPanoramiXGetState ld: warning multiple definitions of symbol _XineramaQueryVersion /opt/local/lib/libkdecore.dylib(single module) definition of _XineramaQueryVersion /opt/local/lib/libqt-mt.dylib(single module) definition of _XineramaQueryVersion ld: warning multiple definitions of symbol _XPanoramiXGetScreenCount /opt/local/lib/libkdecore.dylib(single module) definition of _XPanoramiXGetScreenCount /opt/local/lib/libqt-mt.dylib(single module) definition of _XPanoramiXGetScreenCount ld: warning multiple definitions of symbol _XineramaIsActive /opt/local/lib/libkdecore.dylib(single module) definition of _XineramaIsActive /opt/local/lib/libqt-mt.dylib(single module) definition of _XineramaIsActive ld: warning multiple definitions of symbol _XineramaQueryScreens /opt/local/lib/libkdecore.dylib(single module) definition of _XineramaQueryScreens /opt/local/lib/libqt-mt.dylib(single module) definition of _XineramaQueryScreens ld: warning multiple definitions of symbol _XineramaQueryExtension /opt/local/lib/libkdecore.dylib(single module) definition of _XineramaQueryExtension /opt/local/lib/libqt-mt.dylib(single module) definition of _XineramaQueryExtension ld: warning multiple definitions of symbol _XPanoramiXAllocInfo /opt/local/lib/libkdecore.dylib(single module) definition of _XPanoramiXAllocInfo /opt/local/lib/libqt-mt.dylib(single module) definition of _XPanoramiXAllocInfo ld: warning multiple definitions of symbol _mkstemp /opt/local/lib/libkdecore.dylib(single module) definition of _mkstemp /usr/lib/libpthread.dylib(mktemp.So) definition of _mkstemp make[3]: * [kcm_keyboard.la.closure] Error 1 make[2]: * [all-recursive] Error 1 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

Change History (2)

comment:1 Changed 17 years ago by olegb@…

Owner: changed from darwinports-bugs@… to ranger@…

assigned to maintainer

comment:2 Changed 16 years ago by toby@…

Resolution: duplicate
Status: newclosed

* This bug has been marked as a duplicate of 578 *

Note: See TracTickets for help on using tickets.