Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#13931 closed defect (fixed)

libxml2 checksum breaks libxml2 install

Reported by: keith.irwin@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: libxml2 Cc: 0xced (Cédric Luthi), keith.irwin@…
Port:

Description

In installing postgresql83, I encountered the following. Far as I can tell, there's a checksum problem for libxml2. I tried removing the binary, cleaning, downloaded the tarball explicitly, and so on. No go.

I can reproduce it doing:

sudo port -d install libxml2

Results:

DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/textproc/libxml2
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/textproc/libxml2
DEBUG: Requested variant darwin is not provided by port libxml2.
DEBUG: Requested variant i386 is not provided by port libxml2.
DEBUG: Requested variant macosx is not provided by port libxml2.
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/textproc/libiconv
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/textproc/libiconv
DEBUG: Requested variant darwin is not provided by port libiconv.
DEBUG: Requested variant i386 is not provided by port libiconv.
DEBUG: Requested variant macosx is not provided by port libiconv.
DEBUG: Searching for dependency: libiconv
DEBUG: Found Dependency: receipt exists for libiconv
DEBUG: Found port in file:///opt/local/var/macports/sources/rsync.macports.org/release/ports/archivers/zlib
DEBUG: Changing to port directory: /opt/local/var/macports/sources/rsync.macports.org/release/ports/archivers/zlib
DEBUG: Requested variant darwin is not provided by port zlib.
DEBUG: Requested variant i386 is not provided by port zlib.
DEBUG: Requested variant macosx is not provided by port zlib.
DEBUG: Searching for dependency: zlib
DEBUG: Found Dependency: receipt exists for zlib
DEBUG: Skipping completed org.macports.main (libxml2)
DEBUG: Skipping completed org.macports.fetch (libxml2)
--->  Verifying checksum(s) for libxml2
DEBUG: Executing org.macports.checksum (libxml2)
--->  Checksumming libxml2-2.6.30.tar.gz
Error: Checksum (md5) mismatch for libxml2-2.6.30.tar.gz
Portfile checksum: libxml2-2.6.30.tar.gz md5 460e6d853e824da700d698532e57316b
Distfile checksum: libxml2-2.6.30.tar.gz md5 5a5bfd9a611d113e0b28e650a979ca4e
Error: Checksum (sha1) mismatch for libxml2-2.6.30.tar.gz
Portfile checksum: libxml2-2.6.30.tar.gz sha1 519701df3a10770980e993336fe19ef7d95b5bba
Distfile checksum: libxml2-2.6.30.tar.gz sha1 f59910a08c292a93d1c3a677e10ab64792c4915c
Error: Checksum (rmd160) mismatch for libxml2-2.6.30.tar.gz
Portfile checksum: libxml2-2.6.30.tar.gz rmd160 8adcca2a60b4e90de898d9710a3a45069b73bbfe
Distfile checksum: libxml2-2.6.30.tar.gz rmd160 4a7d23ee18c4df5269784cf64e68901c4a5428b1
Error: Target org.macports.checksum returned: Unable to verify file checksums
Warning: the following items did not execute (for libxml2): org.macports.activate org.macports.extract org.macports.checksum org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install
Error: Status 1 encountered during processing.

Change History (14)

comment:1 Changed 13 years ago by tim.harding@…

+1 on this bug.

tim@manhattan:~$ sudo port install rb-rmagick ---> Verifying checksum(s) for libxml2 Error: Checksum (md5) mismatch for libxml2-2.6.30.tar.gz Error: Checksum (sha1) mismatch for libxml2-2.6.30.tar.gz Error: Checksum (rmd160) mismatch for libxml2-2.6.30.tar.gz Error: Target org.macports.checksum returned: Unable to verify file checksums Error: The following dependencies failed to build: ImageMagick libxml2 pkgconfig tiff ruby ncurses ncursesw openssl readline Error: Status 1 encountered during processing.

comment:2 in reply to:  1 Changed 13 years ago by tim.harding@…

tim@manhattan:~$ uname -a Darwin manhattan.config 9.1.0 Darwin Kernel Version 9.1.0: Wed Oct 31 17:46:22 PDT 2007; root:xnu-1228.0.2~1/RELEASE_I386 i386

Replying to tim.harding@gmail.com:

+1 on this bug.

tim@manhattan:~$ sudo port install rb-rmagick ---> Verifying checksum(s) for libxml2 Error: Checksum (md5) mismatch for libxml2-2.6.30.tar.gz Error: Checksum (sha1) mismatch for libxml2-2.6.30.tar.gz Error: Checksum (rmd160) mismatch for libxml2-2.6.30.tar.gz Error: Target org.macports.checksum returned: Unable to verify file checksums Error: The following dependencies failed to build: ImageMagick libxml2 pkgconfig tiff ruby ncurses ncursesw openssl readline Error: Status 1 encountered during processing.

comment:3 Changed 13 years ago by sixhat@…

I've encountered the same problem when installing libxml2 package:

Sixhat:~ david$ sudo port install libxml2
--->  Verifying checksum(s) for libxml2
Error: Checksum (md5) mismatch for libxml2-2.6.30.tar.gz
Error: Checksum (sha1) mismatch for libxml2-2.6.30.tar.gz
Error: Checksum (rmd160) mismatch for libxml2-2.6.30.tar.gz
Error: Target org.macports.checksum returned: Unable to verify file checksums
Error: Status 1 encountered during processing.

I've got the same Checksum problem...

comment:4 Changed 13 years ago by renato.furter@…

Same Problem here with the Checksum on libxml2 package:

macrf:~ furter$ sudo port install libxml2
--->  Verifying checksum(s) for libxml2
Error: Checksum (md5) mismatch for libxml2-2.6.30.tar.gz
Error: Checksum (sha1) mismatch for libxml2-2.6.30.tar.gz
Error: Checksum (rmd160) mismatch for libxml2-2.6.30.tar.gz
Error: Target org.macports.checksum returned: Unable to verify file checksums
Error: Status 1 encountered during processing.
macrf:~ furter$ uname -a
Darwin macrf.switch.ch 9.1.0 Darwin Kernel Version 9.1.0: Wed Oct 31 17:46:22 PDT 2007; 
root:xnu-1228.0.2~1/RELEASE_I386 i386

comment:5 Changed 13 years ago by tjeanneret@…

...and once more when trying to build GIMP :

Error: Checksum (md5) mismatch for libxml2-2.6.30.tar.gz Portfile checksum: libxml2-2.6.30.tar.gz md5 460e6d853e824da700d698532e57316b Distfile checksum: libxml2-2.6.30.tar.gz md5 5a5bfd9a611d113e0b28e650a979ca4e Error: Checksum (sha1) mismatch for libxml2-2.6.30.tar.gz Portfile checksum: libxml2-2.6.30.tar.gz sha1 519701df3a10770980e993336fe19ef7d95b5bba Distfile checksum: libxml2-2.6.30.tar.gz sha1 f59910a08c292a93d1c3a677e10ab64792c4915c Error: Checksum (rmd160) mismatch for libxml2-2.6.30.tar.gz Portfile checksum: libxml2-2.6.30.tar.gz rmd160 8adcca2a60b4e90de898d9710a3a45069b73bbfe Distfile checksum: libxml2-2.6.30.tar.gz rmd160 4a7d23ee18c4df5269784cf64e68901c4a5428b1 Error: Target org.macports.checksum returned: Unable to verify file checksums

and it is highly reproductible ! Best regards, happy new year

comment:6 Changed 13 years ago by afb@…

the distfile from the GNOME mirror seems to be alright, even if the one from xmlsoft.org is bad

ftp://ftp.gnome.org/pub/GNOME/sources/libxml2/2.6/libxml2-2.6.30.tar.gz

comment:7 in reply to:  6 Changed 13 years ago by onyxraven@…

Replying to afb@macports.org:

the distfile from the GNOME mirror seems to be alright, even if the one from xmlsoft.org is bad

ftp://ftp.gnome.org/pub/GNOME/sources/libxml2/2.6/libxml2-2.6.30.tar.gz

This worked, dropping the file into the distfiles location. The portfile should either be updated to point at gnome.org first or checksums updated, though.

comment:8 Changed 13 years ago by jmpp@…

Milestone: Port Bugs
Priority: HighNormal

comment:9 in reply to:  8 ; Changed 13 years ago by tjeanneret@…

Replying to jmpp@macports.org: Sorry, new comer, don't understand how you can get rid of this. I changed my portfile as :

#master_sites ${homepage}sources/ \ # ftp://xmlsoft.org/${name}/ \ # ftp://fr.rpmfind.net/pub/libxml/ \ # ftp://gd.tuwien.ac.at/pub/libxml/ \

master_sites gnome:sources/${name}/[strsed ${version} {/\.[0-9]*$}]/

checksums md5 460e6d853e824da700d698532e57316b \

sha1 519701df3a10770980e993336fe19ef7d95b5bba \ rmd160 8adcca2a60b4e90de898d9710a3a45069b73bbfe

#checksums md5 5a5bfd9a611d113e0b28e650a979ca4e \ # sha1 f59910a08c292a93d1c3a677e10ab64792c4915c \ # rmd160 4a7d23ee18c4df5269784cf64e68901c4a5428b1

None of these modifs worked : For the checksums I got :

Portfile changed since last build; discarding previous state. ---> Fetching libxml2 ---> Verifying checksum(s) for libxml2 ---> Checksumming libxml2-2.6.30.tar.gz ---> Extracting libxml2 ---> Extracting libxml2-2.6.30.tar.gz /usr/bin/gnutar: Skipping to next header /usr/bin/gnutar: Archive contains obsolescent base-64 headers

gzip: /opt/local/var/macports/distfiles/libxml2/libxml2-2.6.30.tar.gz: invalid compressed data--crc error

gzip: /opt/local/var/macports/distfiles/libxml2/libxml2-2.6.30.tar.gz: invalid compressed data--length error /usr/bin/gnutar: Error exit delayed from previous errors Error: Target org.macports.extract returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_textproc_libxml2/work" && gzip -dc /opt/local/var/macports/distfiles/libxml2/libxml2-2.6.30.tar.gz | /usr/bin/gnutar --no-same-owner -xf - " returned error 2 Command output: /usr/bin/gnutar: Skipping to next header /usr/bin/gnutar: Archive contains obsolescent base-64 headers

gzip: /opt/local/var/macports/distfiles/libxml2/libxml2-2.6.30.tar.gz: invalid compressed data--crc error

gzip: /opt/local/var/macports/distfiles/libxml2/libxml2-2.6.30.tar.gz: invalid compressed data--length error /usr/bin/gnutar: Error exit delayed from previous errors

Warning: the following items did not execute (for libxml2): org.macports.activate org.macports.extract org.macports.patch org.macports.configure org.macports.build org.macports.destroot org.macports.install Error: Status 1 encountered during processing.

For the source modification, I got :

---> Fetching libxml2 ---> Verifying checksum(s) for libxml2 Error: Checksum (md5) mismatch for libxml2-2.6.30.tar.gz Error: Checksum (sha1) mismatch for libxml2-2.6.30.tar.gz Error: Checksum (rmd160) mismatch for libxml2-2.6.30.tar.gz Error: Target org.macports.checksum returned: Unable to verify file checksums Error: Status 1 encountered during processing.

Don't know what to do now. May be using a prepackaged Gimp ?

comment:10 in reply to:  9 ; Changed 13 years ago by renato.furter@…

what I did after i saw the comment from afb and onyxraven was to get the libxml2-2.6.30.tar.gz from gnome and just copied it into the distfile folder (/opt/local/var/macports/distfiles/ on my mac) and then installed libxml2 throug macports with

ports install libxml2

worked fine for me.

comment:11 in reply to:  10 Changed 13 years ago by renato.furter@…

grrr... its of course port without 's'.

comment:12 Changed 13 years ago by 0xced (Cédric Luthi)

It seems there was a glitch on xmlsoft.org
Just do

port clean --work --dist libxml2

and everything should work again.

Someone with appropriate rights may close this ticket.

comment:13 in reply to:  12 Changed 13 years ago by raimue (Rainer Müller)

Resolution: fixed
Status: newclosed

Replying to cedric.luthi@gmail.com: Okay, I am closing this.

comment:14 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.