Opened 12 years ago

Closed 11 years ago

Last modified 11 years ago

#13953 closed defect (duplicate)

sqlite3 3.5.4 build failure

Reported by: nadeem.shabir@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: asmarin@…, rderuiter@…, ryandesign (Ryan Schmidt)
Port:

Description (last modified by jmpp@…)

I've been trying for over a week to simply install php5 +apache2 I'm running Mac OSX 10.5 and have installed Xcode 3.0 plus all the X11 SDK tools etc. as per in the installation guide.

I have used the Macports 1.6.0 installer. and run sudo port -v selfupdate and sync successfully.

However whenever I try to issue the command:

sudo port install php5 +apache2

i'm currently getting the following error:

Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_sqlite3/work/sqlite-3.5.4" && gnumake all " returned error 2
Command output: sed -e s/--VERS--/3.5.4/ ./src/sqlite.h.in | \
	sed -e s/--VERSION-NUMBER--/3005004/ >sqlite3.h
/usr/bin/gcc-4.0 -O2 -o lemon ./tool/lemon.c
cp ./tool/lempar.c .
cp ./src/parse.y .
./lemon  parse.y
mv parse.h parse.h.temp
f ./addopcodes.awk parse.h.temp >parse.h
/bin/sh: f: command not found
gnumake: [parse.c] Error 127 (ignored)
cat parse.h ./src/vdbe.c |  -f ./mkopcodeh.awk >opcodes.h
/bin/sh: -f: command not found
cat: stdout: Broken pipe
gnumake: *** [opcodes.h] Error 127

Error: The following dependencies failed to build: apr-util sqlite3 openssl zlib pcre
Error: Status 1 encountered during processing.
Macintosh-2:/ nadeemshabir$ sudo port install apr-util
Password:
--->  Building sqlite3 with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_sqlite3/work/sqlite-3.5.4" && gnumake all " returned error 2
Command output: ./libtool --mode=compile --tag=CC /usr/bin/gcc-4.0 -O2 -I. -I./src -DNDEBUG   -DSQLITE_THREADSAFE=1 -DSQLITE_THREAD_OVERRIDE_LOCK=-1 -DSQLITE_OMIT_LOAD_EXTENSION=1 -c ./src/alter.c
mkdir .libs
/usr/bin/gcc-4.0 -O2 -I. -I./src -DNDEBUG -DSQLITE_THREADSAFE=1 -DSQLITE_THREAD_OVERRIDE_LOCK=-1 -DSQLITE_OMIT_LOAD_EXTENSION=1 -c ./src/alter.c  -fno-common -DPIC -o .libs/alter.o
./src/alter.c: In function 'renameTableFunc':
./src/alter.c:77: error: 'TK_SPACE' undeclared (first use in this function)
./src/alter.c:77: error: (Each undeclared identifier is reported only once
./src/alter.c:77: error: for each function it appears in.)
./src/alter.c:79: error: 'TK_LP' undeclared (first use in this function)
./src/alter.c:79: error: 'TK_USING' undeclared (first use in this function)
./src/alter.c: In function 'renameTriggerFunc':
./src/alter.c:135: error: 'TK_SPACE' undeclared (first use in this function)
./src/alter.c:148: error: 'TK_DOT' undeclared (first use in this function)
./src/alter.c:148: error: 'TK_ON' undeclared (first use in this function)
./src/alter.c:151: error: 'TK_WHEN' undeclared (first use in this function)
./src/alter.c:151: error: 'TK_FOR' undeclared (first use in this function)
./src/alter.c:151: error: 'TK_BEGIN' undeclared (first use in this function)
./src/alter.c: In function 'reloadTableSchema':
./src/alter.c:246: error: 'OP_DropTrigger' undeclared (first use in this function)
./src/alter.c:251: error: 'OP_DropTable' undeclared (first use in this function)
./src/alter.c:256: error: 'OP_ParseSchema' undeclared (first use in this function)
./src/alter.c: In function 'sqlite3AlterRenameTable':
./src/alter.c:365: error: 'OP_String8' undeclared (first use in this function)
./src/alter.c:366: error: 'OP_VRename' undeclared (first use in this function)
./src/alter.c: In function 'sqlite3AlterFinishAddColumn':
./src/alter.c:478: error: 'TK_NULL' undeclared (first use in this function)
gnumake: *** [alter.lo] Error 1

i have no idea why this keeps happening

Change History (17)

comment:1 Changed 12 years ago by jmpp@…

Description: modified (diff)
Milestone: Port Bugs

comment:2 Changed 12 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to mww@…
Summary: sudo port install php5 +apache2 keeps crashingsqlite3 3.5.4 build failure

Assigning to the maintainer of the failing port (sqlite3).

comment:3 Changed 12 years ago by ingokeck@…

'port install gmake' before installing sqlite3 solved the problem in my case.

comment:4 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: asmarin@… rderuiter@… added

Has duplicate #14322 with some additional info.

comment:5 Changed 12 years ago by reiffert@…

Resolution: fixed
Status: newclosed

port install gmake confirmed as solution by robroy on irc.

comment:6 Changed 11 years ago by jmroot (Joshua Root)

Resolution: fixed
Status: closedreopened

comment:7 Changed 11 years ago by jmroot (Joshua Root)

This is a manifestation of the Leopard environment variable problem.

comment:8 Changed 11 years ago by ryandesign (Ryan Schmidt)

So then r35079 which added gmake as a dependency to sqlite3 should be undone?

comment:9 Changed 11 years ago by ryandesign (Ryan Schmidt)

See also #15478, which says the nawk dependency isn't needed either.

comment:10 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

comment:11 Changed 11 years ago by pilsbier@…

I had the same problem installing subversion. If you install TK before ( sudo port install TK), everything works great. So it's the dependency TK needed by sqlite3.

comment:12 Changed 11 years ago by ryandesign (Ryan Schmidt)

sqlite3 installs fine for me on Leopard PowerPC without tk installed. So are you SURE tk is a dependency? Because the Leopard environment variable issue is such that when you experience it, simply cleaning the affected port and installing it again cures it. So tk is most likely NOT a dependency of sqlite3.

comment:13 in reply to:  description Changed 11 years ago by nicholas.faiz@…

I'm also seeing this problem - it interferes with svn and git installations. Installing gmake and TK didn't help.

Nicholas

Replying to nadeem.shabir@gmail.com:

I've been trying for over a week to simply install php5 +apache2 I'm running Mac OSX 10.5 and have installed Xcode 3.0 plus all the X11 SDK tools etc. as per in the installation guide.

I have used the Macports 1.6.0 installer. and run sudo port -v selfupdate and sync successfully.

However whenever I try to issue the command:

sudo port install php5 +apache2

i'm currently getting the following error:

Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_sqlite3/work/sqlite-3.5.4" && gnumake all " returned error 2
Command output: sed -e s/--VERS--/3.5.4/ ./src/sqlite.h.in | \
	sed -e s/--VERSION-NUMBER--/3005004/ >sqlite3.h
/usr/bin/gcc-4.0 -O2 -o lemon ./tool/lemon.c
cp ./tool/lempar.c .
cp ./src/parse.y .
./lemon  parse.y
mv parse.h parse.h.temp
f ./addopcodes.awk parse.h.temp >parse.h
/bin/sh: f: command not found
gnumake: [parse.c] Error 127 (ignored)
cat parse.h ./src/vdbe.c |  -f ./mkopcodeh.awk >opcodes.h
/bin/sh: -f: command not found
cat: stdout: Broken pipe
gnumake: *** [opcodes.h] Error 127

Error: The following dependencies failed to build: apr-util sqlite3 openssl zlib pcre
Error: Status 1 encountered during processing.
Macintosh-2:/ nadeemshabir$ sudo port install apr-util
Password:
--->  Building sqlite3 with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_databases_sqlite3/work/sqlite-3.5.4" && gnumake all " returned error 2
Command output: ./libtool --mode=compile --tag=CC /usr/bin/gcc-4.0 -O2 -I. -I./src -DNDEBUG   -DSQLITE_THREADSAFE=1 -DSQLITE_THREAD_OVERRIDE_LOCK=-1 -DSQLITE_OMIT_LOAD_EXTENSION=1 -c ./src/alter.c
mkdir .libs
/usr/bin/gcc-4.0 -O2 -I. -I./src -DNDEBUG -DSQLITE_THREADSAFE=1 -DSQLITE_THREAD_OVERRIDE_LOCK=-1 -DSQLITE_OMIT_LOAD_EXTENSION=1 -c ./src/alter.c  -fno-common -DPIC -o .libs/alter.o
./src/alter.c: In function 'renameTableFunc':
./src/alter.c:77: error: 'TK_SPACE' undeclared (first use in this function)
./src/alter.c:77: error: (Each undeclared identifier is reported only once
./src/alter.c:77: error: for each function it appears in.)
./src/alter.c:79: error: 'TK_LP' undeclared (first use in this function)
./src/alter.c:79: error: 'TK_USING' undeclared (first use in this function)
./src/alter.c: In function 'renameTriggerFunc':
./src/alter.c:135: error: 'TK_SPACE' undeclared (first use in this function)
./src/alter.c:148: error: 'TK_DOT' undeclared (first use in this function)
./src/alter.c:148: error: 'TK_ON' undeclared (first use in this function)
./src/alter.c:151: error: 'TK_WHEN' undeclared (first use in this function)
./src/alter.c:151: error: 'TK_FOR' undeclared (first use in this function)
./src/alter.c:151: error: 'TK_BEGIN' undeclared (first use in this function)
./src/alter.c: In function 'reloadTableSchema':
./src/alter.c:246: error: 'OP_DropTrigger' undeclared (first use in this function)
./src/alter.c:251: error: 'OP_DropTable' undeclared (first use in this function)
./src/alter.c:256: error: 'OP_ParseSchema' undeclared (first use in this function)
./src/alter.c: In function 'sqlite3AlterRenameTable':
./src/alter.c:365: error: 'OP_String8' undeclared (first use in this function)
./src/alter.c:366: error: 'OP_VRename' undeclared (first use in this function)
./src/alter.c: In function 'sqlite3AlterFinishAddColumn':
./src/alter.c:478: error: 'TK_NULL' undeclared (first use in this function)
gnumake: *** [alter.lo] Error 1

i have no idea why this keeps happening

comment:14 Changed 11 years ago by nicholas.faiz@…

I ended up cleaning sqlite3 and it installed properly afterward.

comment:15 in reply to:  14 Changed 11 years ago by corycollier@…

Replying to nicholas.faiz@gmail.com:

I ended up cleaning sqlite3 and it installed properly afterward.

A cleanup after the initial install attempt was all I needed as well. For others, I started with a fresh install of MacPorts, and ran the following

sudo port selfupdate (worked fine)

sudo port install gawk (worked fine, but took a while to install dependencies)

sudo port install nawk (worked fine)

sudo port install php5 +apache2 +mysql5 +server (died at the sqlite3 install)

so, the following commands allowed me to get on with my life:

sudo port clean sqlite3

sudo port build sqlite3

after that I was able to complete my original need :

sudo port install php5 +apache2 +mysql5 +server

comment:16 Changed 11 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: reopenedclosed

The gawk and gmake dependencies were removed in r40995. Once again: this is a manifestation of the Leopard environment variable bug, so this is a duplicate of #13930.

comment:17 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.