Opened 13 years ago

Closed 12 years ago

#13954 closed defect (worksforme)

python25 not building, OpenGL problem

Reported by: macosforge@… Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: blb@…
Port: python25

Description

When I try to build the python25 package, the build fails with the error "OpenGL/OpenGL.h: No such file or directory". Which seems likely to be either an autoconf error or a package dependency error.

I just installed ports this evening, and yes I ran selfupdate first, so this isn't a cached file problem.

I'm running on an Intel iMac running 10.4.11.

Attachments (1)

python25-build-err.txt (4.9 KB) - added by macosforge@… 13 years ago.

Download all attachments as: .zip

Change History (9)

Changed 13 years ago by macosforge@…

Attachment: python25-build-err.txt added

comment:1 Changed 13 years ago by afb@…

It should be in /System/Library/Frameworks/OpenGL.framework/Headers/OpenGL.h, so you are probably missing the OpenGL SDK ? (that should have been installed with the default Xcode Tools installation...)

comment:2 Changed 13 years ago by jmpp@…

Milestone: Port Bugs

comment:3 Changed 13 years ago by afb@…

Resolution: worksforme
Status: newclosed

comment:4 Changed 13 years ago by jeb@…

Resolution: worksforme
Status: closedreopened

Looks like I'm getting the same problem, again on 10.4.11. I've got OpenGL SDK installed. The machine has a 'default' Xcode installation on. The error occurs during an upgrade, there is already a copy of python25 installed with macports back in october last year.

---> Fetching python25 ---> Verifying checksum(s) for python25 ---> Extracting python25 ---> Applying patches to python25 ---> Configuring python25 ---> Building python25 with target all Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_lang_python25/work/Python-2.5.2" && make all " returned error 2 Command output: from /System/Library/Frameworks/QuickTime.framework/Headers/MediaHandlers.h:24,

from /System/Library/Frameworks/QuickTime.framework/Headers/QuickTime.h:30, from Include/pymactoolbox.h:11, from Python/mactoolboxglue.c:27:

/System/Library/Frameworks/QuartzCore.framework/Headers/CVOpenGLBuffer.h:84: error: parse error before 'CGLContextObj' In file included from /System/Library/Frameworks/QuartzCore.framework/Headers/CoreVideo.h:29,

from /System/Library/Frameworks/QuickTime.framework/Headers/ImageCompression.h:25, from /System/Library/Frameworks/QuickTime.framework/Headers/Movies.h:51, from /System/Library/Frameworks/QuickTime.framework/Headers/MediaHandlers.h:24, from /System/Library/Frameworks/QuickTime.framework/Headers/QuickTime.h:30, from Include/pymactoolbox.h:11, from Python/mactoolboxglue.c:27:

/System/Library/Frameworks/QuartzCore.framework/Headers/CVOpenGLTexture.h:66: error: parse error before 'CVOpenGLTextureGetTarget' /System/Library/Frameworks/QuartzCore.framework/Headers/CVOpenGLTexture.h:74: error: parse error before 'CVOpenGLTextureGetName' /System/Library/Frameworks/QuartzCore.framework/Headers/CVOpenGLTexture.h:95: error: parse error before 'GLfloat' In file included from /System/Library/Frameworks/QuartzCore.framework/Headers/CoreVideo.h:30,

from /System/Library/Frameworks/QuickTime.framework/Headers/ImageCompression.h:25, from /System/Library/Frameworks/QuickTime.framework/Headers/Movies.h:51, from /System/Library/Frameworks/QuickTime.framework/Headers/MediaHandlers.h:24, from /System/Library/Frameworks/QuickTime.framework/Headers/QuickTime.h:30, from Include/pymactoolbox.h:11, from Python/mactoolboxglue.c:27:

/System/Library/Frameworks/QuartzCore.framework/Headers/CVOpenGLTextureCache.h:62: error: parse error before 'CGLContextObj' In file included from /System/Library/Frameworks/QuickTime.framework/Headers/Movies.h:51,

from /System/Library/Frameworks/QuickTime.framework/Headers/MediaHandlers.h:24, from /System/Library/Frameworks/QuickTime.framework/Headers/QuickTime.h:30, from Include/pymactoolbox.h:11, from Python/mactoolboxglue.c:27:

/System/Library/Frameworks/QuickTime.framework/Headers/ImageCompression.h:12560: error: parse error before 'CGLContextObj' make: * [Python/mactoolboxglue.o] Error 1

comment:5 Changed 13 years ago by jmroot (Joshua Root)

Owner: changed from macports-tickets@… to mww@…
Status: reopenednew

comment:6 Changed 12 years ago by blb@…

Cc: blb@… added
Port: python25 added

The original report, as afb says, appears to be caused by a missing OpenGL SDK. The later report by jeb appears to be causes by some CoreVideo issues, possibly due to an older QuickTime installation?

Is either of these issues still occurring, with Xcode 2.5 and an updated QuickTime, as well as the current python25 port at 2.5.4?

comment:7 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:8 Changed 12 years ago by blb@…

Resolution: worksforme
Status: newclosed

Closing, lack of response.

Note: See TracTickets for help on using tickets.