Opened 13 years ago

Closed 12 years ago

Last modified 11 years ago

#13982 closed defect (worksforme)

tiff 3.8.2 and libpng 1.2.24 cannot find zlib

Reported by: dorfman@… Owned by: waqar@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: ImageMagick zlib Cc: ryandesign (Ryan Schmidt)
Port:

Description (last modified by jmpp@…)

I'm new to MacPorts, but I don't think I'm doing anything unusual. I have a fresh install of MacPorts 1.6, for the sole purpose (at this point) of installing ImageMagick. I am getting a failure indicating that I do not have zlib, although it does appear in 'port installed'.

I have literally done nothing but install MacPorts and then issue the following command:

   sudo port install tiff -macosx imagemagick +q8 +gs +wmf

(which I got from here: http://rmagick.rubyforge.org/install-osx.html)

Here is the error message I'm getting:

Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_tiff/work/tiff-3.8.2" && ./configure --prefix=/opt/local --mandir=/opt/local/share/man --with-docdir=/opt/local/share/doc/tiff-3.8.2 --with-jpeg-include-dir=/opt/local/include --with-jpeg-lib-dir=/opt/local/lib --with-zlib-include-dir=/opt/local/include --with-zlib-lib-dir=/opt/local/lib " returned error 1
Command output: checking for int... yes
checking size of int... 4
checking for long... yes
checking size of long... 4
checking whether time.h and sys/time.h may both be included... yes
checking whether struct tm is in sys/time.h or time.h... time.h
checking for int8... no
checking for int16... no
checking for int32... no
checking for floor... yes
checking for isascii... yes
checking for memmove... yes
checking for memset... yes
checking for mmap... yes
checking for pow... yes
checking for sqrt... yes
checking for strchr... yes
checking for strrchr... yes
checking for strstr... yes
checking for strtol... yes
checking for getopt... yes
checking for strcasecmp... yes
checking for strtoul... yes
checking for lfind... yes
checking native cpu bit order... lsb2msb
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no
checking for _LARGE_FILES value needed for large files... no
checking for inflateEnd in -lz... no
configure: error: Zlib library not found at /opt/local/lib

Error: Status 1 encountered during processing.

Change History (12)

comment:1 Changed 13 years ago by jmpp@…

Description: modified (diff)
Milestone: Port Bugs

comment:2 Changed 13 years ago by ryandesign (Ryan Schmidt)

Owner: changed from macports-tickets@… to waqar@…
Summary: ImageMagick install fails w/ zlib errortiff 3.8.2 install fails w/ zlib error

Based on your output, the port experiencing the zlib problem is tiff, not ImageMagick. Assigning to maintainer of tiff.

comment:3 Changed 13 years ago by dorfman@…

The problem appears to be bigger than just TIFF - Here, the same thing appears to happen when I omit the TIFF part of the install command:

dagger% sudo port install imagemagick +q8 +gs +wmf Password: ---> Fetching bzip2 ---> Attempting to fetch bzip2-1.0.4.tar.gz from http://www.bzip.org/1.0.4/ ---> Verifying checksum(s) for bzip2 ---> Extracting bzip2 ---> Applying patches to bzip2 ---> Configuring bzip2 ---> Building bzip2 with target all ---> Staging bzip2 into destroot ---> Installing bzip2 1.0.4_1 ---> Activating bzip2 1.0.4_1 ---> Cleaning bzip2 ---> Fetching expat ---> Attempting to fetch expat-2.0.1.tar.gz from http://downloads.sourceforge.net/expat ---> Verifying checksum(s) for expat ---> Extracting expat ---> Configuring expat ---> Building expat with target all ---> Staging expat into destroot ---> Installing expat 2.0.1_0 ---> Activating expat 2.0.1_0 ---> Cleaning expat ---> Fetching freetype ---> Attempting to fetch freetype-2.3.5.tar.bz2 from http://download.savannah.gnu.org/releases/freetype/ ---> Verifying checksum(s) for freetype ---> Extracting freetype ---> Applying patches to freetype ---> Configuring freetype ---> Building freetype with target all ---> Staging freetype into destroot ---> Installing freetype 2.3.5_1 ---> Activating freetype 2.3.5_1 ---> Cleaning freetype ---> Fetching fontconfig ---> Attempting to fetch fontconfig-2.5.0.tar.gz from http://fontconfig.org/release/ ---> Verifying checksum(s) for fontconfig ---> Extracting fontconfig ---> Configuring fontconfig ---> Building fontconfig with target all ---> Staging fontconfig into destroot ---> Installing fontconfig 2.5.0_0+macosx ---> Activating fontconfig 2.5.0_0+macosx ---> Cleaning fontconfig ---> Fetching ghostscript ---> Attempting to fetch ghostscript-8.61.tar.gz from http://downloads.sourceforge.net/ghostscript ---> Attempting to fetch ghostscript-fonts-std-8.11.tar.gz from http://downloads.sourceforge.net/gs-fonts ---> Attempting to fetch ghostscript-fonts-other-6.0.tar.gz from http://downloads.sourceforge.net/gs-fonts ---> Verifying checksum(s) for ghostscript ---> Extracting ghostscript ---> Applying patches to ghostscript ---> Configuring ghostscript ---> Building ghostscript ---> Staging ghostscript into destroot Warning: ghostscript requests to install files outside the common directory structure! ---> Installing ghostscript 8.61_0 ---> Activating ghostscript 8.61_0 ---> Cleaning ghostscript ---> Fetching libpng ---> Attempting to fetch libpng-1.2.24.tar.bz2 from http://downloads.sourceforge.net/libpng ---> Verifying checksum(s) for libpng ---> Extracting libpng ---> Configuring libpng Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_libpng/work/libpng-1.2.24" && ./configure --prefix=/opt/local " returned error 1 Command output: checking whether to build shared libraries... yes checking whether to build static libraries... yes configure: creating libtool appending configuration tag "CXX" to libtool checking for ld used by /usr/bin/g++-4.0... /usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld checking if the linker (/usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld) is GNU ld... no checking whether the /usr/bin/g++-4.0 linker (/usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld) supports shared libraries... yes checking for /usr/bin/g++-4.0 option to produce PIC... -fno-common checking if /usr/bin/g++-4.0 PIC flag -fno-common works... yes checking if /usr/bin/g++-4.0 static flag -static works... no checking if /usr/bin/g++-4.0 supports -c -o file.o... yes checking whether the /usr/bin/g++-4.0 linker (/usr/libexec/gcc/i686-apple-darwin8/4.0.1/ld) supports shared libraries... yes checking dynamic linker characteristics... darwin8.11.1 dyld checking how to hardcode library paths into programs... immediate appending configuration tag "F77" to libtool checking for ANSI C header files... (cached) yes checking malloc.h usability... no checking malloc.h presence... no checking for malloc.h... no checking for stdlib.h... (cached) yes checking for string.h... (cached) yes checking for strings.h... (cached) yes checking for an ANSI C-conforming const... yes checking for size_t... yes checking whether struct tm is in sys/time.h or time.h... time.h checking for working strtod... yes checking for memset... yes checking for pow... yes checking for zlibVersion in -lz... no configure: error: zlib not installed

Error: The following dependencies failed to build: libpng libwmf libxml2 pkgconfig tiff Error: Status 1 encountered during processing. dagger% sudo port list active Password: bzip2 @1.0.4 archivers/bzip2 expat @2.0.1 textproc/expat fontconfig @2.5.0 graphics/fontconfig freetype @2.3.5 print/freetype gettext @0.17 devel/gettext ghostscript @8.61 print/ghostscript jpeg @6b graphics/jpeg libiconv @1.12 textproc/libiconv man2html @3.0.1 textproc/man2html openssl @0.9.8g devel/openssl wget @1.10.2 net/wget zlib @1.2.3 archivers/zlib

comment:4 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added

Please remember the WikiFormatting rules when pasting in literal output.

So we have both tiff and libpng failing to find zlib. Is the zlib port installed? (What does port installed zlib say?) If it is installed, try rebuilding it. (sudo port -ncuf upgrade zlib) If it is not installed, install it (sudo port install zlib). Then try again and let us know what happens.

comment:5 Changed 13 years ago by ryandesign (Ryan Schmidt)

Summary: tiff 3.8.2 install fails w/ zlib errortiff 3.8.2 and libpng 1.2.24 cannot find zlib

Sorry, I see in your output now that you do have zlib installed. Still, try reinstalling it. Be sure to "sudo port selfupdate" first to make sure you're up to date.

FYI: "port list active" doesn't do what you think it does. You want "port installed active" instead.

comment:6 Changed 12 years ago by ryandesign (Ryan Schmidt)

What is the status of this issue?

comment:7 Changed 12 years ago by dorfman@…

Sorry, I was traveling when the last response came in, and lost track of it by the time I got back.

Although the rebuild command given didn't work due to complications relating from further efforts on my part to solve the problem, I was able to completely remove zlib and reinstall it from scratch. I did run the selfupdate first, and it indicated no changes were needed.

After manually installing zlib the original command from the beginning of this ticked now works. It seems to me there must still be a bug somewhere, but my system no longer reproduces it.

Also, I should mention that since I originally opened this ticket, I have upgraded to Leopard. It may be that the problem is 10.4 specific.

comment:8 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: worksforme
Status: newclosed

I use 10.4 on my primary port development machine and can't reproduce this either. I'm going to close this. If anyone can reproduce this and believes a change needs to be made in MacPorts, please re-open.

comment:9 in reply to:  8 ; Changed 12 years ago by woevans@…

Replying to ryandesign@…:

I use 10.4 on my primary port development machine and can't reproduce this either. I'm going to close this. If anyone can reproduce this and believes a change needs to be made in MacPorts, please re-open.

Reopening based on comment accompanying the previous change in status to "closed". FYI, I'm running OSX 10.5.6. Here's the output:

bash-3.2# port installed active
The following ports are currently installed:
  cgdb @0.6.4_0 (active)
  expat @2.0.1_0 (active)
  gettext @0.17_3 (active)
  gperf @3.0.3_0 (active)
  jpeg @6b_3+universal (active)
  libiconv @1.12_0 (active)
  libpng @1.2.34_0 (active)
  lynx @2.8.6rel.5_1+ssl (active)
  ncurses @5.7_0 (active)
  ncursesw @5.7_0 (active)
  openssl @0.9.8i_0 (active)
  readline @5.2.012_1 (active)
  wget @1.11.4_0 (active)
  zlib @1.2.3_2 (active)

bash-3.2# port install tiff +universal
--->  Fetching tiff
--->  Verifying checksum(s) for tiff
--->  Extracting tiff
--->  Applying patches to tiff
--->  Configuring tiff
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_tiff/work/tiff-3.8.2" && ./configure --prefix=/opt/local --mandir=/opt/local/share/man --with-docdir=/opt/local/share/doc/tiff-3.8.2 --with-jpeg-include-dir=/opt/local/include --with-jpeg-lib-dir=/opt/local/lib --with-zlib-include-dir=/opt/local/include --with-zlib-lib-dir=/opt/local/lib --with-apple-opengl-framework --disable-dependency-tracking " returned error 1
Command output: checking for int... yes
checking size of int... 4
checking for long... yes
checking size of long... 4
checking whether time.h and sys/time.h may both be included... yes
checking whether struct tm is in sys/time.h or time.h... time.h
checking for int8... no
checking for int16... no
checking for int32... no
checking for floor... yes
checking for isascii... yes
checking for memmove... yes
checking for memset... yes
checking for mmap... yes
checking for pow... yes
checking for sqrt... yes
checking for strchr... yes
checking for strrchr... yes
checking for strstr... yes
checking for strtol... yes
checking for getopt... yes
checking for strcasecmp... yes
checking for strtoul... yes
checking for lfind... yes
checking native cpu bit order... lsb2msb
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... no
checking for _LARGE_FILES value needed for large files... no
checking for inflateEnd in -lz... no
configure: error: Zlib library not found at /opt/local/lib


comment:10 in reply to:  9 Changed 12 years ago by woevans@…

Replying to woevans@…:

Correction - I do not have sufficient privileges to reopen. Status remains "closed" - though I'd reopen if I could.

comment:11 in reply to:  9 Changed 12 years ago by blb@…

Replying to woevans@…:

Reopening based on comment accompanying the previous change in status to "closed". FYI, I'm running OSX 10.5.6. Here's the output:

...

zlib @1.2.3_2 (active)

...

bash-3.2# port install tiff +universal

You're trying to install tiff +universal but your zlib is not currently +universal, which is going to fail. You need to make sure all of tiff's dependencies are universal if you want it universal as well. MacPorts can't currently depend on variants, see #126.

comment:12 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.