Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#13991 closed defect (duplicate)

Mercurial doesn't build on Leopard

Reported by: ndw@… Owned by: deric@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: leopard mac osx mercurial Cc: raimue (Rainer Müller)
Port:

Description (last modified by jmpp@…)

$ sudo port install mercurial
...
--->  Attempting to fetch mercurial-0.9.5.tar.gz from http://www.selenic.com/mercurial/release/
--->  Verifying checksum(s) for mercurial
--->  Extracting mercurial
--->  Configuring mercurial
--->  Building mercurial with target build
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_mercurial/work/mercurial-0.9.5" && /opt/local/bin/python2.4 setup.py build " returned error 1
Command output: copying hgext/graphlog.py -> build/lib.macosx-10.3-i386-2.4/hgext
copying hgext/hbisect.py -> build/lib.macosx-10.3-i386-2.4/hgext
copying hgext/hgk.py -> build/lib.macosx-10.3-i386-2.4/hgext
copying hgext/imerge.py -> build/lib.macosx-10.3-i386-2.4/hgext
copying hgext/interhg.py -> build/lib.macosx-10.3-i386-2.4/hgext
copying hgext/mq.py -> build/lib.macosx-10.3-i386-2.4/hgext
copying hgext/notify.py -> build/lib.macosx-10.3-i386-2.4/hgext
copying hgext/parentrevspec.py -> build/lib.macosx-10.3-i386-2.4/hgext
copying hgext/patchbomb.py -> build/lib.macosx-10.3-i386-2.4/hgext
copying hgext/purge.py -> build/lib.macosx-10.3-i386-2.4/hgext
copying hgext/record.py -> build/lib.macosx-10.3-i386-2.4/hgext
copying hgext/transplant.py -> build/lib.macosx-10.3-i386-2.4/hgext
copying hgext/win32text.py -> build/lib.macosx-10.3-i386-2.4/hgext
creating build/lib.macosx-10.3-i386-2.4/hgext/convert
copying hgext/convert/__init__.py -> build/lib.macosx-10.3-i386-2.4/hgext/convert
copying hgext/convert/common.py -> build/lib.macosx-10.3-i386-2.4/hgext/convert
copying hgext/convert/cvs.py -> build/lib.macosx-10.3-i386-2.4/hgext/convert
copying hgext/convert/darcs.py -> build/lib.macosx-10.3-i386-2.4/hgext/convert
copying hgext/convert/filemap.py -> build/lib.macosx-10.3-i386-2.4/hgext/convert
copying hgext/convert/git.py -> build/lib.macosx-10.3-i386-2.4/hgext/convert
copying hgext/convert/hg.py -> build/lib.macosx-10.3-i386-2.4/hgext/convert
copying hgext/convert/subversion.py -> build/lib.macosx-10.3-i386-2.4/hgext/convert
copying hgext/convert/transport.py -> build/lib.macosx-10.3-i386-2.4/hgext/convert
running build_ext
building 'mercurial.mpatch' extension
creating build/temp.macosx-10.3-i386-2.4
creating build/temp.macosx-10.3-i386-2.4/mercurial
-fno-strict-aliasing -Wno-long-double -no-cpp-precomp -fno-common -fno-common -dynamic -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -I/opt/local/Library/Frameworks/Python.framework/Versions/2.4/include/python2.4 -c mercurial/mpatch.c -o build/temp.macosx-10.3-i386-2.4/mercurial/mpatch.o
unable to execute -fno-strict-aliasing: No such file or directory
error: command '-fno-strict-aliasing' failed with exit status 1

Error: Status 1 encountered during processing.

Change History (8)

comment:1 Changed 14 years ago by jmpp@…

Description: modified (diff)
Milestone: Port Bugs

comment:2 Changed 14 years ago by raimue (Rainer Müller)

Cc: raimue@… added
Owner: changed from macports-tickets@… to deric@…

It works for me on Leopard. Do you have the latest Xcode installed?

Assigning to maintainer.

comment:3 Changed 14 years ago by zioproto@…

I have the latest Xcode installed (the one released on 26th October 2007) and Mercurial does not build to me on Leopard on a Mac Mini G4.

comment:4 Changed 14 years ago by raimue (Rainer Müller)

Ok, I tested on Intel. But as you are on ppc I am wondering why the build log mentions i386 that often... Maybe there is something broken in the mercurial configure scripts?

comment:5 Changed 14 years ago by macosforge@…

I have the same issue on my MBP running osx v10.5.1.

$ gcc --version
i686-apple-darwin9-gcc-4.0.1 (GCC) 4.0.1 (Apple Inc. build 5465)

Thanks for any help.

comment:6 Changed 14 years ago by macosforge@…

Have succeeded after some housekeeping:

sudo port sync
sudo port selfupdate
sudo port upgrade installed
sudo port install mercurial

comment:7 Changed 14 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #13930.

comment:8 Changed 13 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.