Opened 13 years ago

Closed 12 years ago

Last modified 11 years ago

#14014 closed defect (duplicate)

jhead staging fails

Reported by: bretthoerner@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: jhead Cc: simon@…, jmroot (Joshua Root)
Port:

Description

sudo port -v install jhead

---

---> Fetching jhead ---> jhead-2.7.tar.gz doesn't seem to exist in /opt/local/var/macports/distfiles/jhead ---> Attempting to fetch jhead-2.7.tar.gz from http://www.sentex.net/~mwandel/jhead/

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

100 58957 100 58957 0 0 56577 0 0:00:01 0:00:01 --:--:-- 91605 ---> Verifying checksum(s) for jhead ---> Checksumming jhead-2.7.tar.gz ---> Extracting jhead ---> Extracting jhead-2.7.tar.gz ---> Configuring jhead ---> Building jhead with target jhead O3 -Wall -c jhead.c -o jhead.o make: O3: Command not found make: [jhead.o] Error 127 (ignored) O3 -Wall -c jpgfile.c -o jpgfile.o make: O3: Command not found make: [jpgfile.o] Error 127 (ignored) O3 -Wall -c exif.c -o exif.o make: O3: Command not found make: [exif.o] Error 127 (ignored) O3 -Wall -c gpsinfo.c -o gpsinfo.o make: O3: Command not found make: [gpsinfo.o] Error 127 (ignored) O3 -Wall -c makernote.c -o makernote.o make: O3: Command not found make: [makernote.o] Error 127 (ignored) o jhead ./jhead.o ./jpgfile.o ./exif.o ./gpsinfo.o ./makernote.o -lm make: o: Command not found make: [jhead] Error 127 (ignored) ---> Staging jhead into destroot . changed

gid expected 0 found 80 modified

./usr missing (created) . missing (directory not created: File exists) ./Applications missing (created) ./Developer missing (created) ./Library missing (created) . changed

gid expected 80 found 0 modified

./bin missing (created) ./etc missing (created) ./include missing (created) ./lib missing (created) ./libexec missing (created) ./sbin missing (created) ./share missing (created) ./share/info missing (created) ./share/man missing (created) ./share/man/cat1 missing (created) ./share/man/cat2 missing (created) ./share/man/cat3 missing (created) ./share/man/cat4 missing (created) ./share/man/cat5 missing (created) ./share/man/cat6 missing (created) ./share/man/cat7 missing (created) ./share/man/cat8 missing (created) ./share/man/cat9 missing (created) ./share/man/catl missing (created) ./share/man/catn missing (created) ./share/man/man1 missing (created) ./share/man/man2 missing (created) ./share/man/man3 missing (created) ./share/man/man4 missing (created) ./share/man/man5 missing (created) ./share/man/man6 missing (created) ./share/man/man7 missing (created) ./share/man/man8 missing (created) ./share/man/man9 missing (created) ./share/man/manl missing (created) ./share/man/mann missing (created) ./share/nls missing (created) ./share/nls/C missing (created) ./share/nls/af_ZA.ISO8859-1 missing (created) ./share/nls/af_ZA.ISO8859-15 missing (created) ./share/nls/bg_BG.CP1251 missing (created) ./share/nls/cs_CZ.ISO8859-2 missing (created) ./share/nls/da_DK.ISO8859-1 missing (created) ./share/nls/da_DK.ISO8859-15 missing (created) ./share/nls/de_AT.ISO8859-1 missing (created) ./share/nls/de_AT.ISO8859-15 missing (created) ./share/nls/de_CH.ISO8859-1 missing (created) ./share/nls/de_CH.ISO8859-15 missing (created) ./share/nls/de_DE.ISO8859-1 missing (created) ./share/nls/de_DE.ISO8859-15 missing (created) ./share/nls/el_GR.ISO8859-7 missing (created) ./share/nls/en_AU.ISO8859-1 missing (created) ./share/nls/en_AU.ISO8859-15 missing (created) ./share/nls/en_AU.US-ASCII missing (created) ./share/nls/en_CA.ISO8859-1 missing (created) ./share/nls/en_CA.ISO8859-15 missing (created) ./share/nls/en_CA.US-ASCII missing (created) ./share/nls/en_GB.ISO8859-1 missing (created) ./share/nls/en_GB.ISO8859-15 missing (created) ./share/nls/en_GB.US-ASCII missing (created) ./share/nls/en_NZ.ISO8859-1 missing (created) ./share/nls/en_NZ.ISO8859-15 missing (created) ./share/nls/en_NZ.US-ASCII missing (created) ./share/nls/en_US.ISO8859-1 missing (created) ./share/nls/en_US.ISO8859-15 missing (created) ./share/nls/es_ES.ISO8859-1 missing (created) ./share/nls/es_ES.ISO8859-15 missing (created) ./share/nls/et_EE.ISO8859-15 missing (created) ./share/nls/fi_FI.ISO8859-1 missing (created) ./share/nls/fi_FI.ISO8859-15 missing (created) ./share/nls/fr_BE.ISO8859-1 missing (created) ./share/nls/fr_BE.ISO8859-15 missing (created) ./share/nls/fr_CA.ISO8859-1 missing (created) ./share/nls/fr_CA.ISO8859-15 missing (created) ./share/nls/fr_CH.ISO8859-1 missing (created) ./share/nls/fr_CH.ISO8859-15 missing (created) ./share/nls/fr_FR.ISO8859-1 missing (created) ./share/nls/fr_FR.ISO8859-15 missing (created) ./share/nls/hi_IN.ISCII-DEV missing (created) ./share/nls/hr_HR.ISO8859-2 missing (created) ./share/nls/hu_HU.ISO8859-2 missing (created) ./share/nls/is_IS.ISO8859-1 missing (created) ./share/nls/is_IS.ISO8859-15 missing (created) ./share/nls/it_CH.ISO8859-1 missing (created) ./share/nls/it_CH.ISO8859-15 missing (created) ./share/nls/it_IT.ISO8859-1 missing (created) ./share/nls/it_IT.ISO8859-15 missing (created) ./share/nls/ja_JP.SJIS missing (created) ./share/nls/ja_JP.eucJP missing (created) ./share/nls/ko_KR.eucKR missing (created) ./share/nls/la_LN.ISO8859-1 missing (created) ./share/nls/la_LN.ISO8859-15 missing (created) ./share/nls/la_LN.ISO8859-2 missing (created) ./share/nls/la_LN.ISO8859-4 missing (created) ./share/nls/la_LN.US-ASCII missing (created) ./share/nls/lt_LT.ISO8859-4 missing (created) ./share/nls/nl_BE.ISO8859-1 missing (created) ./share/nls/nl_BE.ISO8859-15 missing (created) ./share/nls/nl_NL.ISO8859-1 missing (created) ./share/nls/nl_NL.ISO8859-15 missing (created) ./share/nls/no_NO.ISO8859-1 missing (created) ./share/nls/no_NO.ISO8859-15 missing (created) ./share/nls/pl_PL.ISO8859-2 missing (created) ./share/nls/pt_BR.ISO8859-1 missing (created) ./share/nls/pt_PT.ISO8859-1 missing (created) ./share/nls/pt_PT.ISO8859-15 missing (created) ./share/nls/ro_RO.ISO8859-2 missing (created) ./share/nls/ru_RU.CP866 missing (created) ./share/nls/ru_RU.ISO8859-5 missing (created) ./share/nls/ru_RU.KOI8-R missing (created) ./share/nls/sk_SK.ISO8859-2 missing (created) ./share/nls/sl_SI.ISO8859-2 missing (created) ./share/nls/sv_SE.ISO8859-1 missing (created) ./share/nls/sv_SE.ISO8859-15 missing (created) ./share/nls/tr_TR.ISO8859-9 missing (created) ./share/nls/uk_UA.ISO8859-5 missing (created) ./share/nls/uk_UA.KOI8-U missing (created) ./share/nls/zh_CN.eucCN missing (created) ./share/nls/zh_TW.Big5 missing (created) ./share/skel missing (created) ./src missing (created) ./var missing (created) ./var/macports missing (created) ./var/macports/distfiles missing (created) ./var/macports/receipts missing (created) ./var/macports/registry missing (created) ./www missing (created) Error: Target org.macports.destroot returned: xinstall: Cannot stat: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_jhead/work/jhead-2.7/jhead, No such file or directory Warning: the following items did not execute (for jhead): org.macports.activate org.macports.destroot org.macports.install Error: Status 1 encountered during processing.

Change History (9)

comment:1 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: simon@… added

Cc'ing maintainer of jhead.

comment:2 Changed 13 years ago by jmroot (Joshua Root)

Cc: jmr@… added

It installs OK for me. Run "sudo port clean jhead" and try again? If that doesn't work, please tell us your OS version, CPU architecture, and XCode version.

comment:3 Changed 12 years ago by markmentovai (Mark Mentovai)

This fails when ${CC} is set in the environment.

comment:4 in reply to:  3 ; Changed 12 years ago by jmroot (Joshua Root)

Replying to mark@moxienet.com:

This fails when ${CC} is set in the environment.

Do you mean that it fails if CC is listed in extra_env, or that MacPorts is not correctly sanitising the environment?

comment:5 in reply to:  4 Changed 12 years ago by markmentovai (Mark Mentovai)

Replying to jmr@macports.org:

Do you mean that it fails if CC is listed in extra_env, or that MacPorts is not correctly sanitising the environment?

I mean that when CC is set in the environment, "sudo port install jhead" doesn't work, and when CC is unset, it does work. I don't know what's getting in the way, because a vanilla build of jhead (not supervised by MacPorts) works regardless of whether ${CC} is set.

I noticed that the portfile specifies:

build.args CFLAGS=-03

(that's "dash zero three")

I don't know if that's related to this problem, but it's wrong. I suspect -O3 ("dash capital-O three") was intended.

comment:6 Changed 12 years ago by markmentovai (Mark Mentovai)

This is #13930, but build.args should still be fixed in the portfile (comment 4).

comment:7 Changed 12 years ago by jmroot (Joshua Root)

Fixed the CFLAGS in r38142.

comment:8 Changed 12 years ago by jmroot (Joshua Root)

Resolution: duplicate
Status: newclosed

Duplicate of #13930 per comment:6.

comment:9 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.