Opened 13 years ago

Closed 12 years ago

Last modified 11 years ago

#14152 closed defect (invalid)

No man pages on Swedish Mac OS X 10.5.1

Reported by: mea@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.6.0
Keywords: Cc:
Port:

Description

All I get when trying to access a man page from something installed with port is:

"Cannot open the message catalog "man" for locale "sv_SE.UTF-8" (NLSPATH="<none>")

No manual entry for"

whatever app I am trying to get the man page for

Change History (5)

comment:1 Changed 13 years ago by jmpp@…

Component: portsbase
Milestone: MacPorts base bugs

Temporarily filing this as a base bug, where it should be if the problem is indeed ours and spans multiple ports. All in all, I'm not sure if there's something we can do about this problem:

  1. The ports providing localized man pages or not is not something that is up to us is any way, we are just a sort of "distributor point" of the packaged software and not the vendor.
  2. Maybe there's some whatis(1) or other type of magic that we could do from within port(1) to serve the installed man pages regardless of the locale...? I wouldn't bet on it, though...

Suggestions welcomed!

-jmpp

comment:2 Changed 13 years ago by neer.target@…

Had the same problem, but it seems adding the MANPATH variable to the environment fixed it...

/neer

comment:3 Changed 12 years ago by tobypeterson

Milestone: MacPorts base bugsMacPorts Future

Milestone MacPorts base bugs deleted

comment:4 Changed 12 years ago by tobypeterson

Resolution: invalid
Status: newclosed

This is <rdar://problem/5291011>, not a MacPorts bug.

comment:5 Changed 11 years ago by jmroot (Joshua Root)

Milestone: MacPorts Future
Note: See TracTickets for help on using tickets.