Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#14242 closed defect (duplicate)

lftp-3.6.1 high cpu usage on Leopard

Reported by: yunzheng.hu@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: ftp poll leopard cpu usage deployment target Cc:
Port:

Description

When compiling and running lftp on Leopard it causes the 'known' 100% cpu usage. This however is not entirely related to the 'poll' bug, like in Tiger.

I have attached a patch for configure that detects the broken poll on Leopard as well. And a modification to the Portfile that sets the MACOSX_DEPLOYMENT_TARGET=10.4, which fixes the cpu usage issue on Leopard.

references to the bug in Tiger:
http://www.mail-archive.com/lftp%40uniyar.ac.ru/msg02101.html

same patch but for Leopard (but does not entirely fix the problem):
http://www.mail-archive.com/lftp@uniyar.ac.ru/msg03091.html

Attachments (2)

patch-configure (631 bytes) - added by yunzheng.hu@… 13 years ago.
patch for configure that also applies to Darwin 9 instead of only Darwin 8
Portfile (2.7 KB) - added by yunzheng.hu@… 13 years ago.
Modified Portfile to include configure patch, and took maintainer ship of this port. (current nomainter)

Download all attachments as: .zip

Change History (4)

Changed 13 years ago by yunzheng.hu@…

Attachment: patch-configure added

patch for configure that also applies to Darwin 9 instead of only Darwin 8

Changed 13 years ago by yunzheng.hu@…

Attachment: Portfile added

Modified Portfile to include configure patch, and took maintainer ship of this port. (current nomainter)

comment:1 Changed 13 years ago by raimue (Rainer Müller)

Resolution: duplicate
Status: newclosed

Duplicate of #13259.

comment:2 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.