Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#14326 closed defect (invalid)

macports on xserve cluster

Reported by: pawel.matykiewicz@… Owned by: jmpp@…
Priority: Normal Milestone:
Component: guide Version: 1.6.0
Keywords: xserve cluster Cc:
Port:

Description (last modified by raimue (Rainer Müller))

I could not find information how/if macports will work on a cluster?

It means that you install macports on a head node shared drive and its available through mounting the shared drive on compute nodes ?

What can be done now?

Change History (4)

comment:1 Changed 13 years ago by jmpp@…

Component: baseguide
Owner: changed from macports-tickets@… to markd@…
Priority: HighNormal

We don't have a "cluster" specific configuration as such, but there certainly are ways in which MacPorts can be built in a more confined fashion so that it becomes share'able across a network through a single volume. Off the top of my head, you need to pass a custom --with-tclpackage flag to the configure script so that the macports1.0 package also gets installed into your confined location, presumably within your installation ${prefix}, and not onto the default /Library/Tcl path.

Don't recall at the moment if there are other things that you need to relocate off their default paths to fully confine your MacPorts installation, so I'll assign this ticket to myself so that I can write something up for the guide or Wiki later for public consumption.

-jmpp

comment:2 Changed 13 years ago by jmpp@…

Owner: changed from markd@… to jmpp@…

comment:3 Changed 12 years ago by raimue (Rainer Müller)

Description: modified (diff)
Resolution: invalid
Status: newclosed

comment:4 Changed 12 years ago by (none)

Milestone: Website & Documentation

Milestone Website & Documentation deleted

Note: See TracTickets for help on using tickets.